2 schede di rete configurate per internet

4 risposte [Ultimo messaggio]
Ritratto di neverdar
neverdar
(Monster)
Offline
Monster
Iscritto: 09/02/2005
Messaggi: 308

Salve
vi descrivo il mio problema
Faccio parte di una rete lan di un'azienda..
la mia macchina ha 2 schede di rete una wireless un'altra ethernet integrata sulla scheda madre.
la mia postazione ha suse linux 9.2 e le schede di rete funzionano entrambe su di essa correttamente.
entrambe le schede sono configurate per accedere alla rete, ma vorrei che il traffico internet sia instradato sulla scheda wireless ath0 dato che la scheda eth0 mi aggiunge latenza perche' e' connesso ad un hub ed un successivo router.
NB non posso eliminare la scheda eth0 per problemi legati all'accesso di alcune risorse che risulterebbero mascherate dal router se accedessi con ath0 (gusto avete ragione si puo' usare il nat o aprire un virtual service sul router ma non sono io l'amministratore di rete )
Qualcuno puo' dirmi come indicare al mio sistema che il traffico su internet instradalo sulla ath0 mentre quello relativo alla rete lan sul eth0 ?

grazie

concordo con tutte le persone che dico che la rete che uso io e' configurata male

SPECTRUM IEEE LA POTENZA E' NULLA SENZA TEORIA DEL CONTROLLO

Ritratto di ziokiwi
ziokiwi
(Junior)
Offline
Junior
Iscritto: 25/03/2005
Messaggi: 6

Ciao, sono lo Zio Kiwi
Scusa la domanda, forse banale, ma se tutte e due le schede di rete sono configurate per la connessione ad internet non ti basterebbe togliere da una delle due la possibilità di uscire sul web?

Ritratto di hobbes
hobbes
(Junior)
Offline
Junior
Iscritto: 23/02/2005
Messaggi: 15

Ciao,
Secondo me basta configurare in maniera corretta la tabella di routing. Si configura con il comando "route".
Devi mettere che per gli ip della Lan usi eth0 per tutti gli altri ath0.
Se ti serve una mano devi mettere un post con l'ip del router della lan . O magari tutto l'output del comando route.

Hobbes

Ritratto di Federico
Federico
(Monster)
Offline
Monster
Iscritto: 29/12/2004
Messaggi: 236

Quote:

hobbes ha scritto:
Ciao,
Secondo me basta configurare in maniera corretta la tabella di routing. Si configura con il comando "route".
Devi mettere che per gli ip della Lan usi eth0 per tutti gli altri ath0.
Se ti serve una mano devi mettere un post con l'ip del router della lan . O magari tutto l'output del comando route.

Hobbes

Forse vado un po OT ma visto che qui si parla di suse non sarebbe meglio consigliare l'utilizzo del modulo per il routing di yast ? Non che la tua proposta sia sbagliata ma penso che uno dei punti di forza principali di questa distro si proprio yast e "snobbarlo" così mi rende triste Sad

Ritratto di hobbes
hobbes
(Junior)
Offline
Junior
Iscritto: 23/02/2005
Messaggi: 15

I moduli si yast sono uno sballo, li uso molto, anzi uso Suse proprio per quelli, pero' spesso ho notato che sono comodi per una configurazione di base, proprio per la loro semplicita' d'uso tralasciano certe parti. In questo caso mi sembrava meglio agire da linea di comando.

Non voglio assolutamente criticare i moduli yast, ripeto che sono uno sballo!

Big Grin