Passaggio da 11.4 a 12.1 con repo tumbleweed

59 risposte [Ultimo messaggio]
Ritratto di aksaf
aksaf
(Guru)
Offline
Guru
Iscritto: 08/03/2011
Messaggi: 957

Guardando un po' meglio a me sembra strano che niente fornisca libstdc++46. Dopo che ti sei accertato di avere aggiornato i repo, o di averli segnati per l'autoaggiornamento, prova a controllare:

zypper se libstdc++*
zypper what-provides libstdc++46

Ritratto di maxg1972
maxg1972
(Geek)
Offline
Geek
Iscritto: 24/06/2009
Messaggi: 62

Stasera ci provo...

Ritratto di Grinch
Grinch
(Guru)
Offline
Guru
Iscritto: 05/12/2011
Messaggi: 887

aksaf ha scritto:

Guardando un po' meglio a me sembra strano che niente fornisca libstdc++46. Dopo che ti sei accertato di avere aggiornato i repo, o di averli segnati per l'autoaggiornamento, prova a controllare:

Il problema non è libstdc++46 ma libstdc++45 che deve essere disinstallato in quanto sulla 12.1 non c'è più , e va in conflitto con quello nuovo.

Sicuramente usciranno nuove dipendenze , perchè molti pacchetti vecchi devono essere disinstallati Party

Ritratto di maxg1972
maxg1972
(Geek)
Offline
Geek
Iscritto: 24/06/2009
Messaggi: 62

Ho disinstallato alcune vecchie versioni di VIrtualBox (erano ancora presenti nel sistema) ed ho lasciato solo la V4.1.8; ho rimosso alcuni altri pacchetti installati che non utilizzavo più (tra cui skype).

Quindi ho provato a fare l'installazione con
zypper dup --from Tumbleweed

ed ho ottenuto i seguenti problemi di dipendenza:

4 Problemi:
Problema: libqt4-32bit-4.8.1-3.1.x86_64 richiede libstdc++.so.6(GLIBCXX_3.4.15), ma non è possibile fornire questa richiesta
Problema: VirtualBox-4.1-4.1.8_75467_openSUSE114-1.x86_64 richiede libQtCore.so.4()(64bit), ma non è possibile fornire questa richiesta
Problema: libsnmp25-5.6.1-4.5.1.x86_64 richiede librpm.so.1()(64bit), ma non è possibile fornire questa richiesta
Problema: kernel-desktop-base-3.3.5-23.1.x86_64 in conflitto con kernel-desktop = 3.3.5-23.1 fornito da kernel-desktop-3.3.5-23.1.x86_64

Problema 1
Problema: libqt4-32bit-4.8.1-3.1.x86_64 richiede libstdc++.so.6(GLIBCXX_3.4.15), ma non è possibile fornire questa richiesta
  provider non installabili: libstdc++46-4.6.2_20111026-1.1.4.i586[openSUSE_Current_OSS]
                   libstdc++46-32bit-4.6.2_20111026-1.1.4.x86_64[openSUSE_Current_OSS]
 Soluzione 1: Le seguenti azioni verranno eseguite:
  Installa libstdc++46-4.6.2_20111026-1.1.4.i586 anche se l'architettura viene modificata
  Disinstallazione di mozilla-xulrunner20-2.0.1-0.2.2.x86_64
  Disinstallazione di mozilla-xulrunner20-gnome-2.0.1-0.2.2.x86_64
  Disinstallazione di mozilla-xulrunner20-translations-common-2.0.1-0.2.2.x86_64
  ...
 Soluzione 2: Disinstallazione di libqt4-32bit-4.7.4-22.1.x86_64
 Soluzione 3: Disinstallazione di libstdc++45-32bit-4.5.1_20101208-9.8.x86_64
 Soluzione 4: mantieni l'obsoleto libqt4-32bit-4.7.4-22.1.x86_64
 Soluzione 5: Danneggiare libqt4-32bit ignorando alcune delle sue dipendenze

Ho risposto 3 come consigliatomi da Grinch

Problema 2

Problema: VirtualBox-4.1-4.1.8_75467_openSUSE114-1.x86_64 richiede libQtCore.so.4()(64bit), ma non è possibile fornire questa richiesta
  provider cancellati: libqt4-4.7.4-22.1.x86_64
provider non installabili: libqt4-4.8.1-3.1.x86_64[Tumbleweed]
                   libqt4-4.7.4-19.2.2.x86_64[openSUSE_Current_OSS]
                   libqt4-4.7.4-19.4.1.x86_64[openSUSE_Current_updates]
                   libqt4-4.7.4-19.6.1.x86_64[openSUSE_Current_updates]
 Soluzione 1: Le seguenti azioni verranno eseguite:
  mantieni l'obsoleto libqt4-4.7.4-22.1.x86_64
  mantieni l'obsoleto kdegames4-carddecks-default-4.6.5-5.1.noarch
 Soluzione 2: Le seguenti azioni verranno eseguite:
  Disinstallazione di VirtualBox-4.1-4.1.8_75467_openSUSE114-1.x86_64
  downgrade di mozilla-kde4-integration-0.6.3-24.1.x86_64 a mozilla-kde4-integration-0.6.3-6.1.2.i586
  architettura modificata da mozilla-kde4-integration-0.6.3-24.1.x86_64 a mozilla-kde4-integration-0.6.3-6.1.2.i586
  Disinstallazione di libktorrent2-1.0.5-1.1.x86_64
  Disinstallazione di libkexiv2-9-4.6.5-5.4.x86_64
  Disinstallazione di libkdcraw9-4.6.5-5.4.x86_64
  downgrade di libQtAssistantClient4-4.6.3-8.2.x86_64 a libQtAssistantClient4-4.6.3-5.1.2.i586
  ...
 Soluzione 3: Disinstallazione di libstdc++45-4.5.1_20101208-9.8.x86_64
 Soluzione 4: Danneggiare VirtualBox-4.1 ignorando alcune delle sue dipendenze

Rispondo 3 anche a questa?

Problema 3

Problema: libsnmp25-5.6.1-4.5.1.x86_64 richiede librpm.so.1()(64bit), ma non è possibile fornire questa richiesta
  provider cancellati: rpm-4.8.0-28.29.1.x86_64
 Soluzione 1: Disinstallazione di kdebase4-openSUSE-11.4-124.3.x86_64
 Soluzione 2: Disinstallazione di libsnmp25-5.6.1-4.5.1.x86_64
 Soluzione 3: Installa kdebase4-openSUSE-12.1-2.3.i586 anche se l'architettura viene modificata
 Soluzione 4: mantieni l'obsoleto kdebase4-openSUSE-11.4-124.3.x86_64
 Soluzione 5: Danneggiare libsnmp25 ignorando alcune delle sue dipendenze

Che rispondo?

Problema 4

Problema: kernel-desktop-base-3.3.5-23.1.x86_64 in conflitto con kernel-desktop = 3.3.5-23.1 fornito da kernel-desktop-3.3.5-23.1.x86_64
 Soluzione 1: Disinstallazione di kernel-desktop-3.3.0-16.1.x86_64
 Soluzione 2: Disinstallazione di kernel-desktop-base-2.6.37.6-0.11.1.x86_64
 Soluzione 3: mantieni l'obsoleto kernel-desktop-3.3.0-16.1.x86_64
 Soluzione 4: Installa kernel-desktop-base-3.1.10-1.9.1.x86_64 dal repository escluso

Che rispondo?

Vi segnalo un'altra cosa anomala del mio sistema che potrebbe esservi utile: all'avvio invece di avere la sola voce Desktop--Opensuse 11.4 - 3.3.0-16, ma ho anche Desktop--Opensuse 11.4 - 2.6.37.6-0.11 che mi è comparso circa un mese fa dopo un aggiornamento ma che non sono mai riuscito a togliere

C'ho il sistema un po' incasina, vero? Wink

Grazie.

Ritratto di Grinch
Grinch
(Guru)
Offline
Guru
Iscritto: 05/12/2011
Messaggi: 887

Problema: libsnmp25-5.6.1-4.5.1.x86_64 richiede librpm.so.1()(64bit), ma non è possibile fornire questa richiesta
provider cancellati: rpm-4.8.0-28.29.1.x86_64
Soluzione 1: Disinstallazione di kdebase4-openSUSE-11.4-124.3.x86_64
Soluzione 2: Disinstallazione di libsnmp25-5.6.1-4.5.1.x86_64
Soluzione 3: Installa kdebase4-openSUSE-12.1-2.3.i586 anche se l'architettura viene modificata
Soluzione 4: mantieni l'obsoleto kdebase4-openSUSE-11.4-124.3.x86_64
Soluzione 5: Danneggiare libsnmp25 ignorando alcune delle sue dipendenze

SOLUZIONE 1 Disinstallazione di kdebase4-openSUSE-11.4-124.3.x86_64 ( a che serve kdebase4-openSUSE-11.4- se passi alla 12.1 ?

Problema: kernel-desktop-base-3.3.5-23.1.x86_64 in conflitto con kernel-desktop = 3.3.5-23.1 fornito da kernel-desktop-3.3.5-23.1.x86_64
Soluzione 1: Disinstallazione di kernel-desktop-3.3.0-16.1.x86_64
Soluzione 2: Disinstallazione di kernel-desktop-base-2.6.37.6-0.11.1.x86_64
Soluzione 3: mantieni l'obsoleto kernel-desktop-3.3.0-16.1.x86_64
Soluzione 4: Installa kernel-desktop-base-3.1.10-1.9.1.x86_64 dal repository escluso

SOLUZIONE 2 Basta un solo Kernel Desktop , in questo caso kernel-desktop = 3.3.5

ai sbagliato quella sopra dovevi rispondere 1

Errore mio .

Ritratto di Grinch
Grinch
(Guru)
Offline
Guru
Iscritto: 05/12/2011
Messaggi: 887

Dai avanti posta

Ritratto di maxg1972
maxg1972
(Geek)
Offline
Geek
Iscritto: 24/06/2009
Messaggi: 62

Citazione:

hai sbagliato quella sopra dovevi rispondere 1

a quale ti ripefrisci? al problema 2?

se si, non basterebbe disinstallare virtualbox e riprovare?

ma se disinstalla virtualbox, poi lo posso installare tranquillamente (dell'RPM del sito perchè mi serve l'uso dell'USB)?

Ritratto di Grinch
Grinch
(Guru)
Offline
Guru
Iscritto: 05/12/2011
Messaggi: 887

Vai avanti , sopra ho cancellato avevo letto male .

Che esce adesso ?

Ritratto di maxg1972
maxg1972
(Geek)
Offline
Geek
Iscritto: 24/06/2009
Messaggi: 62

Problema: libsnmp25-5.6.1-4.5.1.x86_64 richiede perl-base = 5.12.3, ma non è possibile fornire questa richiesta
provider cancellati: perl-base-5.12.3-11.20.1.x86_64
Soluzione 1: Disinstallazione di exiftool-8.40-3.1.x86_64
Soluzione 2: Disinstallazione di libsnmp25-5.6.1-4.5.1.x86_64
Soluzione 3: mantieni l'obsoleto exiftool-8.40-3.1.x86_64
Soluzione 4: Danneggiare libsnmp25 ignorando alcune delle sue dipendenze

Ritratto di Grinch
Grinch
(Guru)
Offline
Guru
Iscritto: 05/12/2011
Messaggi: 887

Soluzione 1