BOINC client

7 risposte [Ultimo messaggio]
Ritratto di tchersi
tchersi
(Junior)
Offline
Junior
Iscritto: 19/07/2012
Messaggi: 21

Sono un utente del programma di calcolo distribuito su base volontaria BOINC (boinc.berkeley.edu). Uso SuSE Linux 11.1 su un sistema SUN. L'ultimo client BOINC funzionante su questo sistema e' 6.10.58 mentre BOINC e' arrivato a 7.0.28. I messaggi di errore dicono che mancano delle librerie ma non so dove trovarle. Stesso discorso per il mio nuovo HP 635 con sistema operativo SLES 11.

tullio chersi

Ritratto di aksaf
aksaf
(Guru)
Offline
Guru
Iscritto: 08/03/2011
Messaggi: 957

Se si guarda su http://software.opensuse.org/search si vede che libboinc7 è disponibile per openSUSE 11.4 e oltre, ma proprio non so se i binari per quelle openSUSE siano compatibili con SLE, dato che se ho ben capito anche sul server hai la SLE (SLES? sp1 o sp2?). Quindi per favore dovresti postare l'elenco di errori che ottieni in fase di compilazione o installazione, spiegando appunto se stai installando dei binari e hai errori di avvio, oppure se hai errori durante le compilazione, da quali sorgenti compili o installi, architettura, etc...

Ritratto di tchersi
tchersi
(Junior)
Offline
Junior
Iscritto: 19/07/2012
Messaggi: 21

libboinc7 include una vecchia versione del client BOINC e quindi non mi interessa. Io scarico il client dal sito boinc.berkeley.edu e l'ultima versione e' 7.0.20. Sul sistema SLES 11 che ho trovato sul noteboook HP 635 ho i seguenti errori:
se lancio il client manca libssl.so.1.o.o
se invece lancio il boincmanager, che lancia anche il client, manca libwx_gtk2u_html-2.8.so.0
Non installo BOINC 7.0.28 sul SUN in quanto ho 7 programmi che girano in ambiente BOINC 6.10.58 e non vogliorischiare.

tullio chersi

Ritratto di aksaf
aksaf
(Guru)
Offline
Guru
Iscritto: 08/03/2011
Messaggi: 957

Da YaST > Gestione pacchetti non hai trovato niente? cercando su software.opensuse.org:
http://software.opensuse.org/package/libopenssl1_0_0
http://software.opensuse.org/package/libwx_gtk2u_html-2_9-3-stl

P.S.: sicuro sull'hp di avere sled (d:=desktop) anziché sles (s:=server)? col comando

cat /etc/SuSE-*

dovrebbe dare la versione esatta anche con le SLE (credo)

Ritratto di tchersi
tchersi
(Junior)
Offline
Junior
Iscritto: 19/07/2012
Messaggi: 21

Il mio LInux sul SUN e' 11.1 e per il momento non lo aggiorno anche se ho gia' il 12.1 su DVD e penso di attendere 12.2, per cui non trovo pacchetti. Sono abituato a scaricare il client BOINC da boinc.berkeley.edu come fanno gli utenti delle altre distribuzioni. Il Linux su HP e' SuSE Enterprise Desktop e sulla documentazione veramente scarsa arrivata con l'HP non c'e' alcuna indicazioene sulla versione.Nella directory /etc SuSE* non esiste. Il monitor di sistema mi da' Rilascio 11, Kernel 2.6.32.29-0.3-pae, GNOME 2.28.2.

tullio chersi

Ritratto di aksaf
aksaf
(Guru)
Offline
Guru
Iscritto: 08/03/2011
Messaggi: 957

tchersi ha scritto:

Il mio LInux sul SUN e' 11.1


intendi openSUSE 11.1? prova a vedere su http://rpm.pbone.net/ se trovi qualcosa...
tchersi ha scritto:


e per il momento non lo aggiorno anche se ho gia' il 12.1 su DVD e penso di attendere 12.2, per cui non trovo pacchetti. Sono abituato a scaricare il client BOINC da boinc.berkeley.edu come fanno gli utenti delle altre distribuzioni. Il Linux su HP e' SuSE Enterprise Desktop


e per la SLE i pacchetti ci sono, nei link che ti ho indicato (clic su Mostra altre versioni e poi su Show unstable...)
tchersi ha scritto:


Nella directory /etc SuSE* non esiste..


assicurati di avere scritto correttamente il comando, il percorso + nomi file é: /etc/SuSE-*
(comunque è sicuramente SLED, allora)

Ritratto di tchersi
tchersi
(Junior)
Offline
Junior
Iscritto: 19/07/2012
Messaggi: 21

Ti ringrazio, comunque nella directory /etc non esiste SUSE-*. Il mio 11.1 e' openSuSE, che mi va bene. Il client BOINC di boinc.berkeley.edu e' stato testato su Ubunto. Poi sono mezionati dei [ackages di installazioen per Debian, Fedora, Gentoo e Ubunto. Non sono menzionati pacchetti SUSE e mi dispiace. Sono uno dei pochissimi utenti Linux dell'ambiente BOINC ad usare SuSE e ne capisco la ragione. Perchee' SuSE non ci dedica piu' attenzione? Siamo migliaia, anche se la maggioranza usa Windows. Io uso anche Scientific Linux del CERN tramite Virtual Box e una Virtual Machine BOINC_VM.

tullio chersi

Ritratto di tchersi
tchersi
(Junior)
Offline
Junior
Iscritto: 19/07/2012
Messaggi: 21

Data la mia scarsa attitudine a usare il touchpad, bo visto finalmente /etc/SuSE-release. Dice
VERRSION=11
PATCHLEVEL=1

tullio chersi