Connessione wireless 100% ma navigazione lenta!

10 risposte [Ultimo messaggio]
Ritratto di Alessia1984
Alessia1984
(Junior)
Offline
Junior
Iscritto: 31/07/2012
Messaggi: 8

Salve a tutti!
Premetto che per connettermi ad internet uso un modem Netgear DM111P e un dispositivo Asus RT-N13U (SuperSpeed N Wireless Router) che può funzionare da Access Point, Router e da Ripetitore; nel mio caso funziona da router. Avendo altri portatili nella stanza e non avendo un semplice router devo usare la connessione wireless. I dispositivi (netgear e asus) si trovano nella stessa stanza del mio portatile ed è per questo che riesco ad avere il 100% della connessione.
Il problema è che la navigazione è lentissima!!!Mentre con la rete cablata è tutto ok.
Inizialmente non avevo questo problema, poi per altri motivi ho formattato il computer (anche 2-3 volte) e ho iniziato ad avere questo problema!
Devo configurare qualcosa?(anche se inizialmente quando era tutto ok non configuravo nulla!)

Ah!questo problema non c'è per il portatile con W7!

Queste sono le informazioni sulla connessione, se possono servire!

AllegatoDimensione
schermata.png657.81 KB
Ritratto di PLACEBO12
PLACEBO12
(Junior)
Offline
Junior
Iscritto: 18/08/2012
Messaggi: 15

Ciao! Scusa il ritardo ma anche io era alle prese con dei problemi di wifi...
Se sei certa che il modulo ath9k (nell'immagine) era quello che comandava la tua interfaccia anche prima della formattazione prova a settare la velocità di trasmissione da riga di comando tipo:

iwconfig wlan0 rate 54M
iwpriv wlan0 mode 0    

la prima riga setta la velocità di trasmissione a 54Mbit/s...il protocollo N del tuo ASUS arriva fino a 300...ma tu fai delle prove a varie velocità...la seconda riga setta in automatico lo standard di comunicazione ...b g n...
dopo il settaggio vedi se cambia qualcosa!!!
Ciao!

Ritratto di Alessia1984
Alessia1984
(Junior)
Offline
Junior
Iscritto: 31/07/2012
Messaggi: 8

Ciao e scusa il ritardo!
Io ho provato a fare ciò che hai scritto, ma mi dice comando non trovato!
Non sono ancora pratica con questo sistema!

Ritratto di PLACEBO12
PLACEBO12
(Junior)
Offline
Junior
Iscritto: 18/08/2012
Messaggi: 15

Per eseguire il comando devi avere i privilegi di root quindi delle due :
o digiti sudo prima di ognuno dei due comandi e conseguentemente fornisci la password di root
o ti logggi come root e esegui le due di codice che ti ho indicato
Per loggarti come root digita:

su (dai enter)
Ti verrà richiesta la password di root.... e tu la inserisci
poi digiti le righe di comando che ti servono...
questa seconda la sconsiglio perchè ti lascia i privilegi di root e se per caso sbagli un comando potresti fare dei danni.....
Fammi sapere!

Ritratto di Alessia1984
Alessia1984
(Junior)
Offline
Junior
Iscritto: 31/07/2012
Messaggi: 8

Ti ringrazio per l'aiuto, ma non succede nulla! Confused
Ho provato entrambi i modi!!
Guarda l'allegato

Immagini allegate:

Ritratto di PLACEBO12
PLACEBO12
(Junior)
Offline
Junior
Iscritto: 18/08/2012
Messaggi: 15

Ciao Alessia... leggiamo più in profondita allora...
Loggati come root...scrivi
su
poi dai enter...ti verrà richiesta la password di root e tu la inserisci
Password: (tua password)
Poi posta il risultato di
iwconfig
Su wlan0 dovresti vedere la tua rete wi-fi ...ti posto il mio risultato:

linux-852p:/home/Faso # iwconfig
lo        no wireless extensions.
 
eth0      no wireless extensions.
 
wlan0     IEEE 802.11bg  ESSID:"NETGEAR1"  
          Mode:Managed  Frequency:2.412 GHz  Access Point: A0:21:B7:65:E6:96   
          Bit Rate=54 Mb/s   Tx-Power=27 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=50/70  Signal level=-60 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

Se vedi la tua rete posta il risultato di
iwlist scan
in pratica ti uscirà una lista delle connessioni (wi-fi e non) disponibili ... ti faccio vedere la mia
lista:Faso@linux-852p:~> su
Password: 
linux-852p:/home/Faso # iwlist scan
lo        Interface doesn't support scanning.
 
eth0      Interface doesn't support scanning.
 
wlan0     Scan completed :
          Cell 01 - Address: A0:21:B7:65:E6:96
                    Channel:1
                    Frequency:2.412 GHz (Channel 1)
                    Quality=52/70  Signal level=-58 dBm  
                    Encryption key:on
                    ESSID:"NETGEAR1"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                    Mode:Master
                    Extra:tsf=00000000285e619a
                    Extra: Last beacon: 292ms ago
                    IE: Unknown: 00084E45544745415231
                    IE: Unknown: 010882848B962430486C
                    IE: Unknown: 030101
                    IE: Unknown: 2A0100
                    IE: Unknown: 2F0100
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
                    IE: Unknown: 32040C121860
                    IE: Unknown: 2D1A7C181BFFFF000000000000000000000000000000000000000000
                    IE: Unknown: 3D1601001300000000000000000000000000000000000000
                    IE: Unknown: DD780050F204104A00011010440001021041000100103B00010310470010D4A2417E302D877D75EF6E25C8D6123C1021000D4E4554474541522C20496E632E1023000744474E323230301024000744474E3232303010420004323230301054000800060050F20400011011000744474E32323030100800020084
                    IE: Unknown: DD090010180201F0050000
                    IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00
                    IE: Unknown: DD1E00904C337C181BFFFF000000000000000000000000000000000000000000
                    IE: Unknown: DD1A00904C3401001300000000000000000000000000000000000000
          Cell 02 - Address: 38:22:9D:EC:F6:EF
                    Channel:11
                    Frequency:2.462 GHz (Channel 11)
                    Quality=31/70  Signal level=-79 dBm  
                    Encryption key:on
                    ESSID:"Telecom-33633513"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                    Mode:Master
                    Extra:tsf=000000430e0b1f37
                    Extra: Last beacon: 84ms ago
                    IE: Unknown: 001054656C65636F6D2D3333363333353133
                    IE: Unknown: 010882848B962430486C
                    IE: Unknown: 03010B
                    IE: Unknown: 2A0100
                    IE: Unknown: 2F0100
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    IE: Unknown: 32040C121860
                    IE: Unknown: 2D1A70181BFF00000000000000000000000000000000000000000000
                    IE: Unknown: 3D160B080000000000000000000000000000000000000000
                    IE: Unknown: 4A0E14000A002C01C800140005001900
                    IE: Unknown: 7F0101
                    IE: Unknown: DD770050F204104A00011010440001021041000100103B00010310470010876691067F660F55EA45EFC1E9AEF5E410210007506972656C6C69102300064469736375731024000630303030303110420004303030311054000800060050F204000110110009506972656C6C694150100800020088103C000101
                    IE: Unknown: DD090010180200F0040000
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00
          Cell 03 - Address: 38:22:9D:35:C0:90
                    Channel:6
                    Frequency:2.437 GHz (Channel 6)
                    Quality=37/70  Signal level=-73 dBm  
                    Encryption key:on
                    ESSID:"Alice-65175169"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                    Mode:Master
                    Extra:tsf=0000014598f01614
                    Extra: Last beacon: 2964ms ago
                    IE: Unknown: 000E416C6963652D3635313735313639
                    IE: Unknown: 010882848B962430486C
                    IE: Unknown: 030106
                    IE: Unknown: 2A0100
                    IE: Unknown: 2F0100
                    IE: Unknown: 32040C121860
                    IE: Unknown: DD600050F204104A00011010440001021041000100103B0001031047001000000000000000000000000000000000102100001023000010240000104200001054000800000000000000001011000E416C6963652D3635313735313639100800020000
                    IE: Unknown: DD090010180202F0000000
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (1) : TKIP
                        Authentication Suites (1) : PSK

Controlla che ci sia la tua rete wi fi e guarda se per caso è su un canale dove trasmette qualche altra rete...o adiacente .
Fammi sapere e non demordere..
Ciao!

Ritratto di Alessia1984
Alessia1984
(Junior)
Offline
Junior
Iscritto: 31/07/2012
Messaggi: 8

Ciao Placebo12, intanto grazie per l'aiuto!
Questo è ciò che mi appare:

alessia@linux:~> su
Password:
linux:/home/alessia # iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11bgn ESSID:"ASUS"
Mode:Managed Frequency:2.432 GHz Access Point: F4:6D:04:A0:11:5C
Bit Rate=78 Mb/s Tx-Power=20 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:on
Link Quality=70/70 Signal level=-31 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

pan0 no wireless extensions.

linux:/home/alessia # iwlist scan
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

wlan0 Scan completed :
Cell 01 - Address: 00:25:53:1F:BE:30
Channel:1
Frequency:2.412 GHz (Channel 1)
Quality=41/70 Signal level=-69 dBm
Encryption key:on
ESSID:"Alice-62667281"
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
24 Mb/s; 36 Mb/s; 54 Mb/s
Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
Mode:Master
Extra:tsf=000002ab97f9c183
Extra: Last beacon: 4524ms ago
IE: Unknown: 000E416C6963652D3632363637323831
IE: Unknown: 010882848B962430486C
IE: Unknown: 030101
IE: Unknown: 2A0100
IE: Unknown: 2F0100
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK
IE: Unknown: 32040C121860
IE: Unknown: DD600050F204104A00011010440001021041000100103B0001031047001000000000000000000000000000000000102100001023000010240000104200001054000800000000000000001011000E416C6963652D3632363637323831100800020000
IE: Unknown: DD090010180200F0000000
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK
Cell 02 - Address: F4:6D:04:A0:11:5C
Channel:5
Frequency:2.432 GHz (Channel 5)
Quality=70/70 Signal level=-35 dBm
Encryption key:on
ESSID:"ASUS"
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 9 Mb/s
18 Mb/s; 36 Mb/s; 54 Mb/s
Bit Rates:6 Mb/s; 12 Mb/s; 24 Mb/s; 48 Mb/s
Mode:Master
Extra:tsf=00000000106d3a47
Extra: Last beacon: 12ms ago
IE: Unknown: 000441535553
IE: Unknown: 010882848B961224486C
IE: Unknown: 030105
IE: Unknown: 2A0104
IE: Unknown: 32040C183060
IE: Unknown: 2D1AEC0117FFFF0000000000000000000000000000000C0000000000
IE: Unknown: 3D1605000400000000000000000000000000000000000000
IE: Unknown: 3E0100
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : CCMP
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : PSK
IE: Unknown: DD180050F2020101000003A4000027A4000042435E0062322F00
IE: Unknown: 0B05020002127A
IE: Unknown: 7F0101
IE: Unknown: DD07000C4307000000
IE: Unknown: 0706474220010D10
IE: Unknown: DD1E00904C33EC0117FFFF0000000000000000000000000000000C0000000000
IE: Unknown: DD1A00904C3405000400000000000000000000000000000000000000
Cell 03 - Address: 00:19:3E:5C:34:46
Channel:1
Frequency:2.412 GHz (Channel 1)
Quality=18/70 Signal level=-92 dBm
Encryption key:on
ESSID:"Alice-32931758"
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
24 Mb/s; 36 Mb/s; 54 Mb/s
Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
Mode:Master
Extra:tsf=0000037cc2694189
Extra: Last beacon: 13980ms ago
IE: Unknown: 000E416C6963652D3332393331373538
IE: Unknown: 010882848B962430486C
IE: Unknown: 030101
IE: Unknown: 050400010000
IE: Unknown: 2A0100
IE: Unknown: 2F0100
IE: Unknown: 32040C121860
IE: Unknown: DD060010180200F4
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK
Cell 04 - Address: 00:0E:A6:A1:3E:E9
Channel:1
Frequency:2.412 GHz (Channel 1)
Quality=18/70 Signal level=-92 dBm
Encryption key:on
ESSID:"shesa"
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
24 Mb/s; 36 Mb/s; 54 Mb/s
Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
Mode:Master
Extra:tsf=0000037cc0b93299
Extra: Last beacon: 4892ms ago
IE: Unknown: 00057368657361
IE: Unknown: 010882848B962430486C
IE: Unknown: 030101
IE: Unknown: 2A0104
IE: Unknown: 2F0104
IE: Unknown: 32040C121860
IE: Unknown: DD050010180103
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK

pan0 Interface doesn't support scanning.

Ed ora che faccio?

Ritratto di PLACEBO12
PLACEBO12
(Junior)
Offline
Junior
Iscritto: 18/08/2012
Messaggi: 15

Ciao Alessia...sembra che il sistema riconsoca la connessione di rete... ma se guardi il risultato di
iwlist scan
si vede che cell01 e cell03 utilizzano lo stesso canale di trasmissione ...se uno dei due corrisponde alla tua rete.. la mia idea è provare a spostare nelle configurazioni del modem il canale di trasmissione... scegline uno che nella lista non c'è e che sia distante dagli altri...e vediamo che succede!!!!!
Fammi sapere
E buon linux!
Marco

Ritratto di Alessia1984
Alessia1984
(Junior)
Offline
Junior
Iscritto: 31/07/2012
Messaggi: 8

Ciao Marco!
Allora la mia rete è ASUS e il canale è 5.....quindi non posso fare ciò che mi hai detto! Confused

Ritratto di PLACEBO12
PLACEBO12
(Junior)
Offline
Junior
Iscritto: 18/08/2012
Messaggi: 15

OOOps!!!!!
Ricordi per caso se il modulo caricato dal kernel per gestire la scheda di rete wi fi (ath9k visibile nella prima immagine che mi hai inviato) è lo stesso che veniva caricato nelle altre installazioni?
Prova a fare qualche ricerca sul modulo più adatto alla tua scheda di rete...e vedi se è quello effettivamente che hai caricato tu (ath9k).
Fammi sapere... scusa se non sono un guru nell'aiutarti ma ho iniziato anche io da poco... Dont Tell Anyone
Ciao!

Ritratto di Alfio
Alfio
(Guru)
Offline
Guru
Iscritto: 30/08/2005
Messaggi: 2678

Elimina la vecchia connessione wireless e riconfigurala da yast elimina prima il modulo da yast e riavvia opensuse cosi ti viene piu facile.
Ciao