webcam Trust

5 risposte [Ultimo messaggio]
Ritratto di Andrea Gatto
Andrea Gatto
(Junior)
Offline
Junior
Iscritto: 26/10/2011
Messaggi: 36

Ciao a tutti
ho una webcam TRUST 13405
non funziona , ne con Skype ne con wxCam.
Ho provato a leggere qualche post a riguardo, ma essendo poco che utilizzo Suse non so come muovermi.

Posto il risultato del comando LSUSB
Bus 001 Device 002: ID 0846:4260 NetGear, Inc. WG111v3 54 Mbps Wireless [realtek RTL8187B]
Bus 001 Device 003: ID 2001:f103 D-Link Corp. DUB-H7 7-port USB 2.0 hub
Bus 001 Device 004: ID 03f0:3d17 Hewlett-Packard LaserJet P1005
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 006: ID 093a:2468 Pixart Imaging, Inc. SoC PC-Camera
Bus 001 Device 007: ID 046d:c018 Logitech, Inc. Optical Wheel Mouse

Utilizzo Suse 12.2 con KDE

Grazie
Ciao

Ritratto di aksaf
aksaf
(Guru)
Offline
Guru
Iscritto: 08/03/2011
Messaggi: 957

Dunque, ho provato a fare un po' di lavoro sporco al posto tuo Wink, spero con qualche risultato: la tua webcam dovrebbe ricadere in questo caso: http://it.opensuse.org/HCL:Webcam#Webcam_supportate_dal_driver_Gspca.2FSpca5xx_.28v1_e_v2.29 e dovrebbe essere supportata
direttamente nel kernel (puoi controllare tu stesso seguendo i link indicati all'inizio di quell'articolo) prova a controllare se il modulo spca è caricato:

lsmod | grep pca

inoltre prova a lanciare il programma che vuoi usare precaricando la libreria v4l1compat.so (è nel pacchetto libv4l che dovrebbe già essere installato sul tuo sistema) come detto nel link indicato sopra

Ritratto di mauriziod
mauriziod
(Guru)
Offline
Guru
Iscritto: 01/06/2009
Messaggi: 1730

Ma non è che forse entra in conflitto con le altre cose? Prova ad inserirla ad accensione della macchina con nient'altro sul USB.

SO: Linux desktop Sistema: OpenSUSE Leap 15.1 (64bit) KDEE 5.12
SO: Linux desktop Sistema: OpenSUSE Tumbleweed (64bit) KDE 5
Miao

Ritratto di Andrea Gatto
Andrea Gatto
(Junior)
Offline
Junior
Iscritto: 26/10/2011
Messaggi: 36

aksaf ha scritto:

Dunque, ho provato a fare un po' di lavoro sporco al posto tuo Wink, spero con qualche risultato: la tua webcam dovrebbe ricadere in questo caso: http://it.opensuse.org/HCL:Webcam#Webcam_supportate_dal_driver_Gspca.2FSpca5xx_.28v1_e_v2.29 e dovrebbe essere supportata
direttamente nel kernel (puoi controllare tu stesso seguendo i link indicati all'inizio di quell'articolo) prova a controllare se il modulo spca è caricato:

lsmod | grep pca

inoltre prova a lanciare il programma che vuoi usare precaricando la libreria v4l1compat.so (è nel pacchetto libv4l che dovrebbe già essere installato sul tuo sistema) come detto nel link indicato sopra

Ti ringrazio molto per le informazioni.
Il link che hai postato e' funzionante ma all'interno della pagina se clicco sull'icona per scaricare il file GSPCA V2 mi dice che il link e' inesistente. Ho cercato altre fonti per il download ma non ho trovato niente.
Comunque , dato che a me la webcam serve solo per skype , dopo un po di esperimenti sono riuscito provando il comando
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so
a far partire la webcam con skype , cosi' ho creato sul dektop un launcher con l'icona SKYPE e il comando
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so Skype
cosi' se ho capito bene fa' il preload e il video e' funzionante.

La prova di avviare il computer con solo la webcam collegata sinceramente non l'ho fatta , in caso fosse quello il problema mi seccherebbe doverla cambiare.

Grazie a tutti
Ciao

Ritratto di mauriziod
mauriziod
(Guru)
Offline
Guru
Iscritto: 01/06/2009
Messaggi: 1730

Guarda che è un caso eccezionale, ma sai provarle tutte non guasta! Wink

SO: Linux desktop Sistema: OpenSUSE Leap 15.1 (64bit) KDEE 5.12
SO: Linux desktop Sistema: OpenSUSE Tumbleweed (64bit) KDE 5
Miao

Ritratto di aksaf
aksaf
(Guru)
Offline
Guru
Iscritto: 08/03/2011
Messaggi: 957

Andrea Gatto ha scritto:

aksaf ha scritto:

Dunque, ho provato a fare un po' di lavoro sporco al posto tuo Wink, spero con qualche risultato: la tua webcam dovrebbe ricadere in questo caso: http://it.opensuse.org/HCL:Webcam#Webcam_supportate_dal_driver_Gspca.2FSpca5xx_.28v1_e_v2.29 e dovrebbe essere supportata
direttamente nel kernel (puoi controllare tu stesso seguendo i link indicati all'inizio di quell'articolo) prova a controllare se il modulo spca è caricato:

lsmod | grep pca

inoltre prova a lanciare il programma che vuoi usare precaricando la libreria v4l1compat.so (è nel pacchetto libv4l che dovrebbe già essere installato sul tuo sistema) come detto nel link indicato sopra

Ti ringrazio molto per le informazioni.
Il link che hai postato e' funzionante ma all'interno della pagina se clicco sull'icona per scaricare il file GSPCA V2 mi dice che il link e' inesistente. Ho cercato altre fonti per il download ma non ho trovato niente.
Comunque , dato che a me la webcam serve solo per skype , dopo un po di esperimenti sono riuscito provando il comando
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so
a far partire la webcam con skype , cosi' ho creato sul dektop un launcher con l'icona SKYPE e il comando
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so Skype
cosi' se ho capito bene fa' il preload e il video e' funzionante.

La prova di avviare il computer con solo la webcam collegata sinceramente non l'ho fatta , in caso fosse quello il problema mi seccherebbe doverla cambiare.

Grazie a tutti
Ciao


Sì è normale che qualche link non funzioni, altre parti di quella guida sono un po' vecchie: come già ti avevo accennato e com'è accennato nel wiki con openSUSE abbastanza recenti i driver sono già inclusi, me resta valido il preload, Il link per il controllo del supporto è questo http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=blob;f=Documentation/video4linux/gspca.txt;hb=HEAD ed è riportato all'inizio della sezione dell'articolo che ti ho indicato.
Ciao e alla prossima