impossibile montare disco esterno

10 risposte [Ultimo messaggio]
Ritratto di robyrom
robyrom
(Geek)
Offline
Geek
Iscritto: 24/10/2007
Messaggi: 183

Ho dovuto cambiare hd a causa di una rottura ed ora ripristinando i dati che avevo salvato su un hd esterno usb ricevo questo messaggio di errore:

An error occurred while accessing 'Iomega HDD', the system responded: The requested operation has failed: Error mounting /dev/sdb1 at /run/media/robyrom/Iomega HDD: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=100,dmask=0077,fmask=0177" "/dev/sdb1" "/run/media/robyrom/Iomega HDD"' exited with non-zero exit status 32: mount: unknown filesystem type 'ntfs'

Il disco con windows funziona e altre chiavette usb sono viste senza problemi. Ho provato a modificare sia i permessi della di di montaggio sia il tipo di file system ma l'errore permane. Avreste qualche suggerimento da darmi? Grazie

robyrom

Ritratto di Grinch
Grinch
(Guru)
Offline
Guru
Iscritto: 05/12/2011
Messaggi: 898

Usa Gparted per formattarlo , poi riprova a montarlo Party

Ritratto di robyrom
robyrom
(Geek)
Offline
Geek
Iscritto: 24/10/2007
Messaggi: 183

Ho usato poche volte gparted ma non vorrei correre il rischio di perdere dati. Grazie

robyrom

Ritratto di Grinch
Grinch
(Guru)
Offline
Guru
Iscritto: 05/12/2011
Messaggi: 898

Non ho capito se è Vuoto o l' hai già scritto con Finestre .

Ritratto di robyrom
robyrom
(Geek)
Offline
Geek
Iscritto: 24/10/2007
Messaggi: 183

E' pieno e l'ho scritto con OpenSuse, sono tutti file di archivio, foto e video.

robyrom

Ritratto di aksaf
aksaf
(Guru)
Offline
Guru
Iscritto: 08/03/2011
Messaggi: 957

Proviamo a vedere le proprietà di questa partizione (?):

udisksctl info -b /dev/sdb1

(perché altrimenti il comando di mount che hai incollato sembra a posto, ed è quello che su openSUSE 12.3 viene comunque usato sia che monti da filemanager, udisksctl, mount o ntfs-3g)

Ritratto di robyrom
robyrom
(Geek)
Offline
Geek
Iscritto: 24/10/2007
Messaggi: 183

questo è l'output

leone:~ # udisksctl info -b /dev/sdb1
/org/freedesktop/UDisks2/block_devices/sdb1:
org.freedesktop.UDisks2.Block:
Configuration: []
CryptoBackingDevice: '/'
Device: /dev/sdb1
DeviceNumber: 2065
Drive: '/org/freedesktop/UDisks2/drives/ST9500325AS_5VE5X9NZ'
HintAuto: true
HintIconName:
HintIgnore: false
HintName:
HintPartitionable: true
HintSystem: false
IdLabel: Iomega HDD
IdType: ntfs
IdUUID: EC4C82D54C8299CA
IdUsage: filesystem
IdVersion:
PreferredDevice: /dev/sdb1
ReadOnly: false
Size: 500105217024
Symlinks: /dev/disk/by-id/ata-ST9500325AS_5VE5X9NZ-part1
/dev/disk/by-id/scsi-SST9500325AS_801130168383-part1
/dev/disk/by-id/wwn-0x5000c5001c424c17-part1
/dev/disk/by-label/Iomega\x20HDD
/dev/disk/by-path/pci-0000:00:1a.0-usb-0:1.2:1.0-scsi-0:0:0:0-part1
/dev/disk/by-uuid/EC4C82D54C8299CA
org.freedesktop.UDisks2.Filesystem:
MountPoints:
org.freedesktop.UDisks2.Partition:
Flags: 0
IsContained: false
IsContainer: false
Name:
Number: 1
Offset: 32256
Size: 500105217024
Table: '/org/freedesktop/UDisks2/block_devices/sdb'
Type: 0x07
UUID:

Anche se non sono un guru a me sembra che vada bene.

robyrom

Ritratto di aksaf
aksaf
(Guru)
Offline
Guru
Iscritto: 08/03/2011
Messaggi: 957

robyrom ha scritto:

questo è l'output

Anche se non sono un guru a me sembra che vada bene.


Neanch'io lo sono, la scritta sotto il nick te la danno d'ufficio quando raggiungi n messaggi (Psychedelic yogi Is not a very groovy groovy guru...). In ogni caso sembra davvero tutto a posto, IMVHO, prova anche questi due comandi:
sudo mount /dev/sdb1 /mnt

e
sudo ntfsfix -n /dev/sdb1

Thinking

Ritratto di robyrom
robyrom
(Geek)
Offline
Geek
Iscritto: 24/10/2007
Messaggi: 183

Il primo dà
mount: special device /dev/sdb1 does not exist
il secondo
ntfsfix: command not found

robyrom

Ritratto di robyrom
robyrom
(Geek)
Offline
Geek
Iscritto: 24/10/2007
Messaggi: 183

Ho risolto installando il pacchetto ntfs-3g. Grazie a tutti

robyrom

Ritratto di aksaf
aksaf
(Guru)
Offline
Guru
Iscritto: 08/03/2011
Messaggi: 957

Solo per fini informativi, potresti indicare che versione di openSUSE stai usando e con che modalità è stata installata, dato che ntfs-3g è richiesto da ntfsprogs che dovrebbe far parte di un'installazione standard Confused