Aiuto per Hp Laserjet P1005

9 risposte [Ultimo messaggio]
Ritratto di luc
luc
(Junior)
Offline
Junior
Iscritto: 23/08/2011
Messaggi: 26

Salute a tutta la comunità Suseitalia,

dopo l'installazione di 12.3 non riesco a far partire la stampante in oggetto.
Ho seguito tutte le procedure indicate anche in un post precedente ma senza ottenere risultato.
Ho dato anche questi comandi

linux-f4a1:/home/lucasuse # zypper addrepo http://download.opensuse.org/repositories/Printing/openSUSE_Factory/Printing.repo
Aggiunta del repository 'Printing System Development Project (openSUSE_Fa[fatto]
Esiste già un repository di nome 'Printing'. Usare un altro alias.
linux-f4a1:/home/lucasuse # zypper refresh
Il repository 'Printing' è aggiornato.
Il repository 'google-chrome' è aggiornato.
Il repository 'openSUSE-12.3-Debug' è aggiornato.
Il repository 'openSUSE-12.3-Non-Oss' è aggiornato.
Il repository 'openSUSE-12.3-Oss' è aggiornato.
Il repository 'openSUSE-12.3-Update' è aggiornato.
Il repository 'openSUSE-12.3-Update-Non-Oss' è aggiornato.
Tutti i repository sono stati aggiornati.
linux-f4a1:/home/lucasuse # zypper install hplip
Lettura dei dati del repository in corso...
Lettura dei pacchetti installati in corso...
'hplip' è già installato.
Nessuno aggiornamento candidato per 'hplip-3.13.4-76.1.x86_64'. La versione più alta disponibile è già installata.
Risoluzione delle dipendenze dei pacchetti in corso…
 
Nessuna operazione da eseguire.
linux-f4a1:/home/lucasuse # 

ma niente. Eppure la stampante ha comunicato la sua presenza, però a ogni richiesta di stampa (di prova o di documenti) tutto resta in "coda" e non lavora.

Sareste così gentili da aiutarmi? Crying
Grazie.

luc

Ritratto di Grinch
Grinch
(Guru)
Offline
Guru
Iscritto: 05/12/2011
Messaggi: 881

Apri il terminale con la stampante accesa
hp-toolbox
Printer control >Job-queve> elimina tutte le stampe in coda poi riprova

Ritratto di luc
luc
(Junior)
Offline
Junior
Iscritto: 23/08/2011
Messaggi: 26

Ho dato
hp-toolbox
risultato

linux-f4a1:/home/lucasuse # hp-toolbox
warning: hp-toolbox should not be run as root/superuser.
 
HP Linux Imaging and Printing System (ver. 3.13.4)
HP Device Manager ver. 15.0
 
Copyright (c) 2001-13 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.
 
warning: Reportlab not installed. Fax coverpages disabled.
warning: Please install version 2.0+ of Reportlab for coverpage support.
error: dBus initialization error. Exiting.

Allego altresì due schermate per mostrare alcune finestre relative a Stampanti dove si evince che ci dev'essere un conflitto tra hplip 3.12 e 3.13.
Forse ho fatto qualche pasticcio. Mi conviene eliminare tutte le stampanti e ripartire da capo?

Immagini allegate:

luc

Ritratto di mauriziod
mauriziod
(Guru)
Offline
Guru
Iscritto: 01/06/2009
Messaggi: 1701

Nessun pasticcio! In yast->gestione pacchetti. elimini Hplib e poi lo reinstalli in quanto deve avere le giuste autorizzazioni che sono cambiate in Suse 12.3

Di solito quell'errore è perchè tu non sei nel gruppo "lp". Per aggiungerti nel gruppo: Yast-utenti e gruppi e clicca modifica e cerca di aggiungerlo nella zona sulla sx.

Se non funziona:
http://it.opensuse.org/SDB:Come_configurare_una_stampante_HP

SO: Linux desktop Sistema: OpenSUSE Leap 15.1 (64bit) KDEE 5.12
SO: Linux desktop Sistema: OpenSUSE Tumbleweed (64bit) KDE 5
Miao

Ritratto di luc
luc
(Junior)
Offline
Junior
Iscritto: 23/08/2011
Messaggi: 26

Grazie del suggerimento, oggi pomeriggio seguirò le istruzioni passo passo.
Per scrupolo, riporto schermata di YaST > Gestione Pacchetti, chiedendo se devo eliminare tutte le versioni di Hplip presenti (3.12 e 3.13) e quale successivamente reinstallare per la mia openSUSE 12.3.

Saluti e a più tardi Wave

Immagini allegate:

luc

Ritratto di mauriziod
mauriziod
(Guru)
Offline
Guru
Iscritto: 01/06/2009
Messaggi: 1701

Pensandoci bene:

Prova prima ad metterti il gruppo (richiede riavvio della macchina) e se non funziona poi fai la disinstallazione di hplib (le altre due sono collegate e dovrebbe automaticamente toglierle, nel caso fallo manualmente).

SO: Linux desktop Sistema: OpenSUSE Leap 15.1 (64bit) KDEE 5.12
SO: Linux desktop Sistema: OpenSUSE Tumbleweed (64bit) KDE 5
Miao

Ritratto di luc
luc
(Junior)
Offline
Junior
Iscritto: 23/08/2011
Messaggi: 26

Citazione:

Prova prima ad metterti il gruppo (richiede riavvio della macchina


Fatto, ma nessun risultato (se non che al riavvio la stampante ha "sentito" il contatto: ma non stampa!).
Citazione:

se non funziona poi fai la disinstallazione di hplib (le altre due sono collegate e dovrebbe automaticamente toglierle, nel caso fallo manualmente)


A tal proposito, per disinstallare il tutto e riprovare a reinstallare ex novo (togliere anche Hp-toolbox per intenderci) come procedere con YaST o quale comando dare da terminale?
Grazie.
Stasera riprovo, seguendo la guida ufficiale. Silly

luc

Ritratto di luc
luc
(Junior)
Offline
Junior
Iscritto: 23/08/2011
Messaggi: 26

Innanzi tutto, scusate il ritardo di questa segnalazione, ma ieri mi risultata impossibile accedere al presente sito di Suse Italia.

Comunque, solo per dire che sono riuscito a installare correttamente la stampante, così facendo:
1) ho disinstallato tutti gli hplip e, successivamente, reinstallato quello specifico per openSUSE 12.3.
Di poi ho installato il plugin mediante Hp Device Manager che ha fatto partire in automatico Xterm, del quale ho seguito i comandi che venivano proposti.
Grazie a tutti e buona domenica.

luc

Ritratto di luc
luc
(Junior)
Offline
Junior
Iscritto: 23/08/2011
Messaggi: 26

Innanzi tutto, scusate il ritardo di questa segnalazione, ma ieri mi risultata impossibile accedere al presente sito di Suse Italia.

Comunque, solo per dire che sono riuscito a installare correttamente la stampante, così facendo:
1) ho disinstallato tutti gli hplip e, successivamente, reinstallato quello specifico per openSUSE 12.3.
Di poi ho installato il plugin mediante Hp Device Manager che ha fatto partire in automatico Xterm, del quale ho seguito i comandi che venivano proposti.
Grazie a tutti e buona domenica.

luc

Ritratto di luc
luc
(Junior)
Offline
Junior
Iscritto: 23/08/2011
Messaggi: 26

Innanzi tutto, scusate il ritardo di questa segnalazione, ma ieri mi risultata impossibile accedere al presente sito di Suse Italia.

Comunque, solo per dire che sono riuscito a installare correttamente la stampante, così facendo:
1) ho disinstallato tutti gli hplip e, successivamente, reinstallato quello specifico per openSUSE 12.3.
Di poi ho installato il plugin mediante Hp Device Manager che ha fatto partire in automatico Xterm, del quale ho seguito i comandi che venivano proposti.
Grazie a tutti e buona domenica.

luc