Dipendenze dei programmi

2 risposte [Ultimo messaggio]
Ritratto di giuse
giuse
(Junior)
Offline
Junior
Iscritto: 08/12/2011
Messaggi: 44

Ciao a tutti non sapevo che titolo dare, comunque il problema è questo: ffmpeg e privo del supporto alla libreria faac così ho scaricato i sorgenti e ho compilato abilitandola, tuttavia non vorrei installarlo nel sistema. Programmi come Arista appoggiandosi a ffmpeg utilizzano quello di sistema, c'è un modo per dire ad Arista di usare l'ffmpeg che ho compilato io?

OpenSUSE 15.1 64 bit - Windows 7 64 bit - Scheda Madre AsRock H77 PRO4/MVP - CPU Intel Core i5-3570 - VGA Gigabyte NVIDIA GeForce GTX 1060 6 Gb - Monitor Led IPS 23" Asus ML239H - RAM DDR3 Corsair Vengeance Low Profile 16Gb - SSD Crucial RealSSD M4 128GB - Hard Disk Interno 3.5" Western Digital Caviar Blu 1TB - Scheda audio ASUS Xonar D1 Low profile PCI 7.1

Ritratto di aksaf
aksaf
(Guru)
Offline
Guru
Iscritto: 08/03/2011
Messaggi: 957

prova con LD_LIBRARY_PATH es.

export LD_LIBRARY_PATH=/percorso/delle/librerie:$LD_LIBRARY_PATH

se ti serve ricompilare ffmpeg (1 0 2) ti conviene prelevare il file src.rpm dal sito di packman, estrarre il file spec, + pacchetto sorgente, modificare quello che serve (ti basterà probabilmente aggiungere a configure l'opzione di compilazione relativa alle librerie che ti servono) e poi ricompilare con rmpbuild in locale il nuovo rpm (vedi guida di A. F.: http://it.opensuse.org/Spec)

Ritratto di mauriziod
mauriziod
(Guru)
Offline
Guru
Iscritto: 01/06/2009
Messaggi: 1706

Faac completo è sui repository
http://packman.inode.at/suse/openSUSE_12.1/
http://packman.inode.at/suse/openSUSE_12.1/Multimedia
http://packman.inode.at/suse/openSUSE_12.1/Essentials
http://opensuse-guide.org/repo/12.1/
oppure
http://download.videolan.org/pub/vlc/SuSE/12.1/

Ovvio che io dispongo della 12.1 dunque cambiare con il numero di versione Suse in possesso.

SO: Linux desktop Sistema: OpenSUSE Leap 15.1 (64bit) KDEE 5.12
SO: Linux desktop Sistema: OpenSUSE Tumbleweed (64bit) KDE 5
Miao