GRUB loading. error: no such partition

10 risposte [Ultimo messaggio]
Ritratto di Lavitz
Lavitz
(Junior)
Offline
Junior
Iscritto: 15/12/2013
Messaggi: 10

***
GRUB loading.
Welcome to GRUB!

error: no such partition.
Entering rescue mode...
grub rescue>
***

Vi spiego cosa ho combinato.
Ho win7 installato sul mio notebook con un singolo hard disk da 750gb, ho deciso di installare per la prima volta OpenSUSE, ovviamente mantenendo win7.
1)Ho preso una pen drive da 8gb e ci ho messo sopra SUSE per l'installazione.
2)Da Win7 apro 'gestione dischi', ho cliccato sulla partizione piu grande da 600 gb e ho cliccato 'riduci' l'ho ridotta esattamente di 100gb.
3)inserisco la pendrive e riavvio, cambio boot e installo suse, credo mi abbia preso in automatico la partizione da 100gb.

4)una volta installato provo OpenSUSE, quando apro YaST o avvio qualche altra applicazione di sistema mi dice che manca la pendrive inserita. Qui iniziano a sargere i miei dubbi, non è che durante l'installazione parte del sistema è stata scritta nella parte libera della pendrive??

5)Allora penso che la soluzione migliore è quella di disinstallare e reinstallare Opensuse scegliendo manualmente le partizioni stavolta.

6)Stupidamente torno a Win7, apro nuovamente 'gestione dischi' elimino la partizione da 100gb in cui avevo messo OpenSUSE. Inoltre formatto la pendrive per poi ricominciare tutto da capo.

Cosa ottengo, se non il suddetto messaggio *** dopo il riavvio. Non posso avviare nè SUSE nè Win7. Per di più la pendrive è inutilizzabile e informattabile anche da altri pc in quanto è diventata misteriosamente da 4mb...

Non dico di avere urgenza a recuperare i file dal PC, spero solo di non aver compromesso nulla e che possiate aiutarmi a recuperare le piene funzionalità del mio pc.

Grazie in anticipo!

Ritratto di pinquadr
pinquadr
(Guru)
Offline
Guru
Iscritto: 20/11/2004
Messaggi: 921

Citazione:

6)Stupidamente torno a Win7, apro nuovamente 'gestione dischi' elimino la partizione da 100gb in cui avevo messo OpenSUSE. Inoltre formatto la pendrive per poi ricominciare tutto da capo.

Sono d'accordo sullo stupidamente, se non sei stato attento alle opzioni hai probabilmente installato il boot-loader di Suse nel settore di avvio del disco. Quando si installa da disco esterno (anche una pendrive USB viene vista come tale) Suse facilmente considera la pendrive come parte del sistema.
Per riformattare la pendrive dovresti usare un programma come PartedMagic (esistono dei CD scaricabili in rete).
La partizione su disco che hai eliminato dovrebbe essere ancora lì in attesa di formattazione.
Mi sembra di capire che puoi accedere ad altre macchine, quindi usa una di quelle per scaricare un CD di utilità come UBCD che può anche essere installato su memoria USB e utilizzato per fare partire Windows 7. Esistono anche diverse utilità per riscrivere il settore di boot del PC.

OpenSuse Leap42 con KDE5 su Intel I7 4930K scheda madre Asus Sabertooth X79 - RAM 32 Gb - scheda video NVIDIA GTX660 1GB - scheda TV Hauppauge WinTV Nova T stick

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2739

Ci dici l'hardware del tuo pc.e se hai un bios efi? Wink

SUSE Tumbleweed- kernel-5.6.14.1.1- kde-plasma-5.18.5.1- Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-390.132.14- SSD samsung 850 pro 512 gb http://opensuse-community.org/

Ritratto di Lavitz
Lavitz
(Junior)
Offline
Junior
Iscritto: 15/12/2013
Messaggi: 10

Ho creato un cd con UBCD come suggerisci, lo inserito e si avvia la seguente schermata:
BIOS
CPU
HDD
Memory
Others
Peripherals
System
Parted Magic
UBCD FreeDOS
User-defined

BOOT next device
reboot
GRUB4DOS menu

Dalla modalità user-defined ho provato alcuni comandi come bootrec /fixmbr, bootrec /fixboot ma non risponde..
come recupero il boot di win7 e di SUSE?
in caso SUSE lo disinstallerei e lo reinstallerei correttamente, sempre che qui vada tutto a buona fine Big Grin

Ho letto dopo il tuo messaggio Dragoncello:
ho un Lenovo ThinkPad Edge E520 Intel Core i3-2330M
per quanto riguarda efi non ne ho idea... Leggo però dal web che è usato nei processori SandyBridge, quindi immagino di si

Ritratto di pinquadr
pinquadr
(Guru)
Offline
Guru
Iscritto: 20/11/2004
Messaggi: 921

Avviato UBCD scegli:

HDD>Boot Management>MBRWork

5) install standard MBR code

dovresti riuscire a ripristinare il settore MBR originale.

OpenSuse Leap42 con KDE5 su Intel I7 4930K scheda madre Asus Sabertooth X79 - RAM 32 Gb - scheda video NVIDIA GTX660 1GB - scheda TV Hauppauge WinTV Nova T stick

Ritratto di Lavitz
Lavitz
(Junior)
Offline
Junior
Iscritto: 15/12/2013
Messaggi: 10

Nella schermata MBRWork seguo i passi da te descritti:
5) Install standard MBR code

poi a schermo compaiono le seguenti opzioni:
Which MBR code Base:
1) Standard
2) Windows 7

Enter choice 1-2?
Che io digiti 1 oppure 2, do la conferma e poi non succede niente, torna alla schermata iniziale di MBRWork.

Leggevo questa piccola guida a MBRWork, ma prima di osare preferisco aspettare consigli, dove ci sono da seguire alcuni step
per recuperare la partizione persa.
http://members.shaw.ca/leesplace/mbrwork.htm

Ritratto di pinquadr
pinquadr
(Guru)
Offline
Guru
Iscritto: 20/11/2004
Messaggi: 921

Ma hai provato a riavviare il sistema dopo le operazioni con MBRWork?

OpenSuse Leap42 con KDE5 su Intel I7 4930K scheda madre Asus Sabertooth X79 - RAM 32 Gb - scheda video NVIDIA GTX660 1GB - scheda TV Hauppauge WinTV Nova T stick

Ritratto di Lavitz
Lavitz
(Junior)
Offline
Junior
Iscritto: 15/12/2013
Messaggi: 10

Certo perchè?
mi compare il messaggio di errore che ho scritto a inizio topic

Ritratto di Lavitz
Lavitz
(Junior)
Offline
Junior
Iscritto: 15/12/2013
Messaggi: 10

Non so più a che santo votarmi, ho messo l'installazione di win7 su usb e ho provato dal prompt comandi del ripristino a fixare il boot ma mi dà 'impossibile trovare elemento' mentre fixMBR mi dice 'operazione completata' tutte le altre operazioni sul bootrec da terminale non si eseguono per un motivo o per l'altro.
Ora provo a creare una nuova live di openSUSE e a reinstallarla, dite che cosi il grub troverà la strada?

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2739

Te lo ripeto,il tuo bios è efi?
Angry

SUSE Tumbleweed- kernel-5.6.14.1.1- kde-plasma-5.18.5.1- Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-390.132.14- SSD samsung 850 pro 512 gb http://opensuse-community.org/

Ritratto di Lavitz
Lavitz
(Junior)
Offline
Junior
Iscritto: 15/12/2013
Messaggi: 10

Lavitz ha scritto:

Ho creato un cd con UBCD come suggerisci, lo inserito e si avvia la seguente schermata:
..............
come recupero il boot di win7 e di SUSE?
in caso SUSE lo disinstallerei e lo reinstallerei correttamente, sempre che qui vada tutto a buona fine Big Grin

Ho letto dopo il tuo messaggio Dragoncello:
ho un Lenovo ThinkPad Edge E520 Intel Core i3-2330M
per quanto riguarda efi non ne ho idea... Leggo però dal web che è usato nei processori SandyBridge, quindi immagino di si

Ti ho gia risposto, entrando nel bios leggo impostazioni UEFI, piu di questo non so..
Comunque in questo momento vi sto scrivendo dal Lenovo con dualboot sia Win7 che SUSE.
Ho risolto alla radice reinstallando SUSE sul precedente, almeno spero!
Solo stavolta sono stato ben attento di non installare parti sulla pendrive di ingresso.
Cosi ovviamente mi ha riscritto la parizione di boot e mi trova entrambi i S.O.
Ora ditemi voi se rischio di non aver sovrascritto la precedente installazione di suse e cosi mi sono giocato una parte di hard disk, come e' successo per la pennetta (ancora non sono riuscito a recuperarla ma continuero' a provarci)

Di per se si portrebbe dire risolto il problema o almeno il grosso di esso.
Grazie a tutti