Programma CAD DraftSight

8 risposte [Ultimo messaggio]
Ritratto di giuse
giuse
(Junior)
Offline
Junior
Iscritto: 08/12/2011
Messaggi: 45

A chi è interessato a programmi stile AutoCAD segnalo questo DraftSight, nativo anche per linux e gratuito per usi non commerciali.

La sola versione RPM è quella per Fedora ed è una beta, ma io l'ho installata sulla 13.1 ed è partita al primo colpo. La lingua dell'interfaccia e della guida è in italiano, come pure i comandi digitati nella console... credevo di sognare...

P.S. Non ho inserito il link perchè altrimenti non riuscivo a postare (filtro antispam), o sono io che non sono capace...

OpenSUSE 15.1 64 bit - Scheda Madre AsRock H77 PRO4/MVP - CPU Intel Core i5-3570 - VGA Gigabyte NVIDIA GeForce GTX 1060 6 Gb - Monitor Led IPS 23" Asus ML239H - RAM DDR3 Corsair Vengeance Low Profile 16Gb - SSD Crucial RealSSD M4 128GB - Hard Disk Interno 3.5" Western Digital Caviar Blu 1TB - Scheda audio ASUS Xonar D1 Low profile PCI 7.1

Ritratto di zioandrea
zioandrea
(Geek)
Offline
Geek
Iscritto: 06/04/2013
Messaggi: 100

Ciao, ho provato ad installare anch'io DraftSight. Mi ha messo tutti i pacchetti in /var/opt/dassault-systemes.
Quando cerco di lanciare /opt/dassault-systemes/DraftSight/Linux/DraftSight PGF64-4_3D.dwg  
mi risponde:
DraftSight: error while loading shared libraries: libGLU.so.1: cannot open shared object file: No such file or directory

Probabilmente occorre settare opportunamente il path per la ricerca delle librerie.
Però, tra i file installati, non riesco a trovare nessun README che spieghi cosa e come fare Sad

Hai qualche suggerimento da darmi?

Andrea

Ritratto di max.riservo
max.riservo
(Monster)
Offline
Monster
Iscritto: 04/02/2012
Messaggi: 202

Per risolvere le dipendenze consiglio di installare il file rpm con il comando (loggati come su) :
zypper in nomefile.rpm

Con questo comando vengono anche scaricati eventuali pacchetti necessari (e non presenti nel file rpm / sistema) : mi sembra che per Draftsight manchi qualche libreria audio (?) a 32 bit.

Nota per Draftsight : per usarlo è necessaria la registrazione. In tutti i PC nei quali l' ho installato (partendo dalla 11.4), passato un anno dalla registrazione, il software NON è più utilizzabile e NON è possibile ri-registrarlo ! Per 'risolvere' il problema l' unico modo è passare il PC ad una nuova versione 'pulita' di Opensuse (ovvero installare in una partizione nuova la nuova versione del SO).

A volte sono presente anche in altri forum di programmazione ....

Ritratto di zioandrea
zioandrea
(Geek)
Offline
Geek
Iscritto: 06/04/2013
Messaggi: 100

Per l'installazione avevo usato Zypper. Quindi il problema non è quello.

Invece, potrebbe essere legato alla mancata registrazione. Devo capire perché non me l'ha chiesta.

Oppure, le mie versioni di libGLU.so.1 (ho /usr/lib/libGLU.so.1 e /usr/lib/libGLU.so.1.3.1) non sono compatibili con quella richiesta da Draftsight.

Andrea

Ritratto di giuse
giuse
(Junior)
Offline
Junior
Iscritto: 08/12/2011
Messaggi: 45

Ciao, ho dato uno sguardo veloce... nel mio sistema sono installate sia la versione a 32 che a 64 bit della libreria libGLU.

Se siamo fortunati...

OpenSUSE 15.1 64 bit - Scheda Madre AsRock H77 PRO4/MVP - CPU Intel Core i5-3570 - VGA Gigabyte NVIDIA GeForce GTX 1060 6 Gb - Monitor Led IPS 23" Asus ML239H - RAM DDR3 Corsair Vengeance Low Profile 16Gb - SSD Crucial RealSSD M4 128GB - Hard Disk Interno 3.5" Western Digital Caviar Blu 1TB - Scheda audio ASUS Xonar D1 Low profile PCI 7.1

Ritratto di zioandrea
zioandrea
(Geek)
Offline
Geek
Iscritto: 06/04/2013
Messaggi: 100

In questi giorni sono stato molto preso dal lavoro e non ho potuto riprendere in mano il problema.

Però, più ci penso e più mi convinco che il problema sia legato alla registrazione.
Io ho scaricato il file da http://www.draftsight.com/download-linux-fedora e non mi è stata chiesta nessuna registrazione,
L'ho installato con zypper, nessuna richiesta!

Però Max.riservo dice che

Citazione:

Nota per Draftsight : per usarlo è necessaria la registrazione.

quindi da qualche parte devo registrarmi e in qualche modo devo dargli un codice di registrazione, Dove, come, quando?

Andrea

Ritratto di max.riservo
max.riservo
(Monster)
Offline
Monster
Iscritto: 04/02/2012
Messaggi: 202

Questo è il sito ufficiale dal quale ho sempre scaricato l' ultima versione (ovviamente la versione per fedora -> .rpm) di draftsight. Attualmente siamo alla V1R5.1 beta (sarà perchè è liberamente utilizzabile ma è sempre rimasto allo stadio BETA !).

Come chiaramente riportato nella pagina è necessario ATTIVARE il sw (mi scuso se impropriamente ho scritto registrare ....).

A volte sono presente anche in altri forum di programmazione ....

Ritratto di mauriziod
mauriziod
(Guru)
Offline
Guru
Iscritto: 01/06/2009
Messaggi: 1761

Ti mancano le librerie GLU (calcoli algebrici) che sono diverse. Cerca "libglu" e caricati tutto da Yast->gestore_dei_programmi non GLUT che è cosa diversa. Anche glu-devil.
Wink

I programmi di Fedora sono usabili anche in Suse per via di un accordo RedHat/Novell dunque non c'è problema se si interscambi tra Suse 13 e fedora 9.

Quel programma occorre di un registrazione, registrati e poi ti viene detto come inserire l'attivazione di programma.

SO: Linux desktop Sistema: OpenSUSE Leap 15.1 (64bit) KDEE 5.12
SO: Linux desktop Sistema: OpenSUSE Tumbleweed (64bit) KDE 5
Miao

Ritratto di calipso
calipso
(Geek)
Offline
Geek
Iscritto: 23/01/2014
Messaggi: 51

Grazie ragazzi stavo diventando matto nell'installare quel pacchetto, mi diceva continuamente che non era supportato dal mio motore.
Con le vostre istruzione è andato tutto a buon fine. Wave