Ubuntu ha rubato l'avvio

5 risposte [Ultimo messaggio]
Ritratto di babay2004
babay2004
(Junior)
Offline
Junior
Iscritto: 07/11/2009
Messaggi: 9

Buongiorno; ho installato tranquillamente l'ultima versione di Opensuse. Ho l'Hard Disk partizionato dove risiede Windows 7 e Ubuntu 14.04;
Opensuse mi ha riconosciuto gli altri sistemi operativi che potavono tranquillamente avviarsi; è successo però che con l'ultimo aggiornamento di Ubuntu al riavvio si è ripresa la priorità e per giunta non ho la possibilità di avviare Opensuse; ho provato diverse alternative proposte dal Wiki di ubuntu ma niente da fare non son riuscito a far riavviare opensuse.
Qualche dritta per evitare di reinstallare tutto daccapo?

Ritratto di gi-gi
gi-gi
(Moderatore)
Offline
Moderatore
Iscritto: 09/12/2014
Messaggi: 418

Ciao.

Premetto che non conosco Ubuntu/Gnome.

In opensuse YaST --> Sistema --> Bootloader --> Opzioni bootloader (scheda) c'è il flag "Verifica altro OS" che dovrebbe risolvere il tuo problema. Potrebbe esistere qualcosa di simile in qualche utility di Ubuntu.

Un'alternativa, se hai il DVD/Pendrive di installazione di Opensuse, è avviare opensuse a lì (c'è l'opzione "Avvio da Hard Disk" o qualcosa di simile) e poi intervenire con YaST come detto sopra.

Se neppure questo funziona, in Ubuntu come utente superuser/root edita il file /boot/grub2/grub.cfg e posta il contenuto.

gigi

Ritratto di babay2004
babay2004
(Junior)
Offline
Junior
Iscritto: 07/11/2009
Messaggi: 9

gi-gi ha scritto:

Ciao.

Premetto che non conosco Ubuntu/Gnome.

In opensuse YaST --> Sistema --> Bootloader --> Opzioni bootloader (scheda) c'è il flag "Verifica altro OS" che dovrebbe risolvere il tuo problema. Potrebbe esistere qualcosa di simile in qualche utility di Ubuntu.

Un'alternativa, se hai il DVD/Pendrive di installazione di Opensuse, è avviare opensuse a lì (c'è l'opzione "Avvio da Hard Disk" o qualcosa di simile) e poi intervenire con YaST come detto sopra.

Se neppure questo funziona, in Ubuntu come utente superuser/root edita il file /boot/grub2/grub.cfg e posta il contenuto.

La prima soluzione è impraticabile in quanto non riesco ad accedere a opensuse:
Appena posso provo la seconda; nel caso non funziona proverò a postare il risultato della terza.
Per ora ti ringrazio; mi scoccerebbe rinunciare ad opensuse per una stupidaggine dato che lo preferisco ad Ubuntu.

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2728

Entri nel bios e metti come prima partenza il boot di suse quindi una volta entrato,da yast vai sul boot e aggiorni.
ciao

SUSE Tumbleweed- kernel-5.3.8-1 kde-plasma-5.17.2.1- Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-390.116.51- SSD samsung 850 pro 512 gb http://opensuse-community.org/

Ritratto di babay2004
babay2004
(Junior)
Offline
Junior
Iscritto: 07/11/2009
Messaggi: 9

Non sapevo che si potesse intervenire sul BIOS. Per ora ho risolto reinstallando il tutto.
comunque proverò anche con quello.

Ritratto di mauriziod
mauriziod
(Guru)
Offline
Guru
Iscritto: 01/06/2009
Messaggi: 1701

secondo me Ubunto che riscrive il Grub (del resto sono due grub diversi e quello di Suse è il Grub2)

Dunque la procedura è simile al "Ripristinare il grub"

Nota: È per Suse 13.2, ma la procedura è uguale per tutti.

SO: Linux desktop Sistema: OpenSUSE Leap 15.1 (64bit) KDEE 5.12
SO: Linux desktop Sistema: OpenSUSE Tumbleweed (64bit) KDE 5
Miao