Setup vecchio modem ADSL

3 risposte [Ultimo messaggio]
Ritratto di forghy
forghy
(Newbie)
Offline
Newbie
Iscritto: 08/02/2016
Messaggi: 3

Buongiono a tutti.

Ho installato Leap su un PC che vorrei collegare ad Internet tramite un modem EB1070 (Telecom / Alice).

Il modem è connesso al PC tramite porta Ethernet (eth0)

Il modem funziona correttamente se utilizzato con opensuse 12.3 impostando i parametri di connessione dai moduli di Yast DSL e Modem.

Non riesco invece a configurarlo in Leap in quanto in Yast i due moduli indicati non sono più disponilibi perchè (immagino) wicked non supporta pppoe.

Ho seguito le indicazioni di questo forum https://forums.opensuse.org/showthread.php/502199-UPGRADING-REMOVES=

ma, a causa delle mie ridotte conoscenze delle reti, non riesco a farlo funzionare.

Riporto il risultato dei comandi ifconfig e route -n per riferimento.

C:~ # ifconfig
eth0      Link encap:Ethernet  HWaddr 08:60:6E:D8:B6:5A  
          inet addr:192.168.1.2  Bcast:255.255.255.255  Mask:255.255.255.0
          inet6 addr: fe80::a60:6eff:fed8:b65a/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:256 errors:0 dropped:0 overruns:0 frame:0
          TX packets:360 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:27202 (26.5 Kb)  TX bytes:33915 (33.1 Kb)
 
lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:1336 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1336 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:106364 (103.8 Kb)  TX bytes:106364 (103.8 Kb)
 
ppp0      Link encap:Point-to-Point Protocol  
          inet addr:87.15.150.19  P-t-P:192.168.100.1  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
          RX packets:97 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3 
          RX bytes:9452 (9.2 Kb)  TX bytes:54 (54.0 b)

PC:~ # route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.1.1     0.0.0.0         UG    0      0        0 eth0
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0
192.168.100.1   0.0.0.0         255.255.255.255 UH    0      0        0 ppp0  

Il seguente invece è il dettaglio del servizio ppp@TIM creato seguendo il thread riportato sopra

ppp@TIM.service - PPP link to TIM
   Loaded: loaded (/etc/systemd/system/ppp@.service; enabled)
   Active: active (running) since Tue 2016-02-09 14:53:46 CET; 37s ago
     Docs: man:pppd(8)
  Process: 4334 ExecStart=/usr/sbin/pppd call %I linkname %I updetach nolog (code=exited, status=0/SUCCESS)
 Main PID: 4341 (pppd)
   CGroup: /system.slice/system-ppp.slice/ppp@TIM.service
           `-4341 /usr/sbin/pppd call TIM linkname TIM updetach nolog
 
Feb 09 14:53:45 PC pppd[4334]: pppd 2.4.7 started by root, uid 0
Feb 09 14:53:45 PC pppd[4334]: PPP session is 2762
Feb 09 14:53:45 PC pppd[4334]: Connected to 00:90:1a:a4:46:da via interface eth0
Feb 09 14:53:45 PC pppd[4334]: Using interface ppp0
Feb 09 14:53:45 PC pppd[4334]: Connect: ppp0  eth0
Feb 09 14:53:46 PC pppd[4334]: PAP authentication succeeded
Feb 09 14:53:46 PC pppd[4334]: peer from calling number 00:90:1A:A4:46:DA authorized
Feb 09 14:53:46 PC pppd[4334]: not replacing default route to eth0 [192.168.1.1]
Feb 09 14:53:46 PC pppd[4334]: local  IP address 79.31.142.200
Feb 09 14:53:47 PC pppd[4341]: Script /etc/ppp/ip-up finished (pid 4342), status = 0x0

Qualcuno mi sa aiutare?

Grazie

Ritratto di mauriziod
mauriziod
(Guru)
Offline
Guru
Iscritto: 01/06/2009
Messaggi: 1686

ATTENZIONE è sperimentale e non te lo consiglio:

per supportare questo devi installare
https://software.opensuse.org/package/smpppd?search_term=pppd
inoltre
https://software.opensuse.org/package/modem-manager-gui
e anche installare Wvdial anche usb_modeswitch

nel caso, non funzionasse anche questo
https://software.opensuse.org/package/rp-pppoe?search_term=pppo

Nota: controlla in Yast ->rete che sia settato (dovrebbe comparire) ifup o pppd

CONSIGLIATO:

È più facile definirlo in Wiked. (il modem deve essere già acceso e connesso) Entra in yast->rete poi (deve essere definito wiked) andare in "panoramica" e qui andare su rete eth0 se è connesso sulla porta LAN, USB se è connesso su porta USB, modem se lo riconosce direttamente e qui entrare nella configurazione guidata dicendo di modificarla e poi ogni modifica cliccare il bottone "avanti".

Qui un mio vecchio articolo, tieni conto che l'icona yast "Modem" adesso è integrata con "reti" e che ifup adesso è wiked.

Altro sistema è networkmanager, qui consiglio di mettere il modem (deve essere già acceso e connesso) quando il PC è spento, avviare Suse, e di solito networkmanager si accorge che esiste e lo configuri da quello.

Nel caso possiamo provare con WvDial...

SO: Linux desktop Sistema: OpenSUSE Leap 15 (32bit) TDE 4 / Mate
SO: Linux desktop Sistema: OpenSUSE Leap 15 (64bit) KDE 5
Miao

Ritratto di forghy
forghy
(Newbie)
Offline
Newbie
Iscritto: 08/02/2016
Messaggi: 3

Grazie per la risposta.

Proverò con calma nel week-end le opzioni che mi hai prospettato.

Ritratto di forghy
forghy
(Newbie)
Offline
Newbie
Iscritto: 08/02/2016
Messaggi: 3

Ho risolto grazie ad un aggiornamento del thread originario.

Grazie comunque a mauriziod per la sua risposta.