Leap-42.1 non parte sessione grafica

3 risposte [Ultimo messaggio]
Ritratto di zioandrea
zioandrea
(Geek)
Offline
Geek
Iscritto: 06/04/2013
Messaggi: 81

Salve,
ho appena finito di installare la nuova Leap-42.1. L'installazione non ha dato nessun problema. Quando
ho riavviato il sistema, tutto è filato liscio fino alla schermata di login, forse un po' troppo grigia.
Ho dato la password, lo schermo si è annerito ed è subito tornato alla schermata di login.
La password è giusta perché se la cambio "protesta" e se passo su una console testuale tutto fila liscio.
Probabilmente c'è qualche problema con la mia scheda NVidia.

Qualche consiglio su come riconfigurarla?
Posso utilizzare la vecchia opensuse-13.1, installata su un'altra partizione dello stesso PC.

Andrea

Ritratto di Grinch
Grinch
(Guru)
Offline
Guru
Iscritto: 05/12/2011
Messaggi: 880

Che scheda Nvidia è ?
Hai aggiunto il repo Nvidia ?
Hai installato i Driver Proprietari ?

Ritratto di zioandrea
zioandrea
(Geek)
Offline
Geek
Iscritto: 06/04/2013
Messaggi: 81

I repo Nvidia non erano previsti nell'installazione NET.
Adesso non ho l'ambiente grafico di Yast quindi penso che avrò qualche difficoltà ad applicare i consigli di SuSE-wiki:

Citazione:


* add the NVIDIA repos in YaST (YaST->Software->Software Repositories->Add->Community Repositories->NVIDIA Graphics Drivers)
* run an online update (or zypper inr in a shell as root). (things are more complicated on openSUSE Leap 42.1, see below)
+ After installation is done restart computer.

The packages contain the correct 'supplements:' so Zypper will find the correct modules for your card. Unfortunately on openSUSE Leap 42.1 these 'supplemements' are being ignored by default by YaST (boo#953522). Therefore you need to select 'Extras/Install All Matching Recommended Packages' in 'Software Management' for autoselection and installation of the appropriate NVIDIA driver packages. When using 'zypper inr' you're not affected by this issue on openSUSE Leap 42.1.

Spero di aver già attivato l'opzione 'Extras/Install All Matching Recommended Packages'

Come driver dovrebbero andare bene gli analoghi di quelli che ho sulla 13.1

nvidia-computeG04-361.42-21.1.x86_64
nvidia-gfxG04-kmp-desktop-361.42_k3.11.6_4-21.1.x86_64
x11-video-nvidiaG04-361.42-21.1.x86_64
nvidia-glG04-361.42-21.1.x86_64

Stanotte mi ero un po' spaventato ed ero corso a chiedere aiuto. Dopo pranzo provo a risolverlo da solo. Poi tornerò a chiedere consiglio o a raccontare come ho fatto.

Andrea

Ritratto di zioandrea
zioandrea
(Geek)
Offline
Geek
Iscritto: 06/04/2013
Messaggi: 81

Fatto al volo ed è andato tutto bene.
L'importante è ricordarsi che nell'interfaccia non-grafica di Yast si deve usare il tasto Tab per passare da una opzione all'altra.
Ho approfittato dell'aggiornamento dell'elenco dei repository per aggiungere anche Pacman e Adobe-flash.

ciao, Andrea