Lettore: SDcard

4 risposte [Ultimo messaggio]
Ritratto di bastia
bastia
(Junior)
Offline
Junior
Iscritto: 09/12/2015
Messaggi: 24

Ciao a tutti,

ho un problema con il lettore della schedina SD.
Portatile Envy15.

lspci -nnk |grep -iA3 card
03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS522A PCI Express Card Reader [10ec:522a] (rev 01)
	Subsystem: Realtek Semiconductor Co., Ltd. RTS522A PCI Express Card Reader [10ec:522a]
04:00.0 3D controller [0302]: NVIDIA Corporation GM107M [GeForce GTX 950M] [10de:139a] (rev a2)
	Subsystem: Hewlett-Packard Company Device [103c:80dd]
	Kernel modules: nouveau

rpm -qa "*kernel*"
kernel-devel-4.1.27-27.1.noarch
kernel-default-devel-4.1.27-27.1.x86_64
texlive-l3kernel-2013.84.svn_4469svn29409-17.5.noarch
kernel-macros-4.1.31-30.1.noarch
kernel-default-devel-4.1.31-30.2.x86_64
kernel-default-4.1.27-27.1.x86_64
kernel-default-4.1.31-30.2.x86_64
texlive-l3kernel-doc-2013.84.svn_4469svn29409-17.5.noarch
kernel-devel-4.1.31-30.1.noarch
kernel-firmware-20160503-3.1.noarch

Leggendo un po in giro ho trovato. da questa discussione https://forums.opensuse.org/showthread.php/518820-RTS522A-PCI-Express-Card-Reader-under-openSUSE-Leap-42-1-(x86_64):

Citazione:

Your Card Reader only works with Kernel 4.4 and higher.

In openSUSE leap, Kernel 4.1 is working.

Linux luca 4.1.31-30-default #1 SMP PREEMPT Wed Aug 24 06:20:09 UTC 2016 (de9ddf8) x86_64 x86_64 x86_64 GNU/Linux

lsb_release -a
LSB Version:	n/a
Distributor ID:	SUSE LINUX
Description:	openSUSE Leap 42.1 (x86_64)
Release:	42.1
Codename:	n/a

Qualcuno ha riscontrato/risolto o sa aiutarmi?
Praticamente quando inserisco la scheda nel lettore non appare/succede niente, nenahce con 'dmesg'....

Grazie a tutti.

p.s. se volessi aggiornare il kernel da 4.1 a 4.7 o altro, quale sarebbe la preocedura senza fare danni? Grazie ancora

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2726

Inserire un repository,andando in:
http://software.opensuse.org/421/it
e scrive Kernel,ti si apre questo:
http://software.opensuse.org/search?utf8=%E2%9C%93&q=kernel&search_devel=false&search_unsupported=false&baseproject=openSUSE%3ALeap%3A42.1
scegli il kernel,e abiliti in yast il repository del kernel che scegli.
quindi aggiorni il kernel,una volta aggiornato apri una shell e come root dai:
grub2-mkconfig -o /boot/grub2/grub.cfg
il (-o) è la lettera.
riavvii il sistema. se usi i driver nvidia devi installarteli a manina,non prima di aver cancellato quelli installati da repository,mettendo in blacklist i driver nouveau,questae ultime cose le fai prima di aggiornare il nuovo kernel.
spero di essere stato esaustivo.
ciao

SUSE Tumbleweed- kernel-5.1.16-1-2 kde-plasma-5.16.2- Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-390.116.51- SSD samsung 850 pro 512 gb http://opensuse-community.org/

Ritratto di bastia
bastia
(Junior)
Offline
Junior
Iscritto: 09/12/2015
Messaggi: 24

Intanto grazie per la celere risposta.

lspci -knn | grep -EA2 'VGA|3D'
00:02.0 VGA compatible controller [0300]: Intel Corporation Broadwell-U Integrated Graphics [8086:1616] (rev 09)
	Subsystem: Hewlett-Packard Company Device [103c:80dd]
	Kernel driver in use: i915
--
04:00.0 3D controller [0302]: NVIDIA Corporation GM107M [GeForce GTX 950M] [10de:139a] (rev a2)
	Subsystem: Hewlett-Packard Company Device [103c:80dd]
	Kernel modules: nouveau

Deduco che sto utilizzando i driver 'non' proprietari; quindi non dovrei cancellare niente....
Abbi pazienza...

Citazione:

ettendo in blacklist i driver nouveau,questae ultime cose le fai prima di aggiornare il nuovo kernel.


sarebbe? Angel

Grazie

p.s. programmi e dati salvati restano incontaminati da questa procedura? Smile

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2726

Avendo due schede grafiche,dovresti installare i driver bumblebee,per i nvidia,ma se in uso ci sono i nouveau,aggiornando il kernel non dovrebbe esserci nessun problema,quindi ti basta mettere il repository del kernel 4.7.4xx dopodichè dai da shell come root il comando:
grub2-mkconfig -o /boot/grub2/grub.cfg
ti ricordo che se non sei intervenuto nel file /etc/zypp/zypp.conf...resta attivo anche il vecchio kernel,per cui non ci sono problemi.

SUSE Tumbleweed- kernel-5.1.16-1-2 kde-plasma-5.16.2- Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-390.116.51- SSD samsung 850 pro 512 gb http://opensuse-community.org/

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2726

Novità?

SUSE Tumbleweed- kernel-5.1.16-1-2 kde-plasma-5.16.2- Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-390.116.51- SSD samsung 850 pro 512 gb http://opensuse-community.org/