Problemi di accesso al sistema operativo in Grub

7 risposte [Ultimo messaggio]
Ritratto di Paloo
Paloo
(Junior)
Offline
Junior
Iscritto: 18/01/2017
Messaggi: 15

Come si vede dall'immagine, accedendo nel grub a Opensuse ho questo errore:

/boot/vmlinuz-4.4.59-4-default has invalid signature.
Caricamento ramdisk iniziale...
errore: è necessario caricare il kernel prima.

Premere un tasto per continuare.

Ritratto di gi-gi
gi-gi
(Moderatore)
Offline
Moderatore
Iscritto: 09/12/2014
Messaggi: 362

Ciao.

Sulla schermata iniziale di GRUB riesci a selezionare la versione precedente del kernel e ad accedere al S.O.?

Da quale sito hai installato la versione 4.4.59-4-default?

gigi

Ritratto di Paloo
Paloo
(Junior)
Offline
Junior
Iscritto: 18/01/2017
Messaggi: 15

Sì, da quando ho questo problema lavoro così, ma oggi non riesco ad accedere neanche con la versione precedente.
Dopo la procedura di avvio compare una bella schermata nera. Nero completo. Devo spegnere e accedere con Windows.

Ho scaricato il s.o. dal sito web ufficiale e funzionava perfettamente, con mia soddisfazione, essendo nuovo di Opensuse.

Ritratto di gi-gi
gi-gi
(Moderatore)
Offline
Moderatore
Iscritto: 09/12/2014
Messaggi: 362

Se hai il DVD di installazione potresti provare ad eseguire un aggiornamento del S.O selezionando SOLO il pacchetto del kernel.

Ricordo di averlo fatto diversi anni fa, però da allora il programma di installazione del SO è stato modificato e comunque non ricordo esattamente i passaggi che ho effettuato.

NB: Se decidi di tentare questa strada accertati di NON FORMATTARE nessuna partizione e se hai dubbi fermati e posta il quesito.

gigi

Ritratto di Paloo
Paloo
(Junior)
Offline
Junior
Iscritto: 18/01/2017
Messaggi: 15

Confesso che la cosa mi lascia un po' frustrato. Ho usato per anni Windows e Ubuntu e ne ho viste di tutti i colori, ma non mi è accaduto nulla di simile: non poter accedere per nulla ad un sistema operativo. Fra l'altro un pc nuovo, con pochi mesi di vita.
Se mi dite una volta inserito il dvd cosa devo fare esattamente ci provo. Se devo rischiare di perdere dati, o reinstallare tutto, passo a Windows 10.

Potrebbe essere un problema di compatibilità con la scheda video (visto che compare un errore legato a Radeon: VCE init error -22)?

Ritratto di gi-gi
gi-gi
(Moderatore)
Offline
Moderatore
Iscritto: 09/12/2014
Messaggi: 362

Sicuramente ti trovi in una situazione delicata, ma fino a quando non formatti non perdi nulla.

Io non sono in grado al momento di seguirti passo-passo, ma il programma di installazione non esegue nulla fino a quando non confermi esplicitamente di procedere con l'installazione, quindi facendo molta attenzione potresti anche provare.

Se non hai premura potresti anche aspettare che qualche altro utente del forum proponga una soluzione migliore.

Per quanto riguarda l'errore della scheda video non saprei...

Quello che non comprendo è dove hai preso esattamente quella versione del kernel che non trovo sul sito ufficiale come aggiornamento di openSuse 42.2 e che immagino possa essere l'origine di tutti i tuoi problemi in assenza di malfunzionamenti hardware.

gigi

Ritratto di Paloo
Paloo
(Junior)
Offline
Junior
Iscritto: 18/01/2017
Messaggi: 15

Ho disabilitato il secure boot di Windows. Il messaggio di errore relativo al kernel non appare più, però permane quello relativo a Radeon.

Dopo questo errore, schermo nero e pc che non reagisce se non al pulsante di spegnimento.

Ritratto di Paloo
Paloo
(Junior)
Offline
Junior
Iscritto: 18/01/2017
Messaggi: 15

Ho risolto con un aggiornamento del kernel accedendo con ctrl+alt+f1 alla una sessione di terminale (la sessione grafica non funzionava per niente e dopo il grub arrivava uno schermo nero da dove non si poteva uscire) e lanciando Yast2 nella versione da terminale dove ho aggiunto la repository del jernel stabile.
Potrebbe essere un bug del kernel legato alla scheda Radeon.