Codecs non trovati.

7 risposte [Ultimo messaggio]
Ritratto di GiulioGG
GiulioGG
(Monster)
Offline
Monster
Iscritto: 26/05/2009
Messaggi: 218

Ho installato openSUSE-Leap-42.2-x86_64 , ma tutti i suoi players sono privi dei necessari codecs, che non trovo neppure nei repositories on-line installati di default da Yast. Che fare?

Ritratto di gi-gi
gi-gi
(Moderatore)
Offline
Moderatore
Iscritto: 09/12/2014
Messaggi: 385

Ciao.

Hai aggiunto ai repository di default quelli di Packman?

(YaST --> Repository dei programmi --> Aggiungi --> Repository della comunità --> Avanti --> Packman).

gigi

Ritratto di capejeaspaje
capejeaspaje
(Geek)
Offline
Geek
Iscritto: 08/07/2007
Messaggi: 112

Dovrebbe essere questa la pagina che cerchi

http://opensuse-community.org/

si installano via 1 click.

Terminata la procedura potrai ascoltare i tuoi mp3 preferiti. Smile

Ritratto di GiulioGG
GiulioGG
(Monster)
Offline
Monster
Iscritto: 26/05/2009
Messaggi: 218

gi-gi ha scritto:

Ciao.

Hai aggiunto ai repository di default quelli di Packman?

(YaST --> Repository dei programmi --> Aggiungi --> Repository della comunità --> Avanti --> Packman).

Ho aggiunto il repository Packman da cui ho scaricato la maggior parte dei players senza codecs. Occorrerebbe un sistema più semplice e pratico per scaricare i players e i codecs ad essi necessari.

Ritratto di GiulioGG
GiulioGG
(Monster)
Offline
Monster
Iscritto: 26/05/2009
Messaggi: 218

capejeaspaje ha scritto:

Dovrebbe essere questa la pagina che cerchi

http://opensuse-community.org/

si installano via 1 click.

Terminata la procedura potrai ascoltare i tuoi mp3 preferiti. Smile

Diffido delle installazioni "via 1 click" dopo le esperienze che ne ho fatto in passato. Provvisoriamente ho risolto il problema accontentandomi di quel che funziona per l'audio (Audacity) e per i filmati installando Vlc dal suo sito. Mi restano irrisolti i problemi di montaggio e conversione di formato dei miei filmati, eccetto quel che può fare Handbrake. Grazie per i suggerimenti.

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2628

GiulioGG ha scritto:

capejeaspaje ha scritto:

Dovrebbe essere questa la pagina che cerchi

http://opensuse-community.org/

si installano via 1 click.

Terminata la procedura potrai ascoltare i tuoi mp3 preferiti. Smile

Diffido delle installazioni "via 1 click" dopo le esperienze che ne ho fatto in passato. Provvisoriamente ho risolto il problema accontentandomi di quel che funziona per l'audio (Audacity) e per i filmati installando Vlc dal suo sito. Mi restano irrisolti i problemi di montaggio e conversione di formato dei miei filmati, eccetto quel che può fare Handbrake. Grazie per i suggerimenti.


Se diffidi di 1 click,allora vai di linea di comando,o non ti fidi neanche di questa?
su -c 'zypper install vlc-codecs xvid4conf xvidcore libxine2-codecs libtheora0 dirac flac w32codec-all speex ffmpeg ffmpeg2theora mpeg2dec h264enc lame lame-mp3rtp x264 xvidenc twolame aften gstreamer-0_10-fluendo-mp3 gstreamer-0_10-plugins-fluendo_mpegdemux gstreamer-0_10-plugins-fluendo_mpegmux'
http://opensuse-guide.org/codecs.php

SUSE Tumbleweed- kernel-4.13.1-1.1- kde-plasma-5.10.5- Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-384.59- SSD samsung 850 pro 512 gb http://opensuse-community.org/

Ritratto di GiulioGG
GiulioGG
(Monster)
Offline
Monster
Iscritto: 26/05/2009
Messaggi: 218

dragoncello ha scritto:


su -c 'zypper install vlc-codecs xvid4conf xvidcore libxine2-codecs libtheora0 dirac flac w32codec-all speex ffmpeg ffmpeg2theora mpeg2dec h264enc lame lame-mp3rtp x264 xvidenc twolame aften gstreamer-0_10-fluendo-mp3 gstreamer-0_10-plugins-fluendo_mpegdemux gstreamer-0_10-plugins-fluendo_mpegmux'

Dando il comando sopraindicato c'è il rischio di metter fuori uso, per coflitto tra file diversi ma omonimi, la versione funzionante di Vlc che ho installato dal suo sito e non da Packman ?

Ritratto di CarloCC
CarloCC
(Geek)
Offline
Geek
Iscritto: 06/04/2017
Messaggi: 66

Io ti posso dire come faccio io con i codec, lo so che in OS sono un po una rottura, ma una volta installati non dovresti più preoccuparti.
Aggiungi packman, apri il gestore dei pacchetti al posto di visualizza metti repository e selezioni packman, installa tutti i codec che trovi ffmpeg e gstreamer se ti esce il messaggio di conflitto seleziona sempre "cambio di fornitore e poi installa. Al termine per sicurezza riseleziona il repo di packman in alto clicca su "passa i pacchetti di sistema a quelli di questo repository", anche qui se ci sono notifiche di conflitti (e ci saranno) clicca sempre sul cambio di fornitore. In questo modo tutto il multimediale sarà gestito da packman. Per Vlc io lo cerco e lo installo, oltre ai pacchetti pre-selezionati installa vlc-codec e sopratutto vlc-devel. In questo modo io non ho mai avuto problemi. Ciao
Edit ...nel caso Vlc non visualizza i filmati vai nelle preferenze di Vlc, vai nella scheda video e dove Windows decorations metti X11video autput(XCB).

Acer Aspire E1-522 Amd Quad-Core E2-3800--Amd Radeon 8280
Acer Aspire M5500 Intel Core 2 - grafica Nvidia GeForce 315
Distribuzione OpenSuse Leap 42.2 Kde Plasma5 - Tumbleweed