HD esterno USB 3 cinese che openSUSE Leap 15.0 non riesce neppure a "vedere".

6 risposte [Ultimo messaggio]
Ritratto di GiulioGG
GiulioGG
(Monster)
Offline
Monster
Iscritto: 26/05/2009
Messaggi: 267

Mi son lasciato tentare dall'aspetto accattivante e dalle dichiarate "driverless" e "plug-and-play" anche con i s.o. a kernel Linux e ho così acquistato un HD esterno USB cinese, però openSUSE non lo "vede" neppure (e neppure Ubuntu). C'è qualcuno che sia riuscito in una situazione simile a recuperare all'uso un HD? Allego immagine del disco in questione.

P.S. del 2019.04.15: Allego anche gli "output" dei comandi dmesg e lsusb.

P.S. del 2019.04.19:
Usando un cavetto di connessione USB 3 diverso da quello in dotazione, KDE Partition Manager riesce a "vedere" il disco, la sua capacità, i n. di testine cilindri settori, lo "vede" non partizionato e privo di tabella valida delle partizioni, ma non riesce a farci nulla perchè non riesce ad "aprire il disco", come è detto nel messaggio di errore. Allego anche l'"output" della interrogazione "sudo fdisk -l /dev/sdb".

AllegatoDimensione
disco_esterno_usb.png770.19 KB
info_su_hd_usb_da_dmesg.txt1.98 KB
info_su_hd_usb_da_lsusb.txt7.31 KB
info_su_hd_usb_da_sudo_fdisk_l_dev_sdb.txt2.67 KB
Ritratto di Grinch
Grinch
(Guru)
Offline
Guru
Iscritto: 05/12/2011
Messaggi: 877

Hai provato a usare gparted live cd https://gparted.org/livecd.php

Ritratto di GiulioGG
GiulioGG
(Monster)
Offline
Monster
Iscritto: 26/05/2009
Messaggi: 267

Grinch ha scritto:

Hai provato a usare gparted live cd https://gparted.org/livecd.php

Avendo ambiente KDE uso parted, che riconosce tutti i supporti di memoria del sistema fuorchè lo HD in questione; gparted può fare di più oppure è il suo uso da supporto esterno che può far la differenza?

P.S. del 2019.03.30: Ho provato anche a usare gparted live da cd che mi ha rivelato soltanto l'esistenza di un misterioso e inafferrabile device sdb connesso al sistema: "Could not stat device /dev/sdb - not such file or directory".

Ritratto di CarloCC
CarloCC
(Monster)
Offline
Monster
Iscritto: 06/04/2017
Messaggi: 279

Il bios lo vede ?

Acer Aspire E1-522 Amd Quad-Core E2-3800--Amd Radeon 8280
Acer Aspire M5500 Intel Quad-Core - Amd Radeon R5 230
Distribuzione openSUSE Leap 15 Kde Plasma5 - Tumbleweed

Ritratto di GiulioGG
GiulioGG
(Monster)
Offline
Monster
Iscritto: 26/05/2009
Messaggi: 267

CarloCC ha scritto:

Il bios lo vede ?

Non lo so; nella schermata "Drives" del BIOS si vede soltanto: "SATA-0" "SATA-1" "M.2 PCIe SSD-0" indipendentemente dal fatto che lo HD in questione sia connesso o no.

P.S. del 2019.04.05: Come posso accertare se il BIOS lo vede o no?

Ritratto di CarloCC
CarloCC
(Monster)
Offline
Monster
Iscritto: 06/04/2017
Messaggi: 279

Ogni bios è diverso, ma ci dovrebbe essere una sezione di boot, dove dovresti capire se il tuo HD è riconosciuto.
Edit. verifica anche che la gestione dell'HD non sia in RAID ma in ahci.

Acer Aspire E1-522 Amd Quad-Core E2-3800--Amd Radeon 8280
Acer Aspire M5500 Intel Quad-Core - Amd Radeon R5 230
Distribuzione openSUSE Leap 15 Kde Plasma5 - Tumbleweed

Ritratto di GiulioGG
GiulioGG
(Monster)
Offline
Monster
Iscritto: 26/05/2009
Messaggi: 267

CarloCC ha scritto:

verifica anche che la gestione dell'HD non sia in RAID ma in ahci.

Nel BIOS "SATA OPERATION" è settato a "AHCI", mentre "ASSET TAG" è settato a "RAIDmode" in modo immodificabile, benchè il computer non abbia una struttura RAID ma 1 SSD e 1 HD di capacità molto diverse.