KIO GDRIVE

9 risposte [Ultimo messaggio]
Ritratto di guero84
guero84
(Junior)
Offline
Junior
Iscritto: 20/05/2012
Messaggi: 35

Ciao a tutti,
Uso la opensuse 15.1 interfaccia KDE.
Cercando un programma per accedere comodamente a gdrive , ho trovato KIO GDRIVE.
Si installa semplicemente, subito vedo gdrive in reti, creo l'account come da manuale, do il consenso all'accesso da Google.
Ma al posto di crearmi la cartella con la mail email Google, rimane "nuovo utente" e non carica i file.
A qualcuno é già capitato?
Soluzioni?
Programmi alternativi affidabili?

Ritratto di CarloCC
CarloCC
(Monster)
Offline
Monster
Iscritto: 06/04/2017
Messaggi: 371

E' un problema noto delle vecchie versioni di Plasma con gli aggiornamenti avvenuti in seguito da Google.
Se passerai a Leap 15.2 tra non molto dovrebbe uscire la versione stabile funzionerà correttamente.

Acer Aspire E1-522 Amd Quad-Core E2-3800--Amd Radeon 8280
Acer Aspire M5500 Intel Quad-Core - Amd Radeon R5 230
Distribuzione openSUSE Leap 15 Kde Plasma5 - Tumbleweed

Ritratto di mauriziod
mauriziod
(Guru)
Offline
Guru
Iscritto: 01/06/2009
Messaggi: 1761

Messo l'account Google anche in impostazioni-KDE -> "Account in linea" ?

Controlla con Yast->Pacchetti che sono presenti kaccounts-integration kaccounts-providers build-essential qtbase5 extra-cmake-modules libkf5kio
gettext libkpimgapi qt5keychain --- nel caso mettili (se non trovi qualcuno è normale sarà all'interno di qualche altro pacchetto) e riavvia.

Qui trovi la versione KIO GDRIVE più recente
https://software.opensuse.org/package/kio-gdrive?search_term=KIO+GDRIVE

Altro non saprei dirti in quanto è un programma indipendente.

SO: Linux desktop Sistema: OpenSUSE Leap 15.1 (64bit) KDEE 5.12
SO: Linux desktop Sistema: OpenSUSE Tumbleweed (64bit) KDE 5
Miao

Ritratto di guero84
guero84
(Junior)
Offline
Junior
Iscritto: 20/05/2012
Messaggi: 35

Ciao,
a maggio poi la vita mi si è sconvolta un po di più... che anno...
però dato che ancora non esco di casa il sabato sera mi sono messo a tentare di risolvere questa questione in sospeso...

kaccounts-integration kaccounts-providers ci sono con quel nome ....
"build-essential" non c'è ma mi è parso di capire che è "pattern:devel_basis-20170319-lp151.5.1.x86_64'" da una ricerca
qtbase5 ho installate le librerie qt5 standarnd della 15.1
libkf5kio sono installate con altro nome anche loro
le api per google le ho aggionrnate...
qt5keychain avevo fatto un casino perchè le stavo reinstallando con cambio fornitorire in repo di qt che mi si era installato in vari tentativi, e non mi si aprivano più òe finestre .... reinstallato con suse come fornitore.

ora mi da
"Protocollo non valido" ... insistendo con i click ignoranti "Impossibile creare un io-slave. klauncher ha detto: Protocollo «gdrive» sconosciuto.

per fortuna è solo uno sfizio

Ritratto di CarloCC
CarloCC
(Monster)
Offline
Monster
Iscritto: 06/04/2017
Messaggi: 371

Sembra essere un problema diffuso, sembra che anche in Gnome c'è il problema, forse è causato da qualche aggiornamento dell'api di Google, ma è solo un'ipotesi. https://forum.ubuntu-it.org/viewtopic.php?f=8&t=640944

Acer Aspire E1-522 Amd Quad-Core E2-3800--Amd Radeon 8280
Acer Aspire M5500 Intel Quad-Core - Amd Radeon R5 230
Distribuzione openSUSE Leap 15 Kde Plasma5 - Tumbleweed

Ritratto di mauriziod
mauriziod
(Guru)
Offline
Guru
Iscritto: 01/06/2009
Messaggi: 1761

Mi risulta che non devi creare un nuovo utente ma usare le credenziali del vecchio utente altrimenti per forza è vuota è nuovo.

Vedi di caricarti anche OCaml e fuse-kio. Gdrive deve essere almeno la 1.3.0
https://software.opensuse.org/package/kio-gdrive

Vai in impostazioni di KDE e vai in "Account in linea" qui aggiungi il tuo account Google che già possiedi. Riavvia.

In Dolphin troverai nella sezione rete "Google Drive" l'accesso vero
sarà disponibile tra qualche minuto.

Attenzione si potranno vedere solo le cartelle Gdrive che hanno visualizzazione pubblica.

SO: Linux desktop Sistema: OpenSUSE Leap 15.1 (64bit) KDEE 5.12
SO: Linux desktop Sistema: OpenSUSE Tumbleweed (64bit) KDE 5
Miao

Ritratto di guero84
guero84
(Junior)
Offline
Junior
Iscritto: 20/05/2012
Messaggi: 35

Ciao mauriziod,
ho rifatto i passaggi, ma si presenta ancora vuoto, non vedo il nome, e nemmeno i file. ho guardo su google e pare che ho abilitato l'accesso a tutto.
Allego la schermata di come rimane dopo che ho fatto il login a google.

Alessandro

Immagini allegate:

Ritratto di mauriziod
mauriziod
(Guru)
Offline
Guru
Iscritto: 01/06/2009
Messaggi: 1761

ma durante l'autenticazione fatta in impostazioni di kde appare dopo user e password questo

SO: Linux desktop Sistema: OpenSUSE Leap 15.1 (64bit) KDEE 5.12
SO: Linux desktop Sistema: OpenSUSE Tumbleweed (64bit) KDE 5
Miao

Ritratto di guero84
guero84
(Junior)
Offline
Junior
Iscritto: 20/05/2012
Messaggi: 35

Ciao, non non ho quel cellulare, ma ho un nokia, e si gli avevo confermato che ero ero e che era tutto OK

Alessandro

Ritratto di mauriziod
mauriziod
(Guru)
Offline
Guru
Iscritto: 01/06/2009
Messaggi: 1761

fatto strano? At Wits End

L'unica che mi viene in mente è provare con il firewall abbassato.

SO: Linux desktop Sistema: OpenSUSE Leap 15.1 (64bit) KDEE 5.12
SO: Linux desktop Sistema: OpenSUSE Tumbleweed (64bit) KDE 5
Miao