Problema avvio da dvd

3 risposte [Ultimo messaggio]
Ritratto di pinguinoconfuso
Offline
Geek
Iscritto: 07/06/2006
Messaggi: 152

Ciao a tutti!

Tempo fa, dopo l'installazione di Leap ho notato che, dal bios, non è più possibile scegliere l'ordine del boot. Ho letto che per variare le impostazioni adesso si usa efibootmgr. Per non pasticciare troppo ho provato un paio di impostazioni:
-t (per variare il tempo e funziona)
-n (per scegliere cosa avviare all'accensione successiva)

Al momento la situazione è questa:

:~> sudo efibootmgr
root's password:
BootCurrent: 0002
Timeout: 3 seconds
BootOrder: 0002,0003,0000,0005,0001,0004,0006,0007
Boot0000* Endless OS
Boot0001* Windows Boot Manager
Boot0002* opensuse-secureboot
Boot0003* UEFI OS
Boot0004* UEFI:CD/DVD Drive
Boot0005* opensuse
Boot0006* UEFI:Removable Device
Boot0007* UEFI:Network Device

Per avviare da cd/dvd ho usato "sudo efibootmgr -n 0004" ed è apparsa la voce "BootNext: 0004", prima di riavviare ho inserito il dvd di una vecchia Knoppix ma quest'ultima non è partita. Fra le opzioni di efibootmgr è anche scomparsa la voce Boot0004 che è ricomparsa dopo un ulteriore riavvio.
Dove sbaglio?

Vorrei installare la nuova Leap da dvd e dei nuovi bios e boot manager ci ho capito poco. Forse avrei dovuto restare con grub!

Grazie in anticipo.

Ritratto di CarloCC
CarloCC
(Monster)
Offline
Monster
Iscritto: 06/04/2017
Messaggi: 411

Ma davvero stai usando ancora un dvd ? Il mio consiglio è di provare con una usb, i lettori dvd non sono mai stati il supporto ideale, a volte i lettori fanno le bizze.
Comunque non ho capito, non c'è più l'ordine di boot nel bios ? Innanzitutto è un pc recente ? Sei sicuro che sia uefi ? In caso affermativo sa tanto di bug del bios, se non vedi più l'ordine di boot. Io ti consiglio prima di controllare sul sito del produttore se è disponibile un aggiornamento del bios, purtroppo ho visto altri pc con lo stesso problema, un bug che dopo l'installazione di Linux o anche Windows faceva sparire il menù di boot, beh ! è evidente che è un bug del bios. Prova controllare.
Tuttavia non ho capito se devi installare openSUSE o cosa stai tentando di fare.

Acer Aspire E1-522 Amd Quad-Core E2-3800--Amd Radeon 8280
Acer Aspire M5500 Intel Quad-Core - Amd Radeon R5 230
Distribuzione openSUSE Leap 15 Kde Plasma5 - Tumbleweed

Ritratto di pinguinoconfuso
Offline
Geek
Iscritto: 07/06/2006
Messaggi: 152

Ciao Carlo, grazie per la risposta.

Si, ho usato dvd per Linux da almeno 15 anni e non ho mai avuto problemi, comunque posso anche provare con una chiavetta ma credo che anche questa dovrebbe comparire fra le opzioni del bios.

Ma andiamo con ordine...

Giusto, non c'è più l'ordine nel bios, compare solo "opensuse_secureboot".
Il pc ha tre anni ed aveva installato un os linux (Endless) e c'è scritto proprio "uefi bios".
Quando ho installato Suse, l'ho fatto da dvd (ovviamente c'era l'opzione dvd nel bios) senza problemi, ho scelto come boot loader EFI (da Yast "Grub2 per EFI") e sembrava tutto a posto.
Ora volevo installare la Leap più recente (avevo già predisposto le partizioni) ma non ho la possibilità di avviare da dvd in quanto manca proprio l'opzione.
Ho provato, come scrivevo sopra, a variare l'ordine di boot con efibootmgr ma senza risultati.
Da Yast potrei anche modificare la scelta del bootlodaer e passare (nel menù a tendina) a Grub2 ma non so cosa possa succedere. E' anche selezionato "abilita supporto a boot sicuro", potrebbe aver a che fare con il mio problema?
Proverò a vedere se trovo info su eventuali aggiornamenti del bios, magari è proprio un bug.

Grazie.

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2752

Io faccio cosi,con parted magic apro gparted,dopodichè cancello dove voglio installare suse abilito gpt metto il dvd riavvio e entro di nuovo sul bios mi comparono delle finestrello un della quale con uefi e il disegno del disco,lo metto all'inizio salvo esco dal bios e quando si riavvia il sistema parte il dvd.

SUSE Tumbleweed- kernel-5.14.6.1-4- kde-plasma-5.23.1.1 Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-390.143-SSD samsung 850 pro 512 gb http://opensuse-community.org/