Problema con installazione dual boot

4 risposte [Ultimo messaggio]
Ritratto di Poalo73
Poalo73
(Junior)
Offline
Junior
Iscritto: 12/11/2015
Messaggi: 43

Ciao, ho (purtroppo Sad ) un'istallazione dual boot Tumbleweed - Windows 10. Tutto procede bene fino a quando Windows (che per la verità uso pochissimo) non decide che è ora di fare i suoi aggiornamenti: a quel punto grub sparisce, e purtroppo l'unica cosa che sono riuscito a fare per rimediare è... reinstallare da capo Tumbleweed...

Chiedo se qualcuno di voi sapesse indirizzarmi verso una procedura che funziona in questi casi: esiste il cd di ripristino di openSUSE, e pure "boot repair", ma nessuno dei due è mai riuscito nell'impresa; in particolare, in quello di openSUSE vado in Yast->Bootloader, ma poi l'analisi mi dà messaggio di errore e si blocca senza propormi alternative. Al momento ho reinstallato, però la terrei a portata di mano per il futuro...

Grazie.

OpenSUSE Tumbleweed - KDE Plasma

Ritratto di spock
spock
(Guru)
Offline
Guru
Iscritto: 03/08/2006
Messaggi: 1221

https://it.opensuse.org/SDB:Riparare_l%27MBR_dopo_l%27installazione_di_Windows

Ciao

Ritratto di Poalo73
Poalo73
(Junior)
Offline
Junior
Iscritto: 12/11/2015
Messaggi: 43

Grazie. Qualcuno l'ha provata?

OpenSUSE Tumbleweed - KDE Plasma

Ritratto di spock
spock
(Guru)
Offline
Guru
Iscritto: 03/08/2006
Messaggi: 1221

Nel tuo caso poi se ti succede ad ogni aggiornamento di windows credo neanche serva, non so se hai attivato l'avvio rapido di windows ma se all'avvio entri nelle impostazioni del bios ed abiliti il boot legacy e metti al primo posto il grub opensuse non dovresti avere più questi problemi.

Ritratto di Poalo73
Poalo73
(Junior)
Offline
Junior
Iscritto: 12/11/2015
Messaggi: 43

Ciao, grazie per tutte le dritte, ma purtroppo non hanno funzionato (sì, è successo ancora Sad )... tra l'altro da BIOS vedo sempre e solo UN bootloader... comunque stavolta mi sono incaponito e un modo l'ho trovato, anche se purtroppo... da Windows 10... ci sono rimasto male, ma tutto ciò che ho trovato che si potesse fare da Linux ad un certo punto si blocca e stop. Sicuramente per colpa della mia inesperienza, però si blocca. Forse è un problema avere un hdd e un ssd, con Windows e la partizione EFI su hdd e openSUSE su ssd?

Comunque, nel caso servisse a qualcuno, ho fatto così:
- Da Windows 10 bisogna trovare il "Prompt dei comandi", al limite digitando "cmd" nel campo di ricerca del lanciatore;
- clic destro sopra, poi bisogna scegliere "Esegui come amministratore";
- bcdedit /set {bootmgr} path \EFI\opensuse\grubx64.efi
- se tutto è andato come deve, al riavvio grub è tornato Big Grin .

Purtroppo al "ritorno" la rete era KO, indagherò anche su questo...

OpenSUSE Tumbleweed - KDE Plasma