Bluetooth speaker che ha smesso di "suonare" su Tumbleweed

1 risposta [Ultimo messaggio]
Ritratto di andy1950
andy1950
(Junior)
Offline
Junior
Iscritto: 20/09/2018
Messaggi: 31

Salve a tutti,
spero che questa sia la sezione giusta per il mio problema.

Per moltissimo tempo ho usato uno speaker bluetooth accoppiato con un portatile Lenovo con Tumbleweed KDE (sempre aggiornatissimo con "zypper dup").

Di colpo, mentre ascoltavo musica, ha smesso di funzionare. Ovviamente ho fatto i controlli del caso (batteria scarica? Disaccoppiamento brutale? Oggetti interposti? Altro?) ma nulla, nell'elenco dei device continua a comparire ogni volta che accendo il portatile (ovviamente accendendo prima la cassa).

Ho provato, da Impostazioni di sistema->bluetooth, a eliminarlo dall'elenco, cercarlo e riaccoppiarlo, si accoppia, fa il suono caratteristico (per lui) per avvertire che è pronto ma nessun mixer non me lo fa vedere e non reagisce.

Ho provato ad accoppiare lo speaker al mio smartphone (Android) o ad altri PC o portatili con Tumbleweed e funziona perfettamente.

Una volta disaccoppiato (sempre da configuratore bluetooth) ho fatto, da utente normale in konsole:

1) pactl unload-module module-bluetooth-discover
2) pactl load-module module-bluetooth-discover
emette a video il numero 24 che, se rilanciato, viene incrementato
3) bluetoothctl
Agent registered
[bluetooth]# power on
Changing power on succeeded
[bluetooth]# agent on
Agent is already registered
[bluetooth]# default-agent
Default agent request successful
[bluetooth]# discoverable on
Changing discoverable on succeeded
[bluetooth]# scan on
Discovery started
[CHG] Controller E4:F8:9C:90:3E:6C Discovering: yes
[NEW] Device ED:6F:CB:FF:6D:C2 SBLP 5.0 B1
[bluetooth]# trust ED:6F:CB:FF:6D:C2
[CHG] Device ED:6F:CB:FF:6D:C2 Trusted: yes
Changing ED:6F:CB:FF:6D:C2 trust succeeded
[bluetooth]# connect ED:6F:CB:FF:6D:C2
Attempting to connect to ED:6F:CB:FF:6D:C2
[CHG] Device ED:6F:CB:FF:6D:C2 Connected: yes
[CHG] Device ED:6F:CB:FF:6D:C2 Modalias: bluetooth:v05D6p000Ad0240
[CHG] Device ED:6F:CB:FF:6D:C2 UUIDs: 0000110b-0000-1000-8000-00805f9b34fb
[CHG] Device ED:6F:CB:FF:6D:C2 UUIDs: 0000110c-0000-1000-8000-00805f9b34fb
[CHG] Device ED:6F:CB:FF:6D:C2 UUIDs: 0000110e-0000-1000-8000-00805f9b34fb
[CHG] Device ED:6F:CB:FF:6D:C2 UUIDs: 00001200-0000-1000-8000-00805f9b34fb
[CHG] Device ED:6F:CB:FF:6D:C2 ServicesResolved: yes
[CHG] Device ED:6F:CB:FF:6D:C2 Bonded: yes
[CHG] Device ED:6F:CB:FF:6D:C2 Paired: yes
[NEW] Endpoint /org/bluez/hci0/dev_ED_6F_CB_FF_6D_C2/sep1
[NEW] Endpoint /org/bluez/hci0/dev_ED_6F_CB_FF_6D_C2/sep2
[NEW] Transport /org/bluez/hci0/dev_ED_6F_CB_FF_6D_C2/sep1/fd1
Connection successful
[CHG] Transport /org/bluez/hci0/dev_ED_6F_CB_FF_6D_C2/sep1/fd1 Volume: 0x0072 (114)
[SBLP 5.0 B1]# scan off
Discovery stopped
[CHG] Device ED:6F:CB:FF:6D:C2 RSSI is nil
[CHG] Controller E4:F8:9C:90:3E:6C Discovering: no
[SBLP 5.0 B1]# exit

I tasti + e - del volume dello speaker, se tenuti premuti per qualche secondo, cambiano brano in Clementine ma non sento nulla.
Il tasto play fa partire o interrompe i brani, il tasto bluetooth lo fa naturalmente scoprire da chi lo cerca...

Qualche idea?
Ripeto: altrove funziona come ha sempre fatto sino ad ora (da almeno due anni)

Grazie in anticipo per le risposte.

Ciao, Andy.

Ritratto di Leon_
Leon_
(Monster)
Offline
Monster
Iscritto: 20/09/2006
Messaggi: 243

Sei riuscito nel frattempo a risolvere?
Secondo me si, ad ogni modo hai provato un downgrade di bluez alla versione precedente?