Errore qmake

9 risposte [Ultimo messaggio]
Ritratto di capoc1974
capoc1974
(Junior)
Offline
Junior
Iscritto: 25/02/2005
Messaggi: 15

Ciao

Da qualche giorno sto cercando di installare Kgest, un gestionale os,
sulla mia Suse 9.3 ma ogni volta che lancio l' installazione ricevo il seguente errore :

Quote:

linux:/usr/local/KGest # make
qmake -o Makefile gestionale.pro
make: qmake: Command not found
make: *** [Makefile] Error 127
linux:/usr/local/KGest #

Qualcuno ha idea del perchè??
Spero qualcuno possa aiutarmi

Ciao a tutti

Ritratto di auris
auris
(Guru)
Offline
Guru
Iscritto: 10/09/2004
Messaggi: 4923

Semplicemente non è presente.
Fa parte del pacchetto qt-x11-free-3.3.4.

Se sei stanco di virus e schermate blu passa a Linux

Ritratto di capoc1974
capoc1974
(Junior)
Offline
Junior
Iscritto: 25/02/2005
Messaggi: 15

Ciao

Ho scaricato da internet il pacchetto e l'ho installato ma purtroppo anche ora continuo a ricevere lo stesso errore..

Ritratto di auris
auris
(Guru)
Offline
Guru
Iscritto: 10/09/2004
Messaggi: 4923

Hai controllato se sia presente qmake?

Se sei stanco di virus e schermate blu passa a Linux

Ritratto di capoc1974
capoc1974
(Junior)
Offline
Junior
Iscritto: 25/02/2005
Messaggi: 15

Trovo qmake in diverse cartelle.
A parte quelle nella cartelle di installazione lo trovo anche in

/usr/lib/qt3/bin

va bene?

Ritratto di auris
auris
(Guru)
Offline
Guru
Iscritto: 10/09/2004
Messaggi: 4923

Si deve trovare proprio in /usr/lib/qt3/bin.

Se sei stanco di virus e schermate blu passa a Linux

Ritratto di capoc1974
capoc1974
(Junior)
Offline
Junior
Iscritto: 25/02/2005
Messaggi: 15

Infatti.. però non capisco perchè dice che non c'è...

Ritratto di EmmeG
EmmeG
(Junior)
Offline
Junior
Iscritto: 12/07/2005
Messaggi: 16

Ho installato ieri la Suse 9.3 e trovato lo stesso problema anche io... dato che uso le QT3 per svariati miei progetti !!
Ho risolto in due modi... te li elenco e poi scegli tu:

Soluzione valida per uno specifico utente: nella cartella home degli utenti c'è un file 'nascosto' chiamato .bashrc, aggiungi all'ultima riga la seguente istruzione
export PATH=/usr/lib/qt3/bin:$PATH
e quando riaprirai la konsole... tutto funzionerà !! Smile

Soluzione valida per tutti gli utenti: esiste un file /etc/profile che contiene i settagi globali della bash, alla riga 103 c'è un pezzo di codice così fatto:
<br />    for dir in  /var/lib/dosemu \<br />                /usr/games \<br />                /opt/bin \<br />                /opt/gnome/bin \<br />                /opt/kde3/bin \<br />                /opt/kde2/bin \<br />                /opt/kde/bin \<br />                /usr/openwin/bin \<br />                /opt/cross/bin<br />    do<br />        test -d $dir &amp;&amp; PATH=$PATH:$dir<br />    done<br />
basta aggiungere la directory delle QT3 ed il gioco è fatto:
<br />                /opt/cross/bin \<br />                /usr/lib/qt3/bin<br />    do<br />        test -d $dir &amp;&amp; PATH=$PATH:$dir<br />    done<br />

Spero sia utile a te ... e a tutti gli altri della community SuseItalia.org,
Ciao,
EmmeG

Ritratto di capoc1974
capoc1974
(Junior)
Offline
Junior
Iscritto: 25/02/2005
Messaggi: 15

Ciao

Ho provato con entrambe le soluzioni ma comunque continua a darmi il solito errore.

C'è qualche comando da dare dopo aver fatto le modifiche che hai detto sopra?

Ciao

Ritratto di capoc1974
capoc1974
(Junior)
Offline
Junior
Iscritto: 25/02/2005
Messaggi: 15

Ciao

Nel mio sistema doveva esserci un po' di confusione ...
Ho reinstallato suse 9.3 e ho provato subito le modifiche di cui sopra.
La prima ha funzionato subito mentre la seconda no.
Comunque sono riuscito ad installare il programma.

Grazie a tutti dell'aiuto e della pazienza.

Ciao