Task Manager

20 risposte [Ultimo messaggio]
Ritratto di lona79
lona79
(Junior)
Offline
Junior
Iscritto: 26/10/2005
Messaggi: 24

Ciao a tutti,
siccome uso da pochissimo Linux e mi si pianta spesso, c'è un task manager tipo windows? come si richiama (in windows ctrl+alt+canc)?

Grazie

Ritratto di boffo
boffo
(Guru)
Offline
Guru
Iscritto: 17/10/2005
Messaggi: 687

non credo che ci sia una cosa del genere in linux, perchè questo programma è stato chreato per quando windows si blocca. Pero cìè la shell o konsole.

Ritratto di Krystyan
Krystyan
(Monster)
Offline
Monster
Iscritto: 08/01/2005
Messaggi: 218

Se intendi un task manager che ti faccia vedere i processi attivi, il loro carico ecc ecc, premi insieme i tasti ctrl+esc
e ti partirà ksysguard! da lì se sei root puoi anche killare processi, assegnargli nice diversi, e tanto altro... ciao!

Cmq in che senso ti si pianta? no perchè in linux sta cosa non è normale!

Suse Linux 10.0 su P4 3.2 Ock 4.3Ghz - Motherboard asus P4C800 Dlx - Ram 512x2 Vdata utt @250 2.2.2.5 - Video Nvidia6800ultra

Ritratto di lona79
lona79
(Junior)
Offline
Junior
Iscritto: 26/10/2005
Messaggi: 24

Nel senso che a volte faccio partire un programma e mi rimane la schermata di avviamento ma non si avvia mai del tutto e così devo riavviare.

E poi è lentissimo. Per Suse 10 quanta memoria RAM minima è consigliabile (x esempio per windows xp si consigliano 512MB)?

Adesso provo i tasti ctrl+esc ....

Ritratto di lona79
lona79
(Junior)
Offline
Junior
Iscritto: 26/10/2005
Messaggi: 24

Ho provato i tasti ma non succede niente.

Come faccio con Suse 10 in KDE ad entrare come root?
Devo farlo dalla shell? nel senso se apro la shell, scrivo "su" e poi la password, e la lascio aperta, premendo i tasti ctrl+esc si avvia il programma che mi hai detto prima ?

Ritratto di Krystyan
Krystyan
(Monster)
Offline
Monster
Iscritto: 08/01/2005
Messaggi: 218

Come ctrl+esc non ti funzionano???
Cmq prova così:
loggati da root su la console, e digita:
ksysguard
Vai sulla tab "carico dei processi" e uccidi il processo che ti da fastidio... attento al resto.

Modo più veloce: premi crtl + alt +esc tutti e tre insieme, e con il cursore del mouse a forma di teschio clicca sulla finestra che si blocca, così ucciderai il processo... attenzione però che quando fai questa combinazione di tasti, tutto il sistema si freeza.

Suse 10.0 non so precisamente di quanta ram necessiti per funzionare al meglio, penso che 512mb di memoria siano più che sufficenti.

Quali sono i programmi che di solito non vanno sul tuo sistema?

Suse Linux 10.0 su P4 3.2 Ock 4.3Ghz - Motherboard asus P4C800 Dlx - Ram 512x2 Vdata utt @250 2.2.2.5 - Video Nvidia6800ultra

Ritratto di lona79
lona79
(Junior)
Offline
Junior
Iscritto: 26/10/2005
Messaggi: 24

Siccome l'ho installato da poco uso principalmente Yast perchè volevo aggiornarlo e mettere i codec per i dvd, e firefox per internet.

e a volte mi si piantano tutti e due

Ritratto di Krystyan
Krystyan
(Monster)
Offline
Monster
Iscritto: 08/01/2005
Messaggi: 218

Che sistema hai? cpu. ram, motherboard ecc?
Così eventualmente escludiamo problemi hardware...

Suse Linux 10.0 su P4 3.2 Ock 4.3Ghz - Motherboard asus P4C800 Dlx - Ram 512x2 Vdata utt @250 2.2.2.5 - Video Nvidia6800ultra

Ritratto di lona79
lona79
(Junior)
Offline
Junior
Iscritto: 26/10/2005
Messaggi: 24

Ah si giusto mi son dimenticato di scriverlo.

Allora:
- Notebook Compaq EVO n1020v
- Processore Intel Pentium M 1,8 GHz
- 256 MB di ram
- Scheda grafica integrata ATI da 64MB

Il resto penso non ti interessi.

Comunque per il rilevamento hardware sono stato molto contento perchè per quello che ho provato va tutto, anche se ho notato che per esempio la scheda grafica è stata riconosciuta con una sigla diversa rispetto a windows. Però mi ha riconosciuto l'addattatore PCMCIA pe rla rete Wireless e si è connesso subito ad internet con router e DCHP

Ritratto di Krystyan
Krystyan
(Monster)
Offline
Monster
Iscritto: 08/01/2005
Messaggi: 218

Il processore è una bomba, la memoria non è tantissima ma sufficente per un sistema decente... la partizione di swap l'hai messa ed è attiva vero?

Suse Linux 10.0 su P4 3.2 Ock 4.3Ghz - Motherboard asus P4C800 Dlx - Ram 512x2 Vdata utt @250 2.2.2.5 - Video Nvidia6800ultra

Ritratto di lona79
lona79
(Junior)
Offline
Junior
Iscritto: 26/10/2005
Messaggi: 24

Vorrei precisare che il processore non è un Centrino ma un Mobile normale.

La partizione di swap c'è ed è di circa 1 GB. Per controllare se è attiva non so come fare.

Su KSysGuard (ah si sono riuscito ad avviarlo) mi dice:
Swap: 36.904 KB usati, 983.184 KB liberi ; quindi presumo sia attiva