Aggiornamento firefox alla versione 1.5.0.2

9 risposte [Ultimo messaggio]
Ritratto di lucadelu
lucadelu
(Geek)
Offline
Geek
Iscritto: 27/03/2006
Messaggi: 76

Ciao a tutti, ho un problemino con firefox, volevo aggiornare la mia versione con la 1.5.0.2, così prima sono andato sul link nella home del sito, ma niente, poi ho provato con yast e gli rpm senza risultati, fino che sono riuscito a scaricare un file tar che però ogni volta bisogna avviare dalla console e che non mi ha aggiornato quello vecchio come speravo...cosa posso fare?

Ritratto di auris
auris
(Guru)
Offline
Guru
Iscritto: 10/09/2004
Messaggi: 4923

Qui trovi tutto quello che ti serve:
ftp://ftp.gwdg.de/linux/suse/projects/mozilla/firefox/1.5.0.2

Se sei stanco di virus e schermate blu passa a Linux

Ritratto di lucadelu
lucadelu
(Geek)
Offline
Geek
Iscritto: 27/03/2006
Messaggi: 76

ci sono andato ma mi apre una pagina vuota...lo devo mettere in yast?

Ritratto di auris
auris
(Guru)
Offline
Guru
Iscritto: 10/09/2004
Messaggi: 4923

Quote:

lucadelu ha scritto:
ci sono andato ma mi apre una pagina vuota...lo devo mettere in yast?

Non mi risulta che si apra una pagina vuota:
ftp://ftp.gwdg.de/linux/suse/projects/mozilla/firefox/1.5.0.2/10.0-i386

Se sei stanco di virus e schermate blu passa a Linux

Ritratto di lucadelu
lucadelu
(Geek)
Offline
Geek
Iscritto: 27/03/2006
Messaggi: 76

Sono proprio gli rpm che ho scaricato, ma quando faccio per installarli mi chiede di inserire un cd di suse e mi installa quelli dal cd (versione vecchia) invece che quelli nuovi!

Ritratto di auris
auris
(Guru)
Offline
Guru
Iscritto: 10/09/2004
Messaggi: 4923

Installali da shell col comando "rpm -Uvh ......rpm"

Se sei stanco di virus e schermate blu passa a Linux

Ritratto di lucadelu
lucadelu
(Geek)
Offline
Geek
Iscritto: 27/03/2006
Messaggi: 76

mi da questi errori, che sono poi quelli che mi diceva quando mi richiedeva il cd:

linux:/home/luca # rpm -Uvh /home/luca/MozillaFirefox-translations-1.5.0.2-0.1.i586.rpm
warning: /home/luca/MozillaFirefox-translations-1.5.0.2-0.1.i586.rpm: V3 DSA signature: NOKEY, key ID 71423d59
error: Failed dependencies:
MozillaFirefox = 1.5.0.2 is needed by MozillaFirefox-translations-1.5.0.2-0.1

linux:/home/luca # rpm -Uvh /home/luca/MozillaFirefox-1.5.0.2-0.1.i586.rpm
warning: /home/luca/MozillaFirefox-1.5.0.2-0.1.i586.rpm: V3 DSA signature: NOKEY, key ID 71423d59
error: Failed dependencies:
MozillaFirefox = 1.0.6 is needed by (installed) MozillaFirefox-translations-1.0.6-16

Ritratto di Alfio
Alfio
(Guru)
Offline
Guru
Iscritto: 30/08/2005
Messaggi: 2678

Disinstalla la vecchia versione prima con yast e poi fai come dice auris prima il pacchetto base e poi la traduzione della lingua.
Ciao

Ritratto di lucadelu
lucadelu
(Geek)
Offline
Geek
Iscritto: 27/03/2006
Messaggi: 76

grazie mille...ora tutto ok!

Ritratto di trinket
trinket
(Newbie)
Offline
Newbie
Iscritto: 29/03/2005
Messaggi: 4

Ricapitolando... io di solito faccio così:

scarico l'ultima versione di Firefox e Thunderbird a partire da
ftp://ftp.gwdg.de/linux/suse/projects/mozilla/

si sceglie la piattaforma hardware/software opportuna,
e, dopo aver scaricato i pacchetti necessari, per esempio:

[...]/firefox/1.5.0.2/10.0-i386/MozillaFirefox-1.5.0.2-0.1.i586.rpm
[...]/firefox/1.5.0.2/10.0-i386/MozillaFirefox-translations-1.5.0.2-0.1.i586.rpm
[...]/thunderbird/1.5.0.2/10.0-i386/MozillaThunderbird-1.5.0.2-0.1.i586.rpm
[...]/thunderbird/1.5.0.2/10.0-i386/MozillaThunderbird-translations-1.5.0.2-0.1.i586.rpm

da shell eseguo:

rpm -Uvh --nodeps Mozilla*

L'opzione --nodeps serve a non tenere conto della dipendenza fra il pacchetto base e quello translation.

Ne approfitto per una domanda agli esperti:
a cosa servono i pacchetti debuginfo ??