aggiornamento Amarok con yast

1 risposta [Ultimo messaggio]
Ritratto di dpaso
dpaso
(Junior)
Offline
Junior
Iscritto: 02/09/2006
Messaggi: 13

Buongiorno,

sto cercando di aggiornare la versione di amarok 1.3.8 installata sulla SUSE 10.1 alla nuova versione 1.4.2. Quindi vado in yast seleziono l'aggiornamento relativo ad amarok, clicco su controllo dipendenze (verifica) e mi da questo errore:

Impossibile installare Amarok-1.4.3-15.guru.suse101.i686[20060916-122550]. Alcune dipendenze sono mancanti<br />    Non esistono provider installabili di libgpod.so.0 per amarok-1.4.3-15.guru.suse101.i686[20060916-122550]<br />

Ho selezionato oltre alla riga di Amarok anche quelle relative ai plugin (helix, libvusal,xine). Quindi non capisco proprio cosa vuol dire il messaggio di errore, soprattutto quello relativo ai provider installabili.

Grazie

A computer is like an air conditioner, it stops working when you open Windows

Ritratto di MacGyver
MacGyver
(Geek)
Offline
Geek
Iscritto: 23/05/2007
Messaggi: 88

Vuol dire che serve un package aggiuntivo che si chiama "libgpod", che è un pacchetto necessario all'interfacciamento di Amarok con l'iPod. Anche se a te non serve devi installarlo comunque per il corretto funzionamento dell'applicazione, purtroppo.

Ad ogni modo, per ovviare al tuo problema e trovare anche quel pacchetto, dovresti aggiungere come prepository Packman (che è dove si trova l'rpm di libgpod): da YaSt clicca su "Cambia sorgente di installazione" poi su "Aggiungi"---->"HTTP" ed infine nella prima riga digiti "packman.iu-bremen.de" senza virgolette, ovvio e nella seconda "suse/10.X" dove X è il numero della tua versione. poi clicchi ok e aspetti che aggiorni i repository.
Finito questo clicchi su Fine e aspetti che si chiuda la finestra. Dopo prova a fare tutto da YaSt come prima e in teoria dovrebbe funzionare tutto!