Anche la 10.2 si blocca al boot

25 risposte [Ultimo messaggio]
Ritratto di mlucci
mlucci
(Junior)
Offline
Junior
Iscritto: 09/12/2006
Messaggi: 11

Strano...

Sei sicuro di aver masterizzato una ISO "sana"?
Hai controllato prima di masterizzare con md5sum?
Hai masterizzato la ISO a 4X o più?

Io di regola masterizzo SO a bassa velocità, MAX 2X o anche meno se ho tempo.

Per instlalare i driver nVidia sulla mia "vecchia" GeForce 4600 ho sempre seguito i consigli specifici per la SuSE che trovi sul sito nVidia:

http://www.suse.de/~sndirsch/nvidia-installer-HOWTO.html

In particolare:

1) Si deve aggiungere il repository addizionale nVidia

YaST -> Software -> Change installation Source -> Add

Protocol: HTTP
Server Name: : download.nvidia.com
Directory on Server: /opensuse/10.2

2) Si installano i nuovi drivers:

YaST -> Software -> Install and Delete Software

x11-video-nvidia
nvidia-gfx-kmp-"versione-kernel"

dove "versione-kernel" è quanto leggi in output dal comando 'uname -r' (ad. es. 2.6.18.2-34-default)

3) Si configurano i nuovi drivers con "sax2 -r"
Nelle vecchie versioni di sax2 occorreva uscire dalla modalità grafica e farlo da terminale. Ora non è più necessario.

4) Eventualmente riavviare X e rimirare la bellezza dello splash-screen nVidia con le potenzialità dei driver nVidia dedicati. Con gli Xorg non riuscivo nemmeno a gestire il movimento del mouse...

Ciao
Max

Windows più che un sistema operativo è un sistema nervoso...

Ritratto di divine_pegasus
divine_pegasus
(Junior)
Offline
Junior
Iscritto: 07/01/2005
Messaggi: 30

Ho controllato l'md5 e sembra tutto ok
Ho masterixzato a 4X perchè è il max che permette il dvd.

Il mio problema è che dovrei installare i driver di nvidia direttamente quando installo il sistema operativo, perchè non ho alcun modo di accere a linux una volta installato... come fare?

Ritratto di mlucci
mlucci
(Junior)
Offline
Junior
Iscritto: 09/12/2006
Messaggi: 11

Quote:

divine_pegasus ha scritto:
Ho controllato l'md5 e sembra tutto ok
Ho masterixzato a 4X perchè è il max che permette il dvd.

Il mio problema è che dovrei installare i driver di nvidia direttamente quando installo il sistema operativo, perchè non ho alcun modo di accere a linux una volta installato... come fare?

sembra... oppure è identico?
DEVE essere identico, altrimenti il checksum, indica che la ISO è corrotta in partenza.
Cmq ti consiglio di masterizzare a più bassa velocità indipendentemente da quanto consenta il supporto o il device fisico: è una regola cui attenersi sempre quando si salvano dati importanti.

Venendo ai drivers nVidia: il tuo problema è che sei fuori rete quanto fai il boot a Linux? Io prima risolverei la connessione. Hai notato problemi di degradazione grafica durante l'installazione? Intendo: pagine corrotte o errori di sorta?

Quello che puoi fare se sei in rete con Windows, poreleva il pacchetto *.run dal sito nVidia e mettilo su un supporto (o una partizione) leggibile da Linux. Infine esegui i file da root, seguito dal solito sax2 -r

Facci sapere
Max

---

Windows più che un sistema operativo è un sistema nervoso...

Ritratto di divine_pegasus
divine_pegasus
(Junior)
Offline
Junior
Iscritto: 07/01/2005
Messaggi: 30

Ho ricalcolato l'MD5SUM ed è identico.
Come detto in precedenza non ho alcun modo di avviare linux, non perchè mi manca la rete (che funziona)...ma perchè sia in failsafe che in modalità normale il sistema va in crash...
Se il problema è la scheda video l'unico modo che ho per risolvere il problema è installare i driver di NVIDIA direttamente quando installo SUSE...sapete dirmi come faccio a dire a YAST quando fa l'aggiornamento online (subito dopo aver terminato l'installazione) di andarsi a prendere i pacchetti che servono dal repository della nvidia?

Ritratto di rafnek
rafnek
(Junior)
Offline
Junior
Iscritto: 07/11/2005
Messaggi: 11

Hai provato a fare partire il sistema con l'opzione no-acpi?