aggiornare firefox

10 risposte [Ultimo messaggio]
Ritratto di vbmanu
vbmanu
(Geek)
Offline
Geek
Iscritto: 12/12/2006
Messaggi: 58

ho scaricato dal sito di mozilla l'ultima versione di firefox (firefox-2.0.0.1.tar.gz). L'ho decompresso ed eseguendo ./firefox parte senza doverlo installare. A questo punto se provo ad installare una qualsiasi estenzione compatibile con la versione mi da errore. Potrebbe essere un problema di permessi?

Ritratto di morphy
morphy
(Monster)
Offline
Monster
Iscritto: 22/12/2006
Messaggi: 267

se ti garbano gli rpm, prova qui:

http://www.suseitalia.org/modules/news/article.php?storyid=450

edit:
impostandolo come repository, è sbagliata la cartella

pub/linux/suse/opensuse/repositories/mozilla/ 10.2

deve essere

pub/linux/suse/opensuse/repositories/mozilla/openSUSE_10.2/

Intel Core i7 CPU Q 720 @ 1.6GHz / ATI MOBILITY RADEON HD 4650
openSUSE 11.4 (x86_64) / KDE 4.6.00 (4.6.0) "release 6"
Linux 2.6.37.1-1.2-desktop x86_64

Ritratto di pernix
pernix
(Guru)
Offline
Guru
Iscritto: 07/07/2006
Messaggi: 995

Quote:

vbmanu ha scritto:
ho scaricato dal sito di mozilla l'ultima versione di firefox (firefox-2.0.0.1.tar.gz). L'ho decompresso ed eseguendo ./firefox parte senza doverlo installare. A questo punto se provo ad installare una qualsiasi estenzione compatibile con la versione mi da errore. Potrebbe essere un problema di permessi?

Non è un problema di permessi. Posta l'errore che ti viene dato e un esempio di un'estensione che dà problemi.

In a world without walls and fences, who needs Windows ad Gates?

openSUSE 10.3 - KDE+Compiz
Dell Latitude D820N: Intel T7200 2GHz; 2GB RAM 667MHz; Nvidia Quadro NVS 120M 512MB

Ritratto di vbmanu
vbmanu
(Geek)
Offline
Geek
Iscritto: 12/12/2006
Messaggi: 58

l'estenzione che ho provato è foxtrick 3.50. Se provo ad installarla dice Errore inatteso consultare la console degli errori -203.
Ho provato con winzoz e si installa correttamente

Ritratto di pernix
pernix
(Guru)
Offline
Guru
Iscritto: 07/07/2006
Messaggi: 995

Hai scaricato l'installazione da http://foxtrick.px.cz/ ?
A me si installa correttamente

In a world without walls and fences, who needs Windows ad Gates?

openSUSE 10.3 - KDE+Compiz
Dell Latitude D820N: Intel T7200 2GHz; 2GB RAM 667MHz; Nvidia Quadro NVS 120M 512MB

Ritratto di vbmanu
vbmanu
(Geek)
Offline
Geek
Iscritto: 12/12/2006
Messaggi: 58

si certo. Con winzoz va tutto alla grande...stessa versione di estensione e stessa versione di firefox boh

Ritratto di vbmanu
vbmanu
(Geek)
Offline
Geek
Iscritto: 12/12/2006
Messaggi: 58

questo è l'errore che mi da quando installo un'estensione:
http://img504.imageshack.us/img504/3476/schermata1ta8.jpg

Ritratto di pernix
pernix
(Guru)
Offline
Guru
Iscritto: 07/07/2006
Messaggi: 995

Quote:

vbmanu ha scritto:
questo è l'errore che mi da quando installo un'estensione:
http://img504.imageshack.us/img504/3476/schermata1ta8.jpg

Ok, ma la console degli errori (Strumenti -> Console degli errori) non ti dice nulla di più? Hai provato a scaricare il file xpi e installarlo da locale (File -> Apri file...)?

In a world without walls and fences, who needs Windows ad Gates?

openSUSE 10.3 - KDE+Compiz
Dell Latitude D820N: Intel T7200 2GHz; 2GB RAM 667MHz; Nvidia Quadro NVS 120M 512MB

Ritratto di vbmanu
vbmanu
(Geek)
Offline
Geek
Iscritto: 12/12/2006
Messaggi: 58

ho provato anche ad installarlo da locale ma da lo stesso errore. Questo è l'errore che spunta nella console:

Errore: installLocation has no properties
File sorgente: file:///usr/lib/firefox/components/nsExtensionManager.js
Riga: 3849

e se clicco mi evidenzia questa riga:

var installLocation = this.getInstallLocation(item.id);

Ritratto di vbmanu
vbmanu
(Geek)
Offline
Geek
Iscritto: 12/12/2006
Messaggi: 58

qualcuno potrebbe darmi una mano?

Ritratto di morphy
morphy
(Monster)
Offline
Monster
Iscritto: 22/12/2006
Messaggi: 267

se puo' interessarti, con firefox istallato da rpm (http://www.suseitalia.org/modules/news/article.php?storyid=450), l'estenzione si istalla correttamente......

Intel Core i7 CPU Q 720 @ 1.6GHz / ATI MOBILITY RADEON HD 4650
openSUSE 11.4 (x86_64) / KDE 4.6.00 (4.6.0) "release 6"
Linux 2.6.37.1-1.2-desktop x86_64