problema grave

20 risposte [Ultimo messaggio]
Ritratto di Isaia
Isaia
(Monster)
Offline
Monster
Iscritto: 16/11/2007
Messaggi: 214

ti ringrazio tantissimo per la risposta molto esaustiva... solo un appunto: visto che uso kde, nei comandi che hai scritto basta sostituire gnome con kde? grazie... appena mi rispondi provo...

Ritratto di AL9000
AL9000
(Guru)
Offline
Guru
Iscritto: 29/10/2005
Messaggi: 1277

no,no!
quel comando è giusto così, è indipendente dal desktop environment che usi, anch'io ho kde.

ciao, auguri

Chi è investito di un'autorità si trasformerà inevitabilmente, secondo una legge sociale immutabile, in un oppressore ed in uno sfruttatore della società. (M.A. Bakunin)

Ritratto di Isaia
Isaia
(Monster)
Offline
Monster
Iscritto: 16/11/2007
Messaggi: 214

ho sicuramente fatto qualche cavolata... allora:
per prima cosa ho provato a disinstallare solamente compiz manager (visto che fa conflitto) per vedere che succedeva, e come risultato ho avuto una bellissima schermata nera...
allora torno in yast, ho cercato tutte i pacchetti che contenvano la parola compiz o fusion e l'ho levato... alla fine però ho dovuto forzare un pò perchè mi diceva che mancavano dipendenze a xgl e kde_xgl... uscito da yast ho dato
init 3
sax2 -r -m 0=radeon
init 5
per ripartire da zero coi radeon (così pensavo)
come risultato ho un sistema ora accessibile, ma con uno scorrimento delle finestre lentissimo e sopratutto messe fuori posto e senza barra in alto (cioè quella con i pulsanti di riduci a icona, chiudi e così via...)... che faccio? ho sicuramente fatto qualche cavolata disinstallando qualcosa che dovevo lasciare...

Ritratto di AL9000
AL9000
(Guru)
Offline
Guru
Iscritto: 29/10/2005
Messaggi: 1277

dai sintomi direi che hai xgl attivo o qualcosa di simile.

prova a dare il comando che serve a disabilitare xgl(punto 7 del mio post precedente)

poi da yast cerca xgl e, se è installato, rimuovilo per il momento

Poi, se hai risettato xorg con i driver radeon senza disinstallare i driver ATI, prova a dare i comandi (da root)
aticonfig --initial<br />sax2 -r -m 0=fglrx
dovresti ritornare coi driver ati funzionanti

Se invece li hai disinstallati, ti conviene sovrasrivere il file /etc/X11/xorg.conf.original-0 (il tuo xorg originale, senza driver ati) sopra il file /etc/X11/xorg.conf

Per farlo basta entrare in quella cartella da root e rinominare il primo file come il secondo(lo so, è ovvio, ma non so mai se riesco a spiegarmi)

Poi reinstalla i driver in uno dei modi possibili

Una volta che hai di nuovo i driver ATI funzionanti ed il server X che funziona normalmente, segui i passi che ti ho indicato prima.

Ciao

Chi è investito di un'autorità si trasformerà inevitabilmente, secondo una legge sociale immutabile, in un oppressore ed in uno sfruttatore della società. (M.A. Bakunin)

Ritratto di Isaia
Isaia
(Monster)
Offline
Monster
Iscritto: 16/11/2007
Messaggi: 214

adesso mi metto a piangere...
nell'ordine:
do il comando
gnome-xgl-switch --disable-xgl
e non lo trova...
allora vado a togliere xgl...fatto.
digito
aticonfig --initial
sax2 -r -m 0=fglrx
e dopo che mi si è aperta la solita finestra do ok e il pc si blocca su una schermata nera....

allora mi dico, chi se ne frega, ricominciamo da capo:
vado in /etc/X11
cp xorg.conf.original-0 xorg.conf.backup
mv xorg.conf.backup xorg.conf
(ne ho fatto una copia per evitare di perdere l'originale)
e riprovo a farlo partire normalmente... mi carica la modalità testuale invece di quella grafica e mi chiede login e password... e poi mi chiede ancora comandi testuali... e la grafica dov'è finita? riprovo ancora con il famoso sax2 [...] e mi si blocca ancora con la schermata nera...
mi tocca formattare o ho ancora speranza almeno di tornare alle condizioni iniziali?

Ritratto di AL9000
AL9000
(Guru)
Offline
Guru
Iscritto: 29/10/2005
Messaggi: 1277

rispondo al volo e scappo

si, hai ancora speranza

purtroppo sax2, dopo l'installazione dei driver ati, a volte non fa ripartire il server grafico(ma è un problema dei driver ati nuovi, succede, non a tutti e non sempre, anche se cerchi di uscire dal server grafico in altre occasioni: logout e ri-login ecc.)

non ho capito se in questo momento hai ancora i driver ATI o se li hai disinstallati.

fammi sapere

ciao

Chi è investito di un'autorità si trasformerà inevitabilmente, secondo una legge sociale immutabile, in un oppressore ed in uno sfruttatore della società. (M.A. Bakunin)

Ritratto di Isaia
Isaia
(Monster)
Offline
Monster
Iscritto: 16/11/2007
Messaggi: 214

prima li avevo, adesso ho provato con il toglierli ma comunque non mi fa entrare, mi chiede sempre login e password da modalità testuale e posso lavorare solo lì... dopo aver tolto i driver avevo fatto
init 3
sax2 -r -m 0=vesa
init 5
ma non è cambiato niente...

cmq buone feste e grazie di aiutarmi anche in questi giorni!!!

Ritratto di AL9000
AL9000
(Guru)
Offline
Guru
Iscritto: 29/10/2005
Messaggi: 1277

Quote:

adesso ho provato con il toglierli

significa che li hai disinstallati via yast? perchè è questo che dovresti fare per "toglierli"

comunque,

forse non risolve, ma prova a dare (da root)
sax2 -r -m 0=radeon
quando sax parte(se parte, ti parte vero?)configura la risoluzione del monitor, salva la configurazione e, se ti riporta in modalità testuale, dai un bel reboot (male non fa).

Se invece trovi una schermata nera, spegni brutalmente e riavvia.

vedi se ti restituisce la modalità grafica.

Altrimenti, sempre nella cartella /etc/X11 dovresti avere una copia del tuo xorg originale (precedente ai tuoi tentativi con i driver ATI e con compiz).

Esplora bene la cartella col comando ls e visualizza il contenuto dei vari files che iniziano per "xorg" col comando cat (es: cat xorg.conf.original-0)

Dovresti trovarne uno che ha il contenuto del tuo xorg iniziale

Per capirci, un file che nella section device ti indica che hai un driver video radeon.

Se lo trovi sovrascrivilo sopra il tuo attuale xorg.conf e riavvia senza far partire sax o dare altri comandi.

Questo perchè, se veramente hai disinstallato i dirver ATI, uno xorg come ti ho descritto sarebbe compatibile col driver che hai in uso.

Spero di essermi spiegato, ma soprattutto spero che tu ne venga fuori, riacquistando la modalità grafica senza dover formattare.

Comunque, io personalmente, oltre al file xorg.conf.original-0 che mi crea la ATI, prima di smanettare col server X mi faccio sempre una bella copia del mio xorg di partenza, pulito-limpido-funzionante, nella mia home.

Per avere modo di risolvere in fretta in casi del genere. Ma non ti preoccupare, certi meccanismi ti verranno automatici con l'esperienza.

Ciao e ancora auguri

Chi è investito di un'autorità si trasformerà inevitabilmente, secondo una legge sociale immutabile, in un oppressore ed in uno sfruttatore della società. (M.A. Bakunin)

Ritratto di Isaia
Isaia
(Monster)
Offline
Monster
Iscritto: 16/11/2007
Messaggi: 214

già provato con il sax2 -r -m 0=radeon e non funziona...
se leggi qualche mio intervento fa ho già provato a fare il replace dello xorg con quello originale, ma non ha dato risultati ... tutto è bloccato alla modalità testuale...

Ritratto di AL9000
AL9000
(Guru)
Offline
Guru
Iscritto: 29/10/2005
Messaggi: 1277

avevo letto, ma è evidente che la tua configuarzione attuale ha qualcosa che non quadra, per questo ti ho chiesto se avevi disinstallato correttamente i driver ati

comunque, armandoti di tanta pazienza puoi reinstallare i driver ATI e riconfigurare il tuo xorg.conf con sax2 -r -m 0=fglrx
Penso che a questo punto si renda necessario, visto che il tuo xorg con i radeon ha qualcosa che non va.

Dovrai fare tutto da modalità testuale, ovviamente.

Yast2, come detto, funziona anche in modo solo testo, aiutati con quello per l'installazione dei driver.

Una volta terminata la procedura dai i soliti comandi aticonfig e sax2 ecc.

Se una volta salvata la configurazione del monitor via sax2 ti restituisce una schermata nera non disperare: spegni e riaccendi e, se hai un minimo di fortuna, dovresti tornare in modalità grafica.

Se così non fosse, io darei un'occhiata al file /etc/sysconfig/displaymanager, che deve avere un contenuto simile al seguente(in particolare vedi le parti in grassetto, non vorrei che fosse rimasta una stringa con xgl attivo nonostante che non ce l'hai più)
## Path:        Desktop/Display manager<br />## Type:        string(Xorg,Xgl)<br />## Default:     &quot;Xorg&quot;<br />#<br /># Xgl is an experimental Xserver using OpenGL for rendering.<br /># Right now only the glx backend is supported, which runs on top of a<br /># standard Xorg server providing OpenGL.<br /># Set this to &#039;Xgl&#039; and run SuSEconfig only if you want to run your<br /># displaymanager (kdm/gdm/xdm) on Xgl on top of Xorg.<br /># This setting is case sensitive.<br /># Warning! This is highly experimental.<br />#<br /><b>DISPLAYMANAGER_XSERVER=&quot;Xorg&quot;</b><br />## Path:        Desktop/Display manager<br />## Type:        string<br />## Default:     &quot;-accel glx:pbuffer -accel xv:pbuffer&quot;<br />#<br /># Xglx is an experimental Xserver using OpenGL for rendering.<br /># Additional options for startup when using a display manager.<br /># You can try<br />#   &quot;-accel glx&quot;<br /># or<br />#   &quot;-accel glx:pbuffer&quot;<br /># in order to get accelerated indirect OpenGL rendering for 3D applications.<br /># You can also try<br />#   &quot;-accel xv&quot;<br /># to accelerate XVideo color space conversion and/or scaling.<br />#<br /># See also /usr/share/doc/packages/xgl/README.SUSE<br />#<br />DISPLAYMANAGER_XGL_OPTS=&quot;-accel glx:pbuffer -accel xv:pbuffer&quot;<br />## Path:      Desktop/Display manager<br />## Description:    settings to generate a proper displaymanager config<br />## Config:      xdm,kdm,gdm<br /><br />## Type:        string(kdm,xdm,gdm,wdm,console)<br />## Default:        &quot;&quot;<br />#<br /># Here you can set the default Display manager (kdm/xdm/gdm/wdm/console).<br /># all changes in this file require a restart of the displaymanager<br />#<br /><b>DISPLAYMANAGER=&quot;kdm&quot;</b><br /><br />## Type:        yesno<br />## Default:  no<br />#<br /># Allow remote access (XDMCP) to your display manager (xdm/kdm/gdm). Please note<br /># that a modified kdm or xdm configuration, e.g. by KDE control center<br /># will not be changed. For gdm, values will be updated after change.<br /># XDMCP service should run only on trusted networks and you have to disable<br /># firewall for interfaces, where you want to provide this service.<br />#<br />DISPLAYMANAGER_REMOTE_ACCESS=&quot;no&quot;<br /><br />## Type:      yesno<br />## Default:  no<br />#<br /># Allow remote access of the user root to your display manager. Note<br /># that root can never login if DISPLAYMANAGER_SHUTDOWN is &quot;auto&quot; and<br /># System/Security/Permissions/PERMISSION_SECURITY is &quot;paranoid&quot;<br />#<br />DISPLAYMANAGER_ROOT_LOGIN_REMOTE=&quot;no&quot;<br /><br />## Type:  yesno<br />## Default:  yes<br />#<br /># Let the displaymanager start a local Xserver.<br /># Set to &quot;no&quot; for remote-access only.<br /># Set to &quot;no&quot; on architectures without any Xserver (e.g. s390/s390x).<br />#<br /><b>DISPLAYMANAGER_STARTS_XSERVER=&quot;yes&quot;</b><br /><br />## Type:        yesno<br />## Default:     no<br />#<br /># TCP port 6000 of Xserver. When set to &quot;no&quot; (default) Xserver is<br /># started with &quot;-nolisten tcp&quot;. Only set this to &quot;yes&quot; if you really<br /># need to. Remote X service should run only on trusted networks and<br /># you have to disable firewall for interfaces, where you want to<br /># provide this service. Use ssh X11 port forwarding whenever possible.<br />#<br />DISPLAYMANAGER_XSERVER_TCP_PORT_6000_OPEN=&quot;no&quot;<br /><br />## Type:    string<br />## Default:<br />#<br /># Define the user whom should get logged in without request. If string<br /># is empty, display standard login dialog.<br />#<br />DISPLAYMANAGER_AUTOLOGIN=&quot;user&quot;<br /><br />## Type:        yesno<br />## Default:     no<br />#<br /># Allow all users to login without password, but ask for the user, if<br /># DISPLAYMANAGER_AUTOLOGIN is empty.<br />#<br />DISPLAYMANAGER_PASSWORD_LESS_LOGIN=&quot;no&quot;<br /><br />## Type:        yesno<br />## Default:     no<br />#<br /># Display a combobox for Active Directory domains.<br />#<br />DISPLAYMANAGER_AD_INTEGRATION=&quot;no&quot;<br /><br />## Type:    list(root,all,none,auto)<br />## Default: auto<br />#<br /># Determine who will be able to shutdown or reboot the system in kdm<br /># and gdm. Valid values are: &quot;root&quot; (only root can shutdown), &quot;all&quot;<br /># (everybody can shutdown), &quot;none&quot; (nobody can shutdown from<br /># displaymanager), &quot;auto&quot; (follow<br /># System/Security/Permissions/PERMISSION_SECURITY to decide: &quot;easy<br /># local&quot; is equal to &quot;all&quot;, everything else is equal to &quot;root&quot;). Note<br /># that remote user can never shutdown in GDM.<br />#<br />DISPLAYMANAGER_SHUTDOWN=&quot;auto&quot;<br /><br />## Type:        string<br />## Default:     &quot;auto&quot;<br />#<br /># Mode to configure on output devices by default<br /># (RANDR 1.2 compatible drivers only).<br />#<br /># If set to &quot;auto&quot;, DISPLAYMANAGER_RANDR_MODE_auto is used on laptops, and<br /># the empty string on workstations.<br />#<br /># The output is not explicitly enabled (read: disabled) if set to an empty<br /># string.<br /># If the variable contains a fully configured modeline (see default of<br /># DISPLAYMANAGER_RANDR_MODE_auto), the mode is defined and set.<br /># If the variable contains a mode name only, the mode has to be defined<br /># already.<br />#<br /># If a monitor is attached during Xstartup, or when invoking &quot;xrandr --auto&quot;<br /># during runtime, the output is correctly configured and a mode is<br /># automatically selected if none has been used so far.<br />#<br /># Variables are checked according to their extension for<br />#    VGA DVI_I DVI_D DVI_A Composite S_Video Component LFP Proprietary<br />#<br />DISPLAYMANAGER_RANDR_MODE_VGA=&quot;auto&quot;<br />#DISPLAYMANAGER_RANDR_MODE_DVI_I=&quot;&quot;<br />#DISPLAYMANAGER_RANDR_MODE_DVI_D=&quot;&quot;<br />#DISPLAYMANAGER_RANDR_MODE_DVI_A=&quot;&quot;<br />#DISPLAYMANAGER_RANDR_MODE_Compsite=&quot;&quot;<br />#DISPLAYMANAGER_RANDR_MODE_S_Video=&quot;&quot;<br />#DISPLAYMANAGER_RANDR_MODE_Component=&quot;&quot;<br />#DISPLAYMANAGER_RANDR_MODE_LFP=&quot;&quot;<br />#DISPLAYMANAGER_RANDR_MODE_Proprietary=&quot;&quot;<br /><br />## Type:        string<br />## Default:     &quot;1024x768_60 64.11 1024 1080 1184 1344 768 769 772 795 -HSync +Vsync&quot;<br />#<br /># Mode to use for laptops for DISPLAYMANAGER_RANDR_MODE_* on laptops only,<br /># when the according variable is set to &quot;auto&quot;.<br /># (RANDR 1.2 compatible drivers only).<br />#<br />DISPLAYMANAGER_RANDR_MODE_auto=&quot;1024x768_60 64.11 1024 1080 1184 1344 768 769 772 795 -HSync +Vsync&quot;<br />## Path:        Desktop/Display manager<br />## Description: settings to generate a proper displaymanager config<br />## Config:      kdm3<br /><br />## Type:    string<br />## Default: <br />#<br /># space separated list of users for which icons should be shown in KDM<br /># if empty, then take system defaults<br />#<br />KDM_USERS=&quot;&quot;<br /><br />## Type:    string<br />## Default: <br />#<br /># Special greeting words in kdm<br />#<br />KDM_GREETSTRING=&quot;&quot;<br /><br />## Type:        string<br />## Default:     SUSE<br />#<br /># Define the theme to be used by kdm. If empty, the traditional login<br /># window is used (which lacks some features)<br /># <br />DISPLAYMANAGER_KDM_THEME=&quot;SUSE&quot;<br />
Purtroppo in questo momento non mi vengono in mente altri interventi possibili per tornare ad avere la grafica.

Nel caso fosse necessario formattare, avevi una partizione separata per la tua home? Se si, almeno eviterai la seccatura di dover copiare tutto quello che non vuoi perdere da un'altra parte. Se no, la prossima volta che formatti crea due partizioni per suse, una per root(la cartella /) ed una per la home.

Ciao

Chi è investito di un'autorità si trasformerà inevitabilmente, secondo una legge sociale immutabile, in un oppressore ed in uno sfruttatore della società. (M.A. Bakunin)