2 schede di rete su server suse: esterna va, interna no

1 risposta [Ultimo messaggio]
Ritratto di dav-76
dav-76
(Newbie)
Offline
Newbie
Iscritto: 30/01/2008
Messaggi: 3

Ciao a tutti,

sono entrateo da poco nel mondo linux suse

e sono alle prese con un probl. che mi sta facendo impazzire!

X questo chiedo il vostro aiuto e spero di aver inserito il post in modo e nel posto giusto...

Ho un server dell preso a novembre 2007 con suse server 10 installato,

2 schede di rete :

- una con ip pubblico, subnet mask, gateway e dns presi dal router pirelli quindi giusti per dare al server un indirizzo web static, il tutto sotto rete esterna del firewall;
- un'altra scheda di rete con ip della lan interna con relativo subnetmask, gateway (l'ip del firewall) e dns tutto controllato con pc windows che funzionano regolarmente con gli stessi ip, il tutto sotto rete interna del firewall.

Il problema è che suse mi va in modo alterno ossia se su yast metto un gateway di una scheda anche quel'altra si prende lo stesso gateway... e quindi o mi funziona su lan interna o come server su web...

Poi se configuro le 2 schede con network manager mi appare l'icona dei 2 pc sulla barra sotto a destra vicino all'ora con relativo messaggio di configurazione andata a buon fine dopo l'ultimo ok su yast,
invece su uso ifup non appare nulla...

C'è un sistema per riuscire a mantenere i due gateway distinti sulle 2 schede di rete in modo che vadano entrambe in modo corretto,
ossia riesca a far accede il server alla lan su interfaccia interna e mi vada l'ftp server che ho messo su mettendo il server su web sull'interfaccia esterna?

Grazie per l'aiuto,

Davide

Ritratto di orion
orion
(Guru)
Offline
Guru
Iscritto: 11/07/2006
Messaggi: 2919

Prova a vedere se questa pagina ti da` informazioni utili a risolvere il tuo problema: http://www.novell.com/coolsolutions/feature/11505.html

openSUSE 12.1 on Acer Aspire 1810tz - LXDE ultima versione dal repo x11:/lxde