Gestioni flussi audio multipli

22 risposte [Ultimo messaggio]
Ritratto di Daniels
Daniels
(Geek)
Offline
Geek
Iscritto: 15/11/2006
Messaggi: 166

grazie per l'aiuto, allora:

- alsa-firmware 1.0.14-24
- alsa 1.0.14-31.2
- alsa oss 1.0.14-23 Big Grin

Ritratto di Daniels
Daniels
(Geek)
Offline
Geek
Iscritto: 15/11/2006
Messaggi: 166

Help please, il problema e' solo nel mandare il suono a 4.1 anche con le musiche.... Sad Sad

Ritratto di Alfio
Alfio
(Guru)
Offline
Guru
Iscritto: 30/08/2005
Messaggi: 2678

http://www.suseitalia.org/modules/newbb/viewtopic.php?topic_id=17627&forum=3&post_id=99686#forumpost99686

Prima fai questo poi ne riparliamo.
Ciao

Ritratto di Daniels
Daniels
(Geek)
Offline
Geek
Iscritto: 15/11/2006
Messaggi: 166

Ho letto ma non ho trovato alcun aiuto. Per di piu' i driver che a lui davano problemi sono presenti nel mio sistema in versione aggiornata...
ecco l'output ottenuto da quel comando:

alsa-plugins-1.0.14-41<br />alsa-oss-1.0.14-23<br />alsa-utils-1.0.14-27<br />alsa-devel-1.0.14-31.2<br />alsa-1.0.14-31.2<br />alsa-firmware-1.0.14-24

ah, il sistema e' completamente aggiornato

Ritratto di Alfio
Alfio
(Guru)
Offline
Guru
Iscritto: 30/08/2005
Messaggi: 2678

Installa da Yast questo repositori:
http://download.opensuse.org/repositories/multimedia:/audio/openSUSE_10.3_Update/
Aggiorna gli alsa è riavvia il pc .
Dovrebbe darti la console un risultato come il mio.

alfio@linux:~> rpm -qa | grep alsa
alsa-plugins-1.0.16.hg20080514-2.1
alsa-driver-kmp-default-1.0.16.20080528_2.6.22.17_0.1-3.1
alsa-utils-1.0.16.hg20080429-1.4
alsa-oss-1.0.15.hg20071007-2.8
alsa-1.0.16.hg20080510-2.1
alfio@linux:~>

Dopo dai un bel alsaconf da root e riconfigura la scheda usb
Ciao

Ritratto di Daniels
Daniels
(Geek)
Offline
Geek
Iscritto: 15/11/2006
Messaggi: 166

Ecco il risultato del comando dopo l'aggiornamento e il riavvio:

alsa-firmware-1.0.16.hg20080314-1.3<br />alsa-devel-1.0.16.hg20080510-2.1<br />alsa-1.0.16.hg20080510-2.1<br />alsa-oss-1.0.15.hg20071007-2.8<br />alsa-plugins-1.0.16.hg20080514-2.1<br />alsa-utils-1.0.16.hg20080429-1.4

Ci credi che alsaconfig mi trova solo la scheda interna e una legacy ISA? La seconda non mi pare sia prorpio la creative. Anche perche' proseguendo con quella scelta trovo solo schede molto vecchie.
Allora da yast ho rimosso e riconfigurato la scheda.

Poi pero', rimettendo quel file di configurazione asoundrc il suono ritorna sui 4 canali ma nulla, il suono ancora funziona solo sulla prima applicazione aperta...

Ritratto di Alfio
Alfio
(Guru)
Offline
Guru
Iscritto: 30/08/2005
Messaggi: 2678

Mi posti il file sound che hai nella home.
Ciao

Ritratto di Daniels
Daniels
(Geek)
Offline
Geek
Iscritto: 15/11/2006
Messaggi: 166

Quote:

Daniels ha scritto:
Trovato il problema. Appena le schede sono installate tutto e' OK!
Poi pero' ho aggiungo questo file di config asoundrc nella home come consigliato qua e la per la mia scheda audio e per ascoltare in 5.1 (meglio 4.1 perche' la cassa centrale era troppo alta).
Ecco il contenuto:

pcm.usb-audio {<br />           type hw<br />           card 0<br />        }<br /><br />ctl.usb-audio {<br />           type hw<br />           card 0<br />        }<br /><br />pcm.!default {<br />        type route<br />        slave.pcm surround51<br />        slave.channels 6<br />        ttable.0.0 1<br />        ttable.1.1 1<br />        ttable.0.2 1<br />        ttable.1.3 1<br />        ttable.0.4 0<br />        ttable.1.4 0<br />        ttable.0.5 0.5<br />        ttable.1.5 0.5<br />   }<br /><br />pcm.dsp0 {<br />        type plug<br />        slave.pcm &quot;dmixer&quot;<br />}<br /><br /><br />pcm.dmixer {<br />        type dmix<br />        ipc_key 1025 # Should be a unique number<br />        slave {<br />                pcm &quot;hw:0&quot;<br />    }<br />    bindings {<br />           0 0<br />           1 1<br />    }<br />}

cosa c'e' che non va? Big Grin

questo Laughing

Ritratto di Daniels
Daniels
(Geek)
Offline
Geek
Iscritto: 15/11/2006
Messaggi: 166

Quale istruzione non mi permette di gestire il flusso audio da piu' applicazioni?

Ritratto di Daniels
Daniels
(Geek)
Offline
Geek
Iscritto: 15/11/2006
Messaggi: 166

piu' niente? Sad