aggiornamento pacchetti

6 risposte [Ultimo messaggio]
Ritratto di giali
giali
(Monster)
Offline
Monster
Iscritto: 19/10/2006
Messaggi: 429

Dopo aver dato “zypper up -t package” per aggiornare, mi si presenta un problema di requisiti non soddisfatti. Individuato il pacchetto con problemi di dipendenze, procedo per risolvere le stesse. Non è importante il pacchetto che creava il conflitto, quanto quello che è accaduto, che sinceramente reputo “poco furbo”. In pratica yast tra i vari pacchetti da aggiornare aveva individuato anche quello relativo alla nuova build 2.4.1.6 di openoffice. Sul mio pc la vecchia build 2.4.1.5 era localizzata in italiano, quindi anche il relativo pacchetto di localizzazione era alla versione 2.4.1.5. La nuova build evidentemente non è stata ancora completata nella nostra lingua (unica spiegazione che da profano riesco a darmi), per cui il conflitto riguardava un pacchetto che non riusciva di pari passo a portare aggiornato. Per risolvere il conflitto dovevo rimuovere il pacchetto di localizzazione _it (cosa che ho fatto). Così zypper è andato avanti (prima si “bloccava”), ma mi sono ritrovato con un'applicazione in inglese e senza alcuna possibilità per il momento di poterla aggiornare in italiano. Io ho provato perchè devo imparare, ma mi chiedo e vi chiedo: è assurdo pensare che se un pacchetto che fa parte di un gruppo non è ancora pronto, tutto il gruppo dovrebbe fermarsi? ovvero, quando la prossima volta vorrò di nuovo aggiornare openoffice (come qualunque altra applicazione), dovrò prima verificare che il relativo pacchetto per la nostra lingua sia stato anch'esso aggiornato? Lo so che forse chiedo troppo ma io, ripeto, lo reputo “poco intelligente”, perchè preferivo tenere una versione vecchia in italiano piuttosto che una nuova in inglese. Thinking

Big Grin

OpenSuSE 11.1 - kde 4.1.3 - acer Aspire 5500

Ritratto di Il_Cjargnel
Il_Cjargnel
(Guru)
Offline
Guru
Iscritto: 04/08/2005
Messaggi: 1886

non mi è mai successo finora, e certo però che sbagliare è umano!! ma se sicuro x esempio di NON avere abilitato cose sperimentali/ustable??? sai li essendo cose sperimentali, nessuno ti garantisce nulla!!

OpenSuse 11.0+ OpenSuse 11.2

Ritratto di giali
giali
(Monster)
Offline
Monster
Iscritto: 19/10/2006
Messaggi: 429

Quote:

Il_Cjargnel ha scritto:
non mi è mai successo finora, e certo però che sbagliare è umano!! ma se sicuro x esempio di NON avere abilitato cose sperimentali/ustable??? sai li essendo cose sperimentali, nessuno ti garantisce nulla!!

Ti riferisci ai repositories? Assolutamente no. Ho solo aggiunto EXTRAS che prima non avevo. E per di più ho appena verificato il notebook! Stessa identica cosa.

Big Grin

OpenSuSE 11.1 - kde 4.1.3 - acer Aspire 5500

Ritratto di wal7er
wal7er
(Guru)
Offline
Guru
Iscritto: 21/09/2007
Messaggi: 572

E' successo anche a me: basta fare un down grade alla versione in italiano e saltare l'installazione quando ci sono anche altri aggiornamenti.

HP Pavilion dv5-1110el powered by OpenSUSE 13.2 64bit

http://linuxcounter.net/cert/432576.png

Ritratto di Il_Cjargnel
Il_Cjargnel
(Guru)
Offline
Guru
Iscritto: 04/08/2005
Messaggi: 1886

probabilmente risolverano... a volte certe cose scappano, specie in sti giorni di caos totale! Wink

OpenSuse 11.0+ OpenSuse 11.2

Ritratto di giali
giali
(Monster)
Offline
Monster
Iscritto: 19/10/2006
Messaggi: 429

Quote:

wal7er ha scritto:
E' successo anche a me: basta fare un down grade alla versione in italiano

il problema e che yast non mi propone più la versione precedente

Quote:

e saltare l'installazione quando ci sono anche altri aggiornamenti.

puoi spiegarti meglio?

Big Grin

OpenSuSE 11.1 - kde 4.1.3 - acer Aspire 5500

Ritratto di wal7er
wal7er
(Guru)
Offline
Guru
Iscritto: 21/09/2007
Messaggi: 572

Devi abilitare i repository di openoffice e gia che ci sei anche quello principale degli aggiornamenti (update)

Di ogni pacchetoo installato puoi selezionare anche la versione che vuoi installare rtamite il gestore dei pacchetti.
Comunque nael caso di openoffice puoi tranquillamente installare il pacchetto che traduce in italiano e quando ti dice che ci sono conflitti digli di ignorarli per quel pacchetto; a queto punto prosegui con l'installazione ed hai openoffice aggiornato ed in italiano.

ciao

HP Pavilion dv5-1110el powered by OpenSUSE 13.2 64bit

http://linuxcounter.net/cert/432576.png