ancora problemi a masterizzare

5 risposte [Ultimo messaggio]
Ritratto di mose53
mose53
(Junior)
Offline
Junior
Iscritto: 15/04/2008
Messaggi: 29

Utilizzo una suse 11 e mi ritrovo ancora questo problema dell'impossibilità di masterizzare (messaggio: CDrecord non ha i permessi per aprire il dispositivo). Per un periodo ho risolto il problema cambiando i permessi al file /media/.hal-mtab-lok, ma ora questa procedura non funziona più. Una curiosità: se il file da masterizzare è molto piccolo (ho provato con uno da 250 Byte) non ci sono problemi!
Ho letto in qualche discussione che il problema è stato risolto per la 11.1. Chiedo se la cosa vale anche per la 11e in questo caso cosa si deve fare.
Grazie mille a chi mi aiuta.

mose53

Ritratto di auris
auris
(Guru)
Offline
Guru
Iscritto: 10/09/2004
Messaggi: 4923

Sono parecchi mesi che utilizzo openSuSE 11 e non ho mai avuto problemi di permessi nel masterizzare CD/DVD.
Si tratta di un masterizzatore interno oppure uno esterno USB?

Se sei stanco di virus e schermate blu passa a Linux

Ritratto di Il_Cjargnel
Il_Cjargnel
(Guru)
Offline
Guru
Iscritto: 04/08/2005
Messaggi: 1886

idem ho 3 pc con opensuse 11.0 con relativi masterizatori interni ata e tutti masterizzano a meravilgia!!

OpenSuse 11.0+ OpenSuse 11.2

Ritratto di steluciani
steluciani
(Monster)
Offline
Monster
Iscritto: 26/02/2008
Messaggi: 346

nemmeno io con opensuse 11.0 ho avuto problemi, comunque prova a vedere se questo ti può aiutare
http://italiafreeware.byethost4.com/?q=node/111
io avevo fatto in quel modo quando era uscita opensuse 11.1 prima dell'aggiornamento che risolveva il problema con il masterizzatore

magari funziona pure con opensuse 11.0 se è un problema di permessi

Ritratto di AL9000
AL9000
(Guru)
Offline
Guru
Iscritto: 29/10/2005
Messaggi: 1277

La butto là, anche se molto probabilmente non è il nocciolo del problema:

siamo sicuri che il problema non dipenda dal fatto che il supporto è montato/smontato?

ricordo che in passato, cercando di cancellare/sovrascrivere un cd/dvd riscrivibile, avevo ricevuto un messaggio simile, ma solo perchè in quel momento il supporto era montato: smontando il supporto tutto filava liscio.

Chi è investito di un'autorità si trasformerà inevitabilmente, secondo una legge sociale immutabile, in un oppressore ed in uno sfruttatore della società. (M.A. Bakunin)

Ritratto di mose53
mose53
(Junior)
Offline
Junior
Iscritto: 15/04/2008
Messaggi: 29

Purtroppo il problema a masterizzare l'ho avuto fin dall'inizio con la 11, mentre non avevo avuto nessun problema con la 10.3.
Il masterizzatore è interno, precisamente è un SONY DVD RW AW-G170A 1.71.
La procedura che mi ha indicato Geek non funziona. In effetti non riesco a masterizzare nemmeno come utente root. Era così anche all'inizio. Poi, nel periodo in cui sono riuscito a masterizzare cambiando i permessi al file /media/.hal-mtab-lok, funzionava con qualsiasi utente (allora avevo scritto della cosa a questo forum e mi era stato segnalato che quella procedura funzionava anche con la 11.1).
Mentre come utente normale il messaggi di errore è questo: Cdrecord non ha il permesso di aprire il dispositivo (alle volte è preceduto da questo: Impossibile fissare il disco), con l'utente root il messaggio chiede di variare la velocità o il modo (TAO piuttosto che SAO) e ad ogni tentativo dice una cosa diversa, magari il contrario di quanto detto prima.
Sul montaggio-smontaggio del dispositivo dovresti dirmi come lo verifichi. Nel percorso system:/media/ quando non ci sono dischi nel CDROM non risulta niente, quando c'è un disco vergine appare l'icona ma il menù relativo non contiene il comando di smontaggio, lo contiene invece quando il CD non è vergine. Pertanto presumo che il dispositivo sia sempre smontato quando parte il processo di masterizzazione.
Comunque non ho nessun problema a cancellare un CD-RW, il problema è solo a masterizzarlo
Se può servire unisco qui sotto il pezzo del log prodotto da k3b e relativo alla segnalazione degli errori:

Waiting for reader process to fill input buffer ... input buffer ready.
Performing OPC...
Starting new track at sector: 0
Track 01: 0 of 0 MB written.
Errno: 5 (Input/output error), write_g1 scsi sendcmd: no error
CDB: 2A 00 00 00 00 00 00 00 1F 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: 70 00 04 00 00 00 00 0A 00 00 00 00 08 03 00 00
Sense Key: 0x4 Hardware Error, Segment 0
Sense Code: 0x08 Qual 0x03 (logical unit communication crc error (ultra-dma/32)) Fru 0x0
Sense flags: Blk 0 (not valid)
cmd finished after 0.050s timeout 40s
/usr/bin/X11/wodim: A write error occured.
/usr/bin/X11/wodim: Please properly read the error message above.
write track data: error after 0 bytes
Trouble flushing the cache
Writing time: 20.670s
Average write speed 0.7x.
Fixating...
Errno: 5 (Input/output error), flush cache scsi sendcmd: no error
CDB: 35 00 00 00 00 00 00 00 00 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: F0 00 03 00 00 01 2F 0A 00 00 00 00 0C 07 00 00
Sense Key: 0x3 Medium Error, Segment 0
Sense Code: 0x0C Qual 0x07 (write error - recovery needed) Fru 0x0
Sense flags: Blk 303 (valid)
cmd finished after 0.936s timeout 120s
Errno: 5 (Input/output error), close track/session scsi sendcmd: no error
CDB: 5B 00 02 00 00 00 00 00 00 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: 70 00 05 00 00 00 00 0A 00 00 00 00 72 04 00 00
Sense Key: 0x5 Illegal Request, Segment 0
Sense Code: 0x72 Qual 0x04 (empty or partially written reserved track) Fru 0x0
Sense flags: Blk 0 (not valid)
cmd finished after 0.008s timeout 480s
cmd finished after 0.008s timeout 480s
Fixating time: 0.011s
/usr/bin/X11/wodim: Cannot fixate disk.
BURN-Free was never needed.
/usr/bin/X11/wodim: fifo had 11 puts and 1 gets.
/usr/bin/X11/wodim: fifo was 0 times empty and 0 times full, min fill was 100%.

mose53