server web

20 risposte [Ultimo messaggio]
Ritratto di Linuxer
Linuxer
(Geek)
Offline
Geek
Iscritto: 06/09/2008
Messaggi: 179

ciao,
avete un'idea se sia possibile ed in che modo l'avvio automatico di Xampp all'avvio del sistema?

Grazie.

Ritratto di anubis
anubis
(Guru)
Offline
Guru
Iscritto: 07/04/2007
Messaggi: 3656

installa yast2-http-server
poi vai su: yast --> servizi di rete --> server http
segui le istruzione ed all'ultimo passaggio scegli "avvia il server apache2 al boot"

OpenSUSE Member,Packman Packager, Education Project Admin, LXDE Project Admin
Powered by http://en.opensuse.org/HP_Pavilion_dv6855el

Ritratto di Linuxer
Linuxer
(Geek)
Offline
Geek
Iscritto: 06/09/2008
Messaggi: 179

Grazie Anubis! Tutto molto facile e pratico. Gentilissimo.

Ritratto di Linuxer
Linuxer
(Geek)
Offline
Geek
Iscritto: 06/09/2008
Messaggi: 179

c'è un problema:
se mi connetto a localhost adesso mi dice che non ho i permessi per vedere la pagina (error 403);
se provo ad avviare Xampp manualmente da console mi dice che un altro daemon http è in esecuzione...

Chiedo ancora lumi...
tnx

Ritratto di anubis
anubis
(Guru)
Offline
Guru
Iscritto: 07/04/2007
Messaggi: 3656

assicurati che nella cartella /srv/www/htdocs ci sia almeno un file "index.html" se non c'è creane uno,
magari con questo contenuto banale:

<html>
<body>
Test.. It WORKS!!
</body>
</html>

se ancora non va, rendi quella cartella accessibile in lettura a TUTTI

sudo chmod -R 755 /srv/www/htdocs
---edit---
p.s. di fatto Xampp : http://www.apachefriends.org/it/xampp.html
non ti serve... hai tutto quello che ti serve  in yast e repo vari...
p.s. vorresti voler installare phpmyadmin e mysql

OpenSUSE Member,Packman Packager, Education Project Admin, LXDE Project Admin
Powered by http://en.opensuse.org/HP_Pavilion_dv6855el

Ritratto di Linuxer
Linuxer
(Geek)
Offline
Geek
Iscritto: 06/09/2008
Messaggi: 179

in htdocs è già caricato un sito wordpress che all'avvio manuale di xampp funziona regolarmente.
il problema si pone all'avvio automatico con l'errore suddetto.
provo ad editare i permessi e vediamo.

Ritratto di Linuxer
Linuxer
(Geek)
Offline
Geek
Iscritto: 06/09/2008
Messaggi: 179

non cambia nulla, ma forse ho capito.
Tu mi hai dato le istruzioni per l'avvio in automatico del server web di Opensuse. Io voglio avviare invece il pacchetto Xampp che è in /opt/lampp/htdocs...
Può essere?
In tal caso come fare?

grazie.

Ritratto di rigel
rigel
(Geek)
Offline
Geek
Iscritto: 17/10/2004
Messaggi: 139

Se vuoi sia lampp che il server apache e mysql indipendenti, devi fermare apache come avvio automatico e avviarlo da terminale quando ti serve
con      /etc/init.d/apache2 start      da root, ovvio
e fermarlo con .........stop
lampp funziona per i fatti suoi.
Ma se impari ad usare apache e mysql come servizi, sei dieci passi avanti, rispetto a lampp.
Ciao

openSuse 12.1 Gnome 3
desktop : Pentium D 3,4 2GB ram nVidia 8800 GTX 768 Mb
openSuse 11.1
notebook : vaio Z11-MN/B - Intel® Core™ Duo P8400 -SDRAM DDR3 (2 x 2048 MB) -NVIDIA® GeForce® 9300M GS + Intel 4500 (Intel® GM45 Express)-

Ritratto di rigel
rigel
(Geek)
Offline
Geek
Iscritto: 17/10/2004
Messaggi: 139

Ah dimenticavo.....
se usi lampp il sito è in /opt/ etc etc
se usi apache come server il sito è in /srv/www/htdocs

ciao

openSuse 12.1 Gnome 3
desktop : Pentium D 3,4 2GB ram nVidia 8800 GTX 768 Mb
openSuse 11.1
notebook : vaio Z11-MN/B - Intel® Core™ Duo P8400 -SDRAM DDR3 (2 x 2048 MB) -NVIDIA® GeForce® 9300M GS + Intel 4500 (Intel® GM45 Express)-

Ritratto di Linuxer
Linuxer
(Geek)
Offline
Geek
Iscritto: 06/09/2008
Messaggi: 179

a me interessa avviare lampp se è possibile.
non vedo perchè cambiare quando lampp è completo: se utilizzo il server web di opensuse dovrei installare a parte php admin e mysql...

Ritratto di rigel
rigel
(Geek)
Offline
Geek
Iscritto: 17/10/2004
Messaggi: 139

ok. problema risolto. Non fare partire il server apache in automatico.
Quindi semplicemente utilizza lampp.

Ciao

openSuse 12.1 Gnome 3
desktop : Pentium D 3,4 2GB ram nVidia 8800 GTX 768 Mb
openSuse 11.1
notebook : vaio Z11-MN/B - Intel® Core™ Duo P8400 -SDRAM DDR3 (2 x 2048 MB) -NVIDIA® GeForce® 9300M GS + Intel 4500 (Intel® GM45 Express)-