OPENSUSE 11.3 PER IMAC APPLE

29 risposte [Ultimo messaggio]
Ritratto di tunjin
tunjin
(Geek)
Offline
Geek
Iscritto: 19/02/2007
Messaggi: 102

ciao
un anno fa ho installato opensuse 11.2 funzione bene su apple imac, vorrei nuovo opensuse 11.3 durante installazione risulta corretta poi riavvia e inizia boot fino ultimo lista boot:
[ 4.069945] generic-usb..........bal bla bla...... e troppo lungo e non fa piu continuare boot sembra fino a bloccare...ho provato ctrl+alt+canc (riavviare) funzione.. ma sempre arrivare ultimo lista di boot è quello sempre generic-usb....

ho provato formattare e ri-installazione e corretto installazione ma sempre ferma fino boot generi-hub.... è sempre stessa cosa come mai?che facciamo...?

Ritratto di bagarozzo85
bagarozzo85
(Guru)
Offline
Guru
Iscritto: 16/06/2006
Messaggi: 1050

Hai già provato a selezionare un kernel alternativo nella pagina che permette la scelta dei pacchetti da installare?

Ritratto di tunjin
tunjin
(Geek)
Offline
Geek
Iscritto: 19/02/2007
Messaggi: 102

ciao bagarozzo85:
selezione kernel in grub? o parli durante installazione?

ora provo grub e scelto "failsafe -- opensuse 11.3 - 2.6.34-12"
...
..
funzione bene e inizia automatica configurare user poi arrivato KDE4!!! bello
e ora provo riavviare spero che vada tutto bene...
noooooo
è la stessa cosa si ferma boot....
che strano solo funzione failsafe invece opensuse non funzione come mai..

Ritratto di bagarozzo85
bagarozzo85
(Guru)
Offline
Guru
Iscritto: 16/06/2006
Messaggi: 1050

Come immaginavo, la causa sta in un modulo del kernel.

Visto che ormai il sistema è installato e che dopotutto si avvia in modalità failsafe, vai in YaST e cerca di installare un kernel alternativo (tra gli altri, dovrebbero essere a disposizione quello dekstop, quello generico, quello PAE, quello server....)

Ritratto di tunjin
tunjin
(Geek)
Offline
Geek
Iscritto: 19/02/2007
Messaggi: 102

ok proverò domani per installare kernel, ma quale tra generico,desktop,pae, server?
però penso dovrò togliere o disattiva 1 servizio durante in boot, entrare yast: quello runlevel b,1,2,3,4,5?che dici?

grazie

Ritratto di bagarozzo85
bagarozzo85
(Guru)
Offline
Guru
Iscritto: 16/06/2006
Messaggi: 1050

Servizi e runlevel non c'entrano. Devi cambiare il kernel. Immagino che sia installato di default il desktop. Prova quello generico, poi gli altri.

A meno che non riesca a capire quale modulo crea conflitti così da riportare un eventuale bug.

Ritratto di tunjin
tunjin
(Geek)
Offline
Geek
Iscritto: 19/02/2007
Messaggi: 102

ok ora installa generico poi vediamo ok? grazie!

Ritratto di tunjin
tunjin
(Geek)
Offline
Geek
Iscritto: 19/02/2007
Messaggi: 102

ciao ma scusa devo disinstallare kernel-desktop e installa default? oppure rimane desktop e installa default?
quindi ora lascio desktop e installa default ok?

Ritratto di tunjin
tunjin
(Geek)
Offline
Geek
Iscritto: 19/02/2007
Messaggi: 102

entrare boot kernel default è la stessa problema... ho provato failsafe con default funzione bene è come failsafe deaktop...
ora installa kernel pea?
------------------------------------------
AGGIRONATO COMMNENTO
[ok ora installa e vediamo ok?]
non posso installare kernel pea motivo dice se installa kernel-pea deve cambiare architettura da x64 a i686...
quindi niente installa altri kernel...ora cosa devo fare?
dobbiamo scrivere bug ma non so dov'è errore...
durante boot non c'è scritto "error" o "fail" solo si ferma a lungo o infinito tempo, lista per rilevazione sempre hub-usb e usb, generic-usb..

penso che ora posso provare andare yast>bootloader> vede cosa scritto avvia boot:
failsafe con script:
"showopts apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe"

invece senza failsafe:
"< resume=/dev/disk/by-id/ata-WDC_WD6400AAKS-40H2B0_WD-WCASY3338542-part3 splash=silent quiet showopts"

penso senza failsafe dobbiamo aggiungere qualcosa?

Ritratto di tunjin
tunjin
(Geek)
Offline
Geek
Iscritto: 19/02/2007
Messaggi: 102

ora provo aggiungere repository in yast:
http://download.opensuse.org/repositories/Kernel:/openSUSE-11.3/openSUSE_11.3/
per nuovi kernel poi vediamo che dici?

Ritratto di tunjin
tunjin
(Geek)
Offline
Geek
Iscritto: 19/02/2007
Messaggi: 102

cari
è la stessa problema dopo aggiornato kernel...uff uffa!! gia perdita tempo circa 3 giorni...devo usare computer imac per mio lavoro...che facciamo?
io penso uso sempre diretta con failsafe, funzione bene con failsafe?
ma failsafe :
showopts apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe
io modifico:
showopts apm=on noresume edd=on powersaved=on nohz=on highres=on"
va bene?