[RISOLTO] Ripristinare grub (era: Maledetto windows)

6 risposte [Ultimo messaggio]
Ritratto di Anonimo
Anonimo
()

In fase di installazione di opensuse avevo creato una partizione boot dedicata di 128mb, oggi, dovendo reinstallare windows dopo gravi problemi, non mi parte più. Credevo di essere al riparo non avendo installato grub sull'mbr invece non va più; ho notato che sulla vers. 11.3 non è più possibile ripristinare grub dal dvd come sulle precedenti, come posso fare per riavere il boot originale?

Ritratto di Andrea85
Andrea85
(Collaboratore)
Offline
Collaboratore
Iscritto: 22/12/2008
Messaggi: 801

Usa questi comandi da una live e riavvia (X dipende da quanti hd hai (0 per il primo, 1 per il secondo...) e Y dalla partizione dove c'è /boot)

grub
root (hdX,Y)
setup (hdX)
quit

Ritratto di mae89
mae89
(Geek)
Offline
Geek
Iscritto: 29/11/2006
Messaggi: 140

confermo che in internet trovi molte guide con il sistema descritto da Andrea 85.

Personalmente, con quel sistema non sono mai riuscito a sistemare il "casino" fatto da windoz.... per cui, ti faccio i miei auguri Wink speriamo tu sia più fortunato di me... eheh

...] LinuxMX [...
Sito riguardante Linux, Programmazione ed Elettronica!!!
E da oggi anche Video Tutorial

Ritratto di Sarkiapone
Sarkiapone
(Webmaster)
Offline
Webmaster
Iscritto: 04/09/2004
Messaggi: 743

Puoi anche leggere questa discussione: http://www.suseitalia.org/forum/varie/ripristinare-grub-con-live-di-opensuse-112?page=1

Sono proposti diversi metodi per ripristinare Grub, Oppure puoi fare una ricerca all'interno del sito:

http://www.suseitalia.org/search/apachesolr_search/ripristinare%20grub

E' un argomento trattato abbastanza spesso Smile

Ritratto di Andrea85
Andrea85
(Collaboratore)
Offline
Collaboratore
Iscritto: 22/12/2008
Messaggi: 801

mae89 ha scritto:

confermo che in internet trovi molte guide con il sistema descritto da Andrea 85.

Personalmente, con quel sistema non sono mai riuscito a sistemare il "casino" fatto da windoz.... per cui, ti faccio i miei auguri Wink speriamo tu sia più fortunato di me... eheh


Strano, io ho sempre fatto in quel modo ed è sempre andato a posto Worried

Ritratto di Crismon
Crismon
(Guru)
Offline
Guru
Iscritto: 28/11/2006
Messaggi: 1715

Segnalo anche questa guida scritta da Maxwell su Crismon's Blog: http://www.crismonblog.org/opensuse-102/opensuse-102-italian/fix-grub-bootloader.html

www.crismonblog.org | Un blog targato openSUSE

Ritratto di Anonimo
susewolf (non verificato)
()

Windows 7 aveva semplicemente eliminato il flag dalla partizione di avvio, con Gparted l'ho rimessa al posto giusto e tutto è andato a posto.
L'avevo già dovuto fare ma, forse a causa del precoce deperimento cerebrale, non mi ricordavo più....