Aggiornamento KDE 4.6.3

5 risposte [Ultimo messaggio]
Ritratto di Benzocaino
Benzocaino
(Junior)
Offline
Junior
Iscritto: 02/06/2011
Messaggi: 6

Sono un nuovissimo utente di OpenSuse, provengo da anni passati con la ex ottima Ubuntu ed ora mi trovo in difficoltà con gli aggiornamenti.
Mi sono documentato sui repository e ne ho provati un paio ma non riesco ad aggiornare la versione di KDE.
Avrei bisogno di qualche dritta.

Ho installato la 11.4, ho inserito e aggiornato i driver propietari nVidia e ho aggiunto questo repository:
http://download.opensuse.org/repositories/KDE:/Release:/46/openSUSE_11.4/

ma kde resta alla versione 4.6.0

Grazie anticipatamente per l'aiuto.

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2732

Core packages: http://download.opensuse.org/repositories/KDE:/Release:/46/openSUSE_11.4/
Extra: http://download.opensuse.org/repositories/KDE:/Extra/KDE_Release_46_openSUSE_11.4/
Unstable:Playground: http://download.opensuse.org/repositories/KDE:/Unstable:/Playground/KDE_Release_46_openSUSE_11.4/
Devi anche modificare zypp,per far si che Yast ti veda gli aggiornamenti.
Basta andare a modificare il file /etc/zypp/zypp.conf decommentare la riga "solver.AllowVendorChange = false" e mettere true al posto di false, salvare chiudere yast e riaprirlo.
decommentare= togliere # davanti a Solver.AllowVendorChange etc etc

metti questi,ma prima rimuovi gli altri kde repository
ciao

SUSE Tumbleweed- kernel-5.4.10-1.1- kde-plasma-5.17.5.1- Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-390.132.51- SSD samsung 850 pro 512 gb http://opensuse-community.org/

Ritratto di Benzocaino
Benzocaino
(Junior)
Offline
Junior
Iscritto: 02/06/2011
Messaggi: 6

Ho fatto come indicato ma al riavvio mi sono trovato un sistema, come dire, troppo ballerino.
Poiché sono in fase di test formatto e provo Chakra, non me ne vogliate susisti, prima o poi tornerò Big Grin

Grazie 1000 dragoncello, a presto.

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2732

Benzocaino ha scritto:

Ho fatto come indicato ma al riavvio mi sono trovato un sistema, come dire, troppo ballerino.
Poiché sono in fase di test formatto e provo Chakra, non me ne vogliate susisti, prima o poi tornerò Big Grin

Grazie 1000 dragoncello, a presto.

Di niente,guarda uso dal 2005 Debian,e suse dalla 9.3,a parte mandriva questi sono stati da sempre i miei os,dei tre il so primario è suse11.4,repository rolling,mai un problema, non risolvibile,non è che hai portato il tuo pc in discoteca?
Ti aspettiamo,
ciao

SUSE Tumbleweed- kernel-5.4.10-1.1- kde-plasma-5.17.5.1- Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-390.132.51- SSD samsung 850 pro 512 gb http://opensuse-community.org/

Ritratto di aksaf
aksaf
(Guru)
Offline
Guru
Iscritto: 08/03/2011
Messaggi: 957

Scusate, messaggio duplicato causa: sottoscritto e connessione Int. a carbone.

Ritratto di aksaf
aksaf
(Guru)
Offline
Guru
Iscritto: 08/03/2011
Messaggi: 957

Ciao Benzocaino,
se riproverai con openSUSE, ricordati che puoi anche aggiornare tutti i pacchetti di un singolo repository via yast: per esempio selezioni da "Gestioni Pacchetti" il repo "KDE 4.6 Release... " e poi click su "Passa i pacchetti di sistema alla versione di questo reposit...", risolvendo poi eventuali dipendenze irrisolte (in genere non molte) in maniera conservativa cioè scegliendo di mantenere la vecchia versione di un pacchetto che va in conflitto per aggiornarlo poi in seguito. Sarà un metodo "niubbio" e poco elegante ma che non mi ha mai dato quei gran problemi. Se sei un amante della CLI guarda qui direttamente: http://en.opensuse.org/SDB:KDE_upgrade#Upgrade_to_Latest_Release_from_Upstream_KDE. Certo è un metodo più macchinoso di quello descritto da Gollum, che ti permetteva di avere una gestione dei pacchetti alla Ubuntu (o alla Debian?), ma alla fine è anche un po' questine di abitudine, penso.