installare le screenlets

6 risposte [Ultimo messaggio]
Ritratto di raveragl
raveragl
(Junior)
Offline
Junior
Iscritto: 10/09/2010
Messaggi: 27

scusate il disturbo ma non riesco a far funzionare le screenlets
ho preso i repo dal sito ufficiale di screenlets e con installa/rimuovi o usato il pacchetto trovato ma non compare nessuna icona
e anche con esegui applcazioni non parte
ho anche provato ad installare il file rpm senza risultato
nel forum ho cercato non ho trovato la soluzione
come distribuzione ho suse 11,4 (celadon)
kelner 2.6.37.2-0.5
gnome 2.32.1
considerate che siccome non sono neofilo in materia posso aver fatto qualche errore
grazie ancora dell'aiuto

Ritratto di Gollum
Gollum
(Collaboratore)
Offline
Collaboratore
Iscritto: 03/03/2005
Messaggi: 802

Scusa ma il pacchetto RPM da dove l'hai preso, io l'unico che ho trovato è quello per openSUSE Factory, poi un'altra cosa hai pensato ad avviare il programma da terminale?

Desktop DELL XPS8100 => openSUSE_12.2 => KDE 4.10 => Core i7 => 3.4.28-2.20 => Nvidia GT220
Notebook Sony Vaio VPPCA =>openSUSE_12.2 => KDE 4.10 => Core i5 => 3.4.28-2.20 => AMD HD 6470M

Ritratto di aksaf
aksaf
(Guru)
Offline
Guru
Iscritto: 08/03/2011
Messaggi: 957

Sul sito ho trovato solo un ppa per Ubuntu e un link per openSUSE, hai scaricato gli rpm dal repo http://download.opensuse.org/repositories/home:/some-guy:/screenlets/openSUSE_Factory/ ?
Non me ne intendo molto ma mi sembrano un po' vecchi.
Perché, per esempio, non provi questi http://download.opensuse.org/repositories/home:/maxge73/openSUSE_11.4/ ?
In ogni caso, usa la ricerca di openSUSE per maggiori risultati: https://build.opensuse.org/search/search?search_text=screenlet&commit=Search&project=1&package=1&name=1&attribute=&advanced=on .
Inoltre una volta trovato ciò che cerchi potresti voler aggiungere direttamente il repository e poi usare yast/zypper per installare: prova a fare una ricerca in questo forum, oppure vedi qua: http://it.opensuse.org/SDB:Aggiungere_repository_dei_pacchetti .

Ritratto di raveragl
raveragl
(Junior)
Offline
Junior
Iscritto: 10/09/2010
Messaggi: 27

grazie dei consigli molto utili e precisi
sono riuscito ad installare con rpm dal tuo link
però ora ho un problema quando uso installa/rimuovi software mi da un pacchetto da modificare
che credo sia un pacchetto di screenlets che avevo installato prima con altri rpm o reposity
però quando lo vado ad disistallare mi dice che non si può e non mi fa più funzionare i screenlets
nuovi installati.
sapete mica come posso fare
capisco che sono stato io a creare il problema facendo installazioni sbagliate
però non so come risolvere
grazie ancora

Ritratto di aksaf
aksaf
(Guru)
Offline
Guru
Iscritto: 08/03/2011
Messaggi: 957

Umh, detto così non mi è molto chiaro.
Puoi mandare il risultato del comando

zypper repos -d

?
inoltre una schermata della finestra con l'errore potrebbe essere molto utile.
Vorrei infatti capire se hai aggiunto il repo degli screenlets, se sì quale. Inoltre se si tratta di un conflitto o di un file da aggiornare, nel caso in cui tu fossi passato dal primo repo degli screenlets (quello Factory) a quello nuovo dell'Open Build Service (max..etc.. mi pare).

Ritratto di raveragl
raveragl
(Junior)
Offline
Junior
Iscritto: 10/09/2010
Messaggi: 27

Da installa/rimuovi in pacchetto che non si installa mi dice :
Rmozione del pacchetto non riuscita
e in mostra dettagli:
Subprocess failed. Error: RPM non riuscito: error: package screenlets-0.1.2-18.1.x86_64 is not installed
per quanto riguarda il termiminale mi dice:

raveragl@Host-002:~> zypper repos -d
#  | Alias                             | Nome                                      | abilitato | Attualizza | Priorità | Tipo   | URI                                                                             | Servizio
---+-----------------------------------+-------------------------------------------+-----------+------------+----------+--------+---------------------------------------------------------------------------------+---------
 1 | download.nvidia.com-opensuse      | nVidia Graphics Drivers                   |||   99     | rpm-md | ftp://download.nvidia.com/opensuse/11.4/                                        |         
 2 | download.opensuse.org-Apps        | openSUSE BuildService - GNOME:Apps        |||   99     | rpm-md | http://download.opensuse.org/repositories/GNOME:/Apps/openSUSE_11.4/            |         
 3 | download.opensuse.org-Banshee     | openSUSE BuildService - Banshee           |||   99     | rpm-md | http://download.opensuse.org/repositories/Banshee/openSUSE_11.4/                |         
 4 | download.opensuse.org-Education   | openSUSE BuildService - Education         |||   99     | rpm-md | http://download.opensuse.org/repositories/Education/openSUSE_11.4/              |         
 5 | download.opensuse.org-STABLE      | openSUSE BuildService - OpenOffice.org    |||   99     | rpm-md | http://download.opensuse.org/repositories/OpenOffice.org:/STABLE/openSUSE_11.4/ |         
 6 | download.opensuse.org-filesystems | openSUSE BuildService - filesystems       |||   99     | rpm-md | http://download.opensuse.org/repositories/filesystems/openSUSE_11.4/            |         
 7 | download.opensuse.org-games       | openSUSE BuildService - Giochi            |||   99     | rpm-md | http://download.opensuse.org/repositories/games/openSUSE_11.4/                  |         
 8 | download.opensuse.org-mozilla     | openSUSE BuildService - Mozilla           |||   99     | rpm-md | http://download.opensuse.org/repositories/mozilla/openSUSE_11.4/                |         
 9 | download.opensuse.org-non-oss     | Repository principale (NON-OSS)           |||   99     | yast2  | http://download.opensuse.org/distribution/11.4/repo/non-oss/                    |         
10 | download.opensuse.org-non-oss_1   | openSUSE-11.4-Non-Oss                     |||   99     | yast2  | http://download.opensuse.org/distribution/11.4/repo/non-oss                     |         
11 | download.opensuse.org-oss         | Repository principale (OSS)               |||   99     | yast2  | http://download.opensuse.org/distribution/11.4/repo/oss/                        |         
12 | download.opensuse.org-oss_1       | openSUSE-11.4-Oss                         |||   99     | yast2  | http://download.opensuse.org/distribution/11.4/repo/oss                         |         
13 | download.opensuse.org-packages    | openSUSE BuildService - Java:packages     |||   99     | rpm-md | http://download.opensuse.org/repositories/Java:/packages/openSUSE_11.4/         |         
14 | download.opensuse.org-standard    | Repository principale (Contrib)           |||   99     | rpm-md | http://download.opensuse.org/repositories/openSUSE:/11.4:/Contrib/standard/     |         
15 | download.opensuse.org-update      | Repository degli aggiornamenti (DEBUG)    |||   99     | rpm-md | http://download.opensuse.org/debug/update/11.4/                                 |         
16 | download.opensuse.org-update_1    | Repository principale degli aggiornamenti |||   99     | rpm-md | http://download.opensuse.org/update/11.4/                                       |         
17 | google                            | google                                    |||   99     | rpm-md | http://dl.google.com/linux/rpm/stable/i386                                      |         
18 | google-chrome                     | google-chrome                             |||   99     | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/x86_64                             |         
19 | home:some-guy:screenlets          | home:some-guy:screenlets                  |||   99     | rpm-md | http://download.opensuse.org/repositories/home:/some-guy:/screenlets/SLE_11/    |         
20 | opensuse-guide.org-repo           | libdvdcss repository                      |||   99     | rpm-md | http://opensuse-guide.org/repo/11.4/                                            |         
21 | packman.inode.at-suse             | Packman Repository                        |||   99     | rpm-md | http://packman.inode.at/suse/openSUSE_11.4/                                     |         
22 | repo-debug                        | openSUSE-11.4-Debug                       |||   99     | yast2  | http://download.opensuse.org/debug/distribution/11.4/repo/oss/                  |         
23 | repo-debug-update                 | openSUSE-11.4-Update-Debug                |||   99     | rpm-md | http://download.opensuse.org/debug/update/11.4/                                 |         
24 | repo-non-oss                      | openSUSE-11.4-Non-Oss                     |||   99     | yast2  | http://download.opensuse.org/distribution/11.4/repo/non-oss/                    |         
25 | repo-oss                          | openSUSE-11.4-Oss                         |||   99     | yast2  | http://download.opensuse.org/distribution/11.4/repo/oss/                        |         
26 | repo-source                       | openSUSE-11.4-Source                      |||   99     | yast2  | http://download.opensuse.org/source/distribution/11.4/repo/oss/                 |         
27 | repo-update                       | openSUSE-11.4-Update                      |||   99     | rpm-md | http://download.opensuse.org/update/11.4/                                       |         
raveragl@Host-002:~>

grazie ancora dell'aiuto

Ritratto di aksaf
aksaf
(Guru)
Offline
Guru
Iscritto: 08/03/2011
Messaggi: 957

Per favore la prossima volta che invii i risultati di un comando se possibile incolla il testo usando il tag code: risulta più leggibile.
Ho notato che hai un repo della SLE per gli screenlet: eliminalo da yast --> programmi --> repository dei prog. o con zypper

# zypper rr 19

aggiungi poi il repo di max73 che ti ho indicato prima, puoi usare yast... repository (come sopra) aggiungi --> url e scrivi l'URL http://download.opensuse.org/repositories/home:/maxge73/openSUSE_11.4 o con zypper:
# zypper ar -f -r http://download.opensuse.org/repositories/home:/maxge73/openSUSE_11.4/home:maxge73.repo

e poi installa quel che ti serve con yast --> Gest. P.. o
# zypper install screenlets

--edit--
corretti errori in cmd e tag