Firefox crasha di continuo

17 risposte [Ultimo messaggio]
Ritratto di badmark
badmark
(Junior)
Offline
Junior
Iscritto: 18/09/2011
Messaggi: 25

Ciao a tutti,

Ho un problema con Firefox e presumo, con il flash player. Il browser crasha su qualsiasi sito "impegnativo", in particolare sotto streaming, dove ormai, poter vedere più di trenta secondi di filmato senza dover riavviare tutto, modem compreso, è diventata un'utopìa.
Il sistema è OpenSuse 11.4, la versione di Firefox è la 6.0, data per stabile...
Posso risolvere installando una versione del browser più vecchia? Se si, come procedo?
E il player? E' normale che crashi una volta sì e l'altra pure?

Grazie.

Ritratto di aksaf
aksaf
(Guru)
Offline
Guru
Iscritto: 08/03/2011
Messaggi: 957

Potresti iniziare verificando di aver installato la versione 11 di flash-player. Se il sistema è a 32 bit dovresti controllare di avere installato ed aggiornato pullin-flash-player (pullin-flash-player-11.4.1-0.3.1.i586.rpm) che scarica l'ultima versione del tiene aggiornato flashplayer, ma alla versione 10, almeno per quanto ne so.
Se invece il sist. è a 64 bit, o se vuoi usare l'ultima versione (11 rc) anche su 32 bit, dovresti eliminare il flashplayer 10 (a 32 bit) installato di default (http://dl.dropbox.com/u/10573557/Flash_Fix/delete_flash.png) e poi... andare qui: http://www.suseitalia.org/blog/wal7er/2011/07/25/makefile-installazione-del-plugin-flash-3264-bit-versione-11-beta

P.S.: puoi usare quella guida e script anche per scaricare ed installare la versione a 32 bit di flashpl. 11

--edit--
corretto versioni disponibili di flash adobe per 32 e 64 bit, in base a mie conoscenze attuali (mi ero lasciato ingannare da ver. pullin-flash-player)

Ritratto di Andrea85
Andrea85
(Collaboratore)
Offline
Collaboratore
Iscritto: 22/12/2008
Messaggi: 801

Come hai installato firefox e flash-player?
Con firefox dal repository mozilla e flash-player da non-oss funziona tutto bene...

Ritratto di badmark
badmark
(Junior)
Offline
Junior
Iscritto: 18/09/2011
Messaggi: 25

Firefox è quello "di serie"; il plugin flash onestamente non ricordo da dove l'ho preso...

Comunque ho scaricato il makefile, ma se provo a dare i comandi indicati mi dice:

If 'make' is not a typo you can use command-not-found to lookup the package that contains it, like this:
cnf make

Con la console sono proprio negato...

Ah, uso Gnome...

Ritratto di wal7er
wal7er
(Guru)
Offline
Guru
Iscritto: 21/09/2007
Messaggi: 572

badmark ha scritto:


Firefox è quello "di serie"; il plugin flash onestamente non ricordo da dove l'ho preso...

Facile: o direttamente dal sito adobe o dai repo di opensuse (che comunque prendono l'eseguibile da adobe)

badmark ha scritto:


Comunque ho scaricato il makefile, ma se provo a dare i comandi indicati mi dice:

If 'make' is not a typo you can use command-not-found to lookup the package that contains it, like this:
cnf make

Con la console sono proprio negato...

Ah, uso Gnome...

Non hai installato il comando make: non è colpa tua perchè di default non viene installato.

NB:
La console è tua amica. Wink

HP Pavilion dv5-1110el powered by OpenSUSE 13.2 64bit

http://linuxcounter.net/cert/432576.png

Ritratto di badmark
badmark
(Junior)
Offline
Junior
Iscritto: 18/09/2011
Messaggi: 25

...e quindi??

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2739

Quindi .....apri yast,gestione pacchetti,visulizza, modelli e spunti sviluppo base,sviluppo /C/C++ ,e datosi che ci sei kernel source,kernel devel
by

SUSE Tumbleweed- kernel-5.6.14.1.1- kde-plasma-5.18.5.1- Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-390.132.14- SSD samsung 850 pro 512 gb http://opensuse-community.org/

Ritratto di badmark
badmark
(Junior)
Offline
Junior
Iscritto: 18/09/2011
Messaggi: 25

non ho capito molto...
comunque ho risolto ugualmente, disinstallando e reinstallando pari pari il plugin e il pullin...boh...misteri di opensuse...

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2739

Metti risolto, "ti ho chiesto troppo" è veramente difficile.........
1)aprire yast
2)gestione pacchetti
3)visualizza
4)modelli
5)spunta, sviluppo base, e sviluppo C/C++
6)kernel devel
7)kernel source

SUSE Tumbleweed- kernel-5.6.14.1.1- kde-plasma-5.18.5.1- Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-390.132.14- SSD samsung 850 pro 512 gb http://opensuse-community.org/

Ritratto di badmark
badmark
(Junior)
Offline
Junior
Iscritto: 18/09/2011
Messaggi: 25

Ci risiamo: adesso il browser crasha ad ogni occasione, anche al di fuori dei siti streaming: se ad esempio insisto troppo a navigare un qualsiasi forum o blog la connessione cade inesorabilmente. resta inoltre il problema sui video, non più di 10 secondi consecutivi di visione prima del crollo...

Ritratto di doc_pluto
doc_pluto
(Guru)
Offline
Guru
Iscritto: 08/02/2007
Messaggi: 871

prova un altro browser e vedi se le cose cambiano, così magari escludi problemi tuoi di rete o altro.

che ne so, prova Chromium, Opera, Konqueror, ..

Hardware: MB:P5E3_Deluxe - CPU:Core2Duo E8400 3.0GHz - RAM:Kingstone_2Gb_DDR3 - Video:GeForce9600GT/PCI/SSE2 - HD: 2x WDCaviarBlue 1TB
--------------------------------
Software: SO:openSuSE 12.1 - ARCH:64bit - DE:Gnome3 - DriverVideo:Ufficiali Nvidia