disabilitare autorun di banshee all'inserimento di chiavetta USB

21 risposte [Ultimo messaggio]
Ritratto di doc_pluto
doc_pluto
(Guru)
Offline
Guru
Iscritto: 08/02/2007
Messaggi: 871

come da topic, ogni volta che inserisco una chiavetta USB, anche se sono assenti file multimediali, viene lanciato in automatico..
non capisco come disabilitare questo comportamento che è stato sempre presente..

Hardware: MB:P5E3_Deluxe - CPU:Core2Duo E8400 3.0GHz - RAM:Kingstone_2Gb_DDR3 - Video:GeForce9600GT/PCI/SSE2 - HD: 2x WDCaviarBlue 1TB
--------------------------------
Software: SO:openSuSE 12.1 - ARCH:64bit - DE:Gnome3 - DriverVideo:Ufficiali Nvidia

Ritratto di aksaf
aksaf
(Guru)
Offline
Guru
Iscritto: 08/03/2011
Messaggi: 957

Non sono sicuro, ma magari nautilus > Modifica > Preferenze > Supporti può fare al caso tuo?

Ritratto di Gollum
Gollum
(Collaboratore)
Offline
Collaboratore
Iscritto: 03/03/2005
Messaggi: 802

aksaf ti ha consigliato la procedura giusta, ma forse lo stesso risultato potresti ottenerlo disabilitando il plugin per il supporto dei dispositivi USB direttamente dalle opzioni di banshee ( non sono sicuro però, dato che è molto tempo che non uso ne banshee, rhythmbox o qualsiasi altro player predefinito ).

Desktop DELL XPS8100 => openSUSE_12.2 => KDE 4.10 => Core i7 => 3.4.28-2.20 => Nvidia GT220
Notebook Sony Vaio VPPCA =>openSUSE_12.2 => KDE 4.10 => Core i5 => 3.4.28-2.20 => AMD HD 6470M

Ritratto di Suse98
Suse98
(Guru)
Offline
Guru
Iscritto: 03/10/2010
Messaggi: 1711

Fai come ti hanno detto i due utenti Gollum e aksaf , o vai in nautilus (come suggerito da aksaf) o da banshee disabiliti i pluhin (come detto da gollum)
Scusa , ma quando la inserisci , non ti compare il menù con scritto cosa puoi fare ?
Ciao

SUSE LINUX Rilascio 12.3 (Dartmounth) KDE 4.10 && GNOME 3.8

Ritratto di doc_pluto
doc_pluto
(Guru)
Offline
Guru
Iscritto: 08/02/2007
Messaggi: 871

scusate ho tralasciato un dettaglio forse importante.
utilizo come DE gnome-shell.

in allegato uno shot delle impostazioni dei dispositivi removibili..
nelle opzioni del file manager ho già guardato, ma non trovo nulla di utile..

proverò a disabilitare il plugin di banshee, attivandolo quando mi serve, ma mi sembra una soluzione poco elegante.

edit: no, all'inserimento di una chiavetta USB non compare nessuna finestra con menu..

Immagini allegate:

Hardware: MB:P5E3_Deluxe - CPU:Core2Duo E8400 3.0GHz - RAM:Kingstone_2Gb_DDR3 - Video:GeForce9600GT/PCI/SSE2 - HD: 2x WDCaviarBlue 1TB
--------------------------------
Software: SO:openSuSE 12.1 - ARCH:64bit - DE:Gnome3 - DriverVideo:Ufficiali Nvidia

Ritratto di doc_pluto
doc_pluto
(Guru)
Offline
Guru
Iscritto: 08/02/2007
Messaggi: 871

non riedito, solo per riportare in alto la discussione, con quest'aggiunta.

ho notato che quando da qualche applicazione (ad esempio qBittorent, Transmission, Skype) si seleziona "Apri cartella di destinazione" da un menù, si apre Banshee invece del file manager.

io credo che il problema dell'apertura di banshee quando insersco chiavette USB derivi da questa cosa, ma non so assolutamente come risolverlo.

Hardware: MB:P5E3_Deluxe - CPU:Core2Duo E8400 3.0GHz - RAM:Kingstone_2Gb_DDR3 - Video:GeForce9600GT/PCI/SSE2 - HD: 2x WDCaviarBlue 1TB
--------------------------------
Software: SO:openSuSE 12.1 - ARCH:64bit - DE:Gnome3 - DriverVideo:Ufficiali Nvidia

Ritratto di doc_pluto
doc_pluto
(Guru)
Offline
Guru
Iscritto: 08/02/2007
Messaggi: 871

doc_pluto ha scritto:

non riedito, solo per riportare in alto la discussione, con quest'aggiunta.

ho notato che quando da qualche applicazione (ad esempio qBittorent, Transmission, Skype) si seleziona "Apri cartella di destinazione" da un menù, si apre Banshee invece del file manager.

io credo che il problema dell'apertura di banshee quando insersco chiavette USB derivi da questa cosa, ma non so assolutamente come risolverlo.

riporto su la discussione.
il problema persiste ancora anche con l'aggiornamento alla 12.1, anzi addirittura ora con la nuova release la situazione è quella in allegato.
ora parte in automatico VLC invece che banshe.

Immagini allegate:

Hardware: MB:P5E3_Deluxe - CPU:Core2Duo E8400 3.0GHz - RAM:Kingstone_2Gb_DDR3 - Video:GeForce9600GT/PCI/SSE2 - HD: 2x WDCaviarBlue 1TB
--------------------------------
Software: SO:openSuSE 12.1 - ARCH:64bit - DE:Gnome3 - DriverVideo:Ufficiali Nvidia

Ritratto di ciappetta
ciappetta (non verificato)
()

credo che la cosa dipenda dalle impostazioni dell'applet notifica dispositivi. Hai delle impostazioni sballate.
prova a disabilitare il montaggio automatico.
E setta i vari dispositivi correttamente.

Ritratto di doc_pluto
doc_pluto
(Guru)
Offline
Guru
Iscritto: 08/02/2007
Messaggi: 871

ciappetta ha scritto:

E setta i vari dispositivi correttamente.

meglio di così??? vedi allegato.

Immagini allegate:

Hardware: MB:P5E3_Deluxe - CPU:Core2Duo E8400 3.0GHz - RAM:Kingstone_2Gb_DDR3 - Video:GeForce9600GT/PCI/SSE2 - HD: 2x WDCaviarBlue 1TB
--------------------------------
Software: SO:openSuSE 12.1 - ARCH:64bit - DE:Gnome3 - DriverVideo:Ufficiali Nvidia

Ritratto di ciappetta
ciappetta (non verificato)
()

Qua non vedo USB. Forse alla voce altri dispositivi?

Ritratto di doc_pluto
doc_pluto
(Guru)
Offline
Guru
Iscritto: 08/02/2007
Messaggi: 871

ciappetta ha scritto:

Qua non vedo USB. Forse alla voce altri dispositivi?

ecco gli "altri dispositivi".
le prime due righe sono bianche, non si legge nulla.
cmq sono tutti impostati su "Nessuna azione"

edit:
quando inserisco un CD, DVD, le uniche opzioni che si presentano sono
_Apri con VLC
_Espelli

non ci sono anche Copia, Cancella, Nautilus?

Immagini allegate:

Hardware: MB:P5E3_Deluxe - CPU:Core2Duo E8400 3.0GHz - RAM:Kingstone_2Gb_DDR3 - Video:GeForce9600GT/PCI/SSE2 - HD: 2x WDCaviarBlue 1TB
--------------------------------
Software: SO:openSuSE 12.1 - ARCH:64bit - DE:Gnome3 - DriverVideo:Ufficiali Nvidia