Problema aggiornamento pacchetti da (nuovo) Packman

4 risposte [Ultimo messaggio]
Ritratto di openGATTO
openGATTO
(Junior)
Offline
Junior
Iscritto: 22/03/2008
Messaggi: 37

Salve! Smile

Uso ancora la "vecchia" versione 11.1 di openSUSE (devo sempre aggiornarla, ma non ho mai tempo...) e ho scoperto di recente che Packman è stato "rivoluzionato" e suddiviso in 4 repos.

Per la 11.1 però ne è disponibile solo 1, che prende il nome di Evergreen (http://packman.inode.at/suse/openSUSE_Evergreen_11.1/).

Sono così andato in YaST2, ho rimosso quello vecchio, la relativa chiave e poi aggiunto i nuovi (repo+key).

Quando però cerco di aggiornare un qualunque pacchetto, mi si apre una finestra di dialogo con il seguente messaggio di errore:

Subprocess failed. Error: RPM non riuscito:error: /var/cache/zypp/packages/Packman/Essentials/i586/libtag1-1.7-6.pm.39.10.i586.rpm: Header V4 RSA/SHA1 signature: BAD, key ID 1abd1afb
error: /var/cache/zypp/packages/Packman/Essentials/i586/libtag1-1.7-6.pm.39.10.i586.rpm cannot be installed

Non mi è mai successo prima e non so come risolvere la faccenda Sad

Mi aiutate?

Grazie!

Un giorno da leone o cento da pecora?
Meglio una vita da (open)GATTO! Wink

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2730

Non è piu supportata da novel,quindi vedi te. il repo packman funziona,la distro è supportata solo da leggi:
http://en.opensuse.org/Portal:11.1
installati la 11.4 o aspetta un mese e metti la 12.1
by

SUSE Tumbleweed- kernel-5.3.12-1.2- kde-plasma-5.17.4.1- Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-390.132.51- SSD samsung 850 pro 512 gb http://opensuse-community.org/

Ritratto di aksaf
aksaf
(Guru)
Offline
Guru
Iscritto: 08/03/2011
Messaggi: 957

In questi due link mi pare ci siano alcune info:
http://forums.opensuse.org/english/get-technical-help-here/install-boot-login/455436-error-packman-evergreen-essential-bad-key.html
http://forums.opensuse.org/english/get-technical-help-here/applications/456811-opensuse-11-1-packman-update-impossible-claiming-key-pb.html

Ritratto di openGATTO
openGATTO
(Junior)
Offline
Junior
Iscritto: 22/03/2008
Messaggi: 37

dragoncello ha scritto:

Non è piu supportata da novel,quindi vedi te. il repo packman funziona,la distro è supportata solo da leggi:
http://en.opensuse.org/Portal:11.1
installati la 11.4 o aspetta un mese e metti la 12.1
by

Ciao! Smile Grazie per la risposta! Smile

Sì, lo sapevo che non era più supportata, però dato che quello di Packman è un repo di terze parti, supponevo fosse ancora disponibile...

... e infatti lo è Smile solo che sembra esserci un bug che affligge proprio la 11.1 (leggi più sotto la mia altra risposta).

Comunque, partendo da quel link che mi hai fornito, ho appreso che ne esiste anche una versione "archivio" (cioè, non più aggiornata periodicamente) ma soprattutto un utilissimo repo "evergreen" gestito dalla comunità, contenente nuove versioni di tutti i pacchetti più importanti! Smile

Per chi fosse interessato, maggiori info qui: http://en.opensuse.org/openSUSE:Evergreen

Un giorno da leone o cento da pecora?
Meglio una vita da (open)GATTO! Wink

Ritratto di openGATTO
openGATTO
(Junior)
Offline
Junior
Iscritto: 22/03/2008
Messaggi: 37

aksaf ha scritto:

In questi due link mi pare ci siano alcune info:
http://forums.opensuse.org/english/get-technical-help-here/install-boot-login/455436-error-packman-evergreen-essential-bad-key.html
http://forums.opensuse.org/english/get-technical-help-here/applications/456811-opensuse-11-1-packman-update-impossible-claiming-key-pb.html

Grazie anche a te per l'aiuto! Smile

Dunque, da ciò che mi sembra di capire da quei due threads, si tratta di un bug della 11.1 Sad che non gestisce chiavi a più di 1024 bit, mentre adesso si usano (Packman Evergreen incluso) a 4096; a tutt'oggi, pare che il problema non sia stato ancora risolto (forse mai lo sarà!). Sad

Mi sa che faccio prima ad aggiornami all'ultima versione di openSUSE! Wink

Un giorno da leone o cento da pecora?
Meglio una vita da (open)GATTO! Wink