Installare file

35 risposte [Ultimo messaggio]
Ritratto di aksaf
aksaf
(Guru)
Offline
Guru
Iscritto: 08/03/2011
Messaggi: 957

Il file binario pcsx2, nell'archivio che alleghi, è a 32 bit, la tua openSUSE parrebbe a 64 bit.
Le librerie wx* che ti servono sono quelle per i586 e *non* x86_64 (per le altre dipendenze c'è la versione di compatibilità con arch a 32 bit, quella con suffisso -32bit al NOME_PACCHETTO -- queste dipendenze dovrebbero comunque già essere installate).
Le librerie per architettura i586 che ti servono sono:

i | openSUSE-11.4-Update                                                          | libwx_baseu-2_8-0-compat-lib-stl                        | 2.8.11-4.13.1                      | i586  
i | openSUSE-11.4-Update                                                          | libwx_baseu-2_8-0-compat-lib-wxcontainer                | 2.8.11-3.13.1                      | i586  
i | openSUSE-11.4-Update                                                          | libwx_baseu-2_8-0-stl                                   | 2.8.11-4.13.1                      | i586  
i | openSUSE-11.4-Update                                                          | libwx_baseu-2_8-0-wxcontainer                           | 2.8.11-3.13.1                      | i586  
i | openSUSE-11.4-Update                                                          | libwx_gtk2u_adv-2_8-0-compat-lib-stl                    | 2.8.11-4.13.1                      | i586  
i | openSUSE-11.4-Update                                                          | libwx_gtk2u_adv-2_8-0-compat-lib-wxcontainer            | 2.8.11-3.13.1                      | i586  
i | openSUSE-11.4-Update                                                          | libwx_gtk2u_adv-2_8-0-stl                               | 2.8.11-4.13.1                      | i586  
i | openSUSE-11.4-Update                                                          | libwx_gtk2u_adv-2_8-0-wxcontainer                       | 2.8.11-3.13.1                      | i586  
i | openSUSE-11.4-Update                                                          | libwx_gtk2u_core-2_8-0-compat-lib-stl                   | 2.8.11-4.13.1                      | i586  
i | openSUSE-11.4-Update                                                          | libwx_gtk2u_core-2_8-0-compat-lib-wxcontainer           | 2.8.11-3.13.1                      | i586  
i | openSUSE-11.4-Update                                                          | libwx_gtk2u_core-2_8-0-stl                              | 2.8.11-4.13.1                      | i586  
i | openSUSE-11.4-Update                                                          | libwx_gtk2u_core-2_8-0-wxcontainer                      | 2.8.11-3.11.1                      | i586  
i | openSUSE-11.4-Update                                                          | wxWidgets-lang                                          | 2.8.11-4.13.1                      | noarch
i | openSUSE-11.4-Update                                                          | wxWidgets-wxcontainer-compat-lib-config                 | 2.8.11-3.13.1                      | i586  

Per sapere se manca altro:
cd /home/luigi/Scaricati/pcsx2-0.9.8-r4594-linux
ldd ./pcsx2

se mancano delle librerie avrai un risultato tipo questo:
libwx_baseu-2.8.so.0 => not found
e saprai/sapremo cosa manca.

Qui http://pkgs.org/mandriva-2011/mib-basic-i586/pcsx2-0.9.8-4600.2-mib2011.0.i686.rpm.html (è per mandriva ma va bene lo stesso) c'è l'elenco cliccabile delle dipendenze. Per ciascuna sono indicati i pacchetti da installare, specifici per ogni distribuzione (es.: http://pkgs.org/download/libwx_baseu-2.8.so.0 )

P.S.: wxWidgets-wxcontainer-compat-lib-config mi dava conflitti, ho evitato di installarlo ma il programma mi parte lo stesso (GUI inclusa), non posso controllare se poi funziona, ovviamente...

Ritratto di Suse98
Suse98
(Guru)
Offline
Guru
Iscritto: 03/10/2010
Messaggi: 1711

Ecco :

luigi@linux-6gb8:~> cd /home/luigi/Scaricati/pcsx2-0.9.8-r4594-linux
luigi@linux-6gb8:~/Scaricati/pcsx2-0.9.8-r4594-linux> ldd ./pcsx2
	linux-gate.so.1 =>  (0xffffe000)
	libwx_baseu-2.8.so.0 => not found
	libwx_gtk2u_core-2.8.so.0 => not found
	libwx_gtk2u_adv-2.8.so.0 => not found
	libglib-2.0.so.0 => /lib/libglib-2.0.so.0 (0xf765a000)
	libgobject-2.0.so.0 => /lib/libgobject-2.0.so.0 (0xf760a000)
	libgdk-x11-2.0.so.0 => /usr/lib/libgdk-x11-2.0.so.0 (0xf755b000)
	libgtk-x11-2.0.so.0 => /usr/lib/libgtk-x11-2.0.so.0 (0xf70f2000)
	libcairo.so.2 => /usr/lib/libcairo.so.2 (0xf702d000)
	libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0xf6fe1000)
	libatk-1.0.so.0 => /usr/lib/libatk-1.0.so.0 (0xf6fc2000)
	libz.so.1 => /lib/libz.so.1 (0xf6fab000)
	libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xf6ebc000)
	libm.so.6 => /lib/libm.so.6 (0xf6e92000)
	libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xf6e74000)
	libpthread.so.0 => /lib/libpthread.so.0 (0xf6e58000)
	libc.so.6 => /lib/libc.so.6 (0xf6ceb000)
	libpcre.so.0 => /lib/libpcre.so.0 (0xf6cb4000)
	librt.so.1 => /lib/librt.so.1 (0xf6caa000)
	libgthread-2.0.so.0 => /lib/libgthread-2.0.so.0 (0xf6ca4000)
	libpangocairo-1.0.so.0 => /usr/lib/libpangocairo-1.0.so.0 (0xf6c96000)
	libgio-2.0.so.0 => /lib/libgio-2.0.so.0 (0xf6b64000)
	libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0xf6b2e000)
	libXext.so.6 => /usr/lib/libXext.so.6 (0xf6b1c000)
	libXrender.so.1 => /usr/lib/libXrender.so.1 (0xf6b11000)
	libXinerama.so.1 => /usr/lib/libXinerama.so.1 (0xf6b0c000)
	libXi.so.6 => /usr/lib/libXi.so.6 (0xf6afc000)
	libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0xf6af3000)
	libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0xf6ae7000)
	libXcomposite.so.1 => /usr/lib/libXcomposite.so.1 (0xf6ae3000)
	libXdamage.so.1 => /usr/lib/libXdamage.so.1 (0xf6ade000)
	libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0xf6ad8000)
	libgdk_pixbuf-2.0.so.0 => /usr/lib/libgdk_pixbuf-2.0.so.0 (0xf6ab8000)
	libX11.so.6 => /usr/lib/libX11.so.6 (0xf697b000)
	libpangoft2-1.0.so.0 => /usr/lib/libpangoft2-1.0.so.0 (0xf694c000)
	libgmodule-2.0.so.0 => /lib/libgmodule-2.0.so.0 (0xf6946000)
	libpixman-1.so.0 => /usr/lib/libpixman-1.so.0 (0xf68c7000)
	libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0xf683f000)
	libpng14.so.14 => /usr/lib/libpng14.so.14 (0xf6813000)
	/lib/ld-linux.so.2 (0xf777d000)
	libresolv.so.2 => /lib/libresolv.so.2 (0xf67fb000)
	libselinux.so.1 => /lib/libselinux.so.1 (0xf67dc000)
	libexpat.so.1 => /lib/libexpat.so.1 (0xf67b2000)
	libxcb.so.1 => /usr/lib/libxcb.so.1 (0xf6792000)
	libdl.so.2 => /lib/libdl.so.2 (0xf678d000)
	libXau.so.6 => /usr/lib/libXau.so.6 (0xf6788000)
luigi@linux-6gb8:~/Scaricati/pcsx2-0.9.8-r4594-linux> 

Quindi ora installo :

Citazione:


        libwx_baseu-2.8.so.0 => not found
	libwx_gtk2u_core-2.8.so.0 => not found
	libwx_gtk2u_adv-2.8.so.0 => not found


Grazie

SUSE LINUX Rilascio 12.3 (Dartmounth) KDE 4.10 && GNOME 3.8

Ritratto di aksaf
aksaf
(Guru)
Offline
Guru
Iscritto: 08/03/2011
Messaggi: 957

Non le trova perché hai installato le librerie a 64 bit: devi installare quelle a 32 (per i586 non i585 Smile - c'era una svista nel mio messaggio di prima che ho corretto, scusa), p.es lo puoi fare via YaST selezionando l'architettura giusta dei pacchetti da installare (i pacchetti sono quelli che ti ho elencato prima).
Ciao

Ritratto di Suse98
Suse98
(Guru)
Offline
Guru
Iscritto: 03/10/2010
Messaggi: 1711

Scusami , ma non è meglio che cerco il file a 64 bit che installare pacchetti a 32 bit che non ho capito come si fa
Grazie

SUSE LINUX Rilascio 12.3 (Dartmounth) KDE 4.10 && GNOME 3.8

Ritratto di Suse98
Suse98
(Guru)
Offline
Guru
Iscritto: 03/10/2010
Messaggi: 1711

Ho trovato questo :
magnet:?xt=urn:btih:SSS7N7GTEDNGDXEXUHRCYO44BX5V6E4G&dn=PS2%20Emulator%200.9.3%20for%20Linux%20-%2032bit%20%26%2064bit%20%5bApp%5d%5bwww.zonatorrent.com%5d.rar&tr=http%3a%2f%2fvip.tracker.thepiratebay.org%2fannounce

SUSE LINUX Rilascio 12.3 (Dartmounth) KDE 4.10 && GNOME 3.8

Ritratto di aksaf
aksaf
(Guru)
Offline
Guru
Iscritto: 08/03/2011
Messaggi: 957

Suse98 ha scritto:

Scusami , ma non è meglio che cerco il file a 64 bit che installare pacchetti a 32 bit che non ho capito come si fa
Grazie


Non credo ci siano problemi, in ogni caso una versione vecchia di pcsx2 per openSUSE 64 bit c'è, cercala al solito posto: software.opensuse.org/search

Ritratto di Suse98
Suse98
(Guru)
Offline
Guru
Iscritto: 03/10/2010
Messaggi: 1711

Scusa , l'ho installato , ma non c'è in computer==>Altre applicazioni.
Come mai ?
Grazie

SUSE LINUX Rilascio 12.3 (Dartmounth) KDE 4.10 && GNOME 3.8

Ritratto di Suse98
Suse98
(Guru)
Offline
Guru
Iscritto: 03/10/2010
Messaggi: 1711

L'ho avviato da terminale , solo che non so configurarlo :
Qualcuno mi può dare una mano ?
Grazie
P.S.:

Per la scheda grafica si devono installare :

libCg
libCg-devel

Grazie per il vostro aiuto
P.P.S.:
Le cartelle per il Bios che io ho trovato , sono queste , vedete se vanno bene ( io ci ho provato ) :
Bios Linux Pcsx2 ; per aprirlo con File Roller , fate fare la ricerca del comando dopo cliccato 2 volte
Grazie ancora

SUSE LINUX Rilascio 12.3 (Dartmounth) KDE 4.10 && GNOME 3.8

Ritratto di Suse98
Suse98
(Guru)
Offline
Guru
Iscritto: 03/10/2010
Messaggi: 1711

L'ho configurato a casaccio , ma se faccio Run CD , lui mi dice che è un bug :

L'allegato è il bug.

AllegatoDimensione
unknown-bugreport.txt 4.79 KB

SUSE LINUX Rilascio 12.3 (Dartmounth) KDE 4.10 && GNOME 3.8

Ritratto di Andrea85
Andrea85
(Collaboratore)
Offline
Collaboratore
Iscritto: 22/12/2008
Messaggi: 801

http://forums.pcsx2.net/Thread-Guida-italiana-ufficiale-v0-9-6