openSUSE 12.1 GNOME + problemi con driver AMD (non installare).

117 risposte [Ultimo messaggio]
Ritratto di Gero
Gero
(Geek)
Offline
Geek
Iscritto: 24/10/2011
Messaggi: 106

Templare ha scritto:

Decisamente non ci siamo in KDE 64 bit. Anche se il driver è effettivamente installato corettamente, KDE va in certi crash da far paura.

L'ho appena installati con il metodo con il quale ho rettificato.

Siete utenti KDE 64 bit? Lasciate perdere i driver proprietari con KDE 64, è un consiglio d'amico.

meglio restare con quelli che ho nativi di linux?

Produttore:  ATI Technologies Inc
  Modello:  ATI MOBILITY RADEON HD 4650
  Driver 2D:  radeon
  Driver 3D:  Sconosciuto Gallium (7.11)

nn capisco come mai il post sia impostato a Risolto?

NoteBook --> HP 1270EL --> T9600 2.8GHz --> 4Gb RAM --> ATI 4650 OpenSuse 12.1 64_Bit con KDE 4.7.3 (4.7.3) "release 10"

Ritratto di Templare
Templare
(Collaboratore)
Offline
Collaboratore
Iscritto: 28/10/2011
Messaggi: 747

Perchè con la mia configurazione io consiglio di restare con i driver open, mentre chi ha schede AMD Radeon dalla serie HD 2000 fino alla HD 5000 può procedere all'installazione del driver proprietario.

Assemblato 1: Phenom II X4 965 Black Edition + AMD Radeon HD 5770 + Scheda Madre Asus Crosshair IV Formula + Scheda Audio Asus Xonar D2X. Sistema Windows 7 Ultimate 64 Bit
Assemblato 3: Intel Core i3 3220 + nVIDIA Geforce 640 GT. Sistema openSUSE 13.1 64 bit GNOME

Ritratto di Gero
Gero
(Geek)
Offline
Geek
Iscritto: 24/10/2011
Messaggi: 106

Templare ha scritto:

Perchè con la mia configurazione io consiglio di restare con i driver open, mentre chi ha schede AMD Radeon dalla serie HD 2000 fino alla HD 5000 può procedere all'installazione del driver proprietario.

per capire quale guida devo seguire?
quello dello script???

NoteBook --> HP 1270EL --> T9600 2.8GHz --> 4Gb RAM --> ATI 4650 OpenSuse 12.1 64_Bit con KDE 4.7.3 (4.7.3) "release 10"

Ritratto di Gollum
Gollum
(Collaboratore)
Offline
Collaboratore
Iscritto: 03/03/2005
Messaggi: 802

Si Gero devi seguire qualla guida la tua scheda la tua scheda è tra quelle citate da Templare.

Desktop DELL XPS8100 => openSUSE_12.2 => KDE 4.10 => Core i7 => 3.4.28-2.20 => Nvidia GT220
Notebook Sony Vaio VPPCA =>openSUSE_12.2 => KDE 4.10 => Core i5 => 3.4.28-2.20 => AMD HD 6470M

Ritratto di Templare
Templare
(Collaboratore)
Offline
Collaboratore
Iscritto: 28/10/2011
Messaggi: 747

Non riesco proprio a spiegarmela questa cosa.

Installo da script, tutto regolare, riavvio, gli effetti funzionano e poi partono i crash. Riavvio in modalità failsafe, vado per disinstallare gli fglrx e non li trovo installati. Li installo e dopo aver fatto un riavvio, tutto funziona regolare.

Proprio non so spiegarmela questa cosa. Ora mi parte anche Savage 2 e Heroes of Newerth

Assemblato 1: Phenom II X4 965 Black Edition + AMD Radeon HD 5770 + Scheda Madre Asus Crosshair IV Formula + Scheda Audio Asus Xonar D2X. Sistema Windows 7 Ultimate 64 Bit
Assemblato 3: Intel Core i3 3220 + nVIDIA Geforce 640 GT. Sistema openSUSE 13.1 64 bit GNOME

Ritratto di Suse98
Suse98
(Guru)
Offline
Guru
Iscritto: 03/10/2010
Messaggi: 1711

Templare ha scritto:

Ora mi parte anche Savage 2 e Heroes of Newerth


Azz !
Ora come li installerò i driver ?
La procedura è quella postata prima ?
Grazie

SUSE LINUX Rilascio 12.3 (Dartmounth) KDE 4.10 && GNOME 3.8

Ritratto di Gero
Gero
(Geek)
Offline
Geek
Iscritto: 24/10/2011
Messaggi: 106

ragazzi installati i driver ma adesso come prima mi mancano di driver per il 3D

Produttore:  ATI Technologies Inc
Modello:  ATI MOBILITY RADEON HD 4650
Driver 2D:  fglrx

ho eseguito la guida di quel Tedesco

1. Konsole starten und zu root werden:
# su
 
 
2. Das Skript herunterladen:
# wget http://www.sebastian-siebert.de/downloads/makerpm-ati-11.11.sh
 
 
3. Die Prüfsummendatei herunterladen:
# wget http://www.sebastian-siebert.de/downloads/makerpm-ati-11.11.sh.sha1
 
 
4. Die Prüfsummendatei gegen das Skript prüfen:
# sha1sum -c makerpm-ati-11.11.sh.sha1
Idealerweise sollte folgende Ausgabe erscheinen, andernfalls stimmt etwas mit dem heruntergeladenen Skript nicht:
# makerpm-ati-11.11.sh: OK
 
 
5. Die Rechte des Skriptes ändern und ausführbar machen:
# chown root:root makerpm-ati-11.11.sh && chmod 744 makerpm-ati-11.11.sh
 
 
6. Das Skript mit dem Argument -i ausführen. Das RPM-Package wird im Anschluß automatisch installiert (bzw. aktualisiert).
# ./makerpm-ati-11.11.sh -i
 
Wichtig: Nach der Installation sollte der Computer neugestartet werden.  (Reboot)

ma i driver ati per il 3d nn meli trova... coma mai?

NoteBook --> HP 1270EL --> T9600 2.8GHz --> 4Gb RAM --> ATI 4650 OpenSuse 12.1 64_Bit con KDE 4.7.3 (4.7.3) "release 10"

Ritratto di Templare
Templare
(Collaboratore)
Offline
Collaboratore
Iscritto: 28/10/2011
Messaggi: 747

Gero ha scritto:

ragazzi installati i driver ma adesso come prima mi mancano di driver per il 3D

Produttore:  ATI Technologies Inc
Modello:  ATI MOBILITY RADEON HD 4650
Driver 2D:  fglrx

ho eseguito la guida di quel Tedesco

1. Konsole starten und zu root werden:
# su
 
 
2. Das Skript herunterladen:
# wget http://www.sebastian-siebert.de/downloads/makerpm-ati-11.11.sh
 
 
3. Die Prüfsummendatei herunterladen:
# wget http://www.sebastian-siebert.de/downloads/makerpm-ati-11.11.sh.sha1
 
 
4. Die Prüfsummendatei gegen das Skript prüfen:
# sha1sum -c makerpm-ati-11.11.sh.sha1
Idealerweise sollte folgende Ausgabe erscheinen, andernfalls stimmt etwas mit dem heruntergeladenen Skript nicht:
# makerpm-ati-11.11.sh: OK
 
 
5. Die Rechte des Skriptes ändern und ausführbar machen:
# chown root:root makerpm-ati-11.11.sh && chmod 744 makerpm-ati-11.11.sh
 
 
6. Das Skript mit dem Argument -i ausführen. Das RPM-Package wird im Anschluß automatisch installiert (bzw. aktualisiert).
# ./makerpm-ati-11.11.sh -i
 
Wichtig: Nach der Installation sollte der Computer neugestartet werden.  (Reboot)

ma i driver ati per il 3d nn meli trova... coma mai?

Non avresti dovuto seguire questa guida Gero. La guida l'ho rettificata, leggi meglio. Il passaggio che dovevi seguire è quello dello script.

Una volta fatta tutta l'installazione tramite script, assicuratevi che in gestione pacchetti da yast, siano installati i driver fglrx.

Suse98 ha scritto:

Azz !
Ora come li installerò i driver ?
La procedura è quella postata prima ?
Grazie

E' quella postata prima, più un'occhio di riguardo alla gestione dei pacchetti da YaST per vedere se il pacchetto fglrx è installato (io dopo averlo installato da script, da gestione pacchetti non l'ho trovato installato. Ho selezionato il pacchetto, installato da gestione pacchetti e ora funziona che è una meraviglia.

Assemblato 1: Phenom II X4 965 Black Edition + AMD Radeon HD 5770 + Scheda Madre Asus Crosshair IV Formula + Scheda Audio Asus Xonar D2X. Sistema Windows 7 Ultimate 64 Bit
Assemblato 3: Intel Core i3 3220 + nVIDIA Geforce 640 GT. Sistema openSUSE 13.1 64 bit GNOME

Ritratto di Gero
Gero
(Geek)
Offline
Geek
Iscritto: 24/10/2011
Messaggi: 106

Templare ha scritto:

[
Non avresti dovuto seguire questa guida Gero. La guida l'ho rettificata, leggi meglio. Il passaggio che dovevi seguire è quello dello script.

Una volta fatta tutta l'installazione tramite script, assicuratevi che in gestione pacchetti da yast, siano installati i driver fglrx.

non capisco che devo fare una volta installato con quello sopra ?

come torno indietro come installo i driver perfetti?

NoteBook --> HP 1270EL --> T9600 2.8GHz --> 4Gb RAM --> ATI 4650 OpenSuse 12.1 64_Bit con KDE 4.7.3 (4.7.3) "release 10"

Ritratto di Templare
Templare
(Collaboratore)
Offline
Collaboratore
Iscritto: 28/10/2011
Messaggi: 747

Gero ha scritto:

Templare ha scritto:

[
Non avresti dovuto seguire questa guida Gero. La guida l'ho rettificata, leggi meglio. Il passaggio che dovevi seguire è quello dello script.

Una volta fatta tutta l'installazione tramite script, assicuratevi che in gestione pacchetti da yast, siano installati i driver fglrx.

non capisco che devo fare una volta installato con quello sopra ?

come torno indietro come installo i driver perfetti?

L'ho detto prima come tornare indietro. Devi disinstallare i driver attuali. Altrimenti provi lo stesso a seguire la guida nonostante tu li abbia già.

Assemblato 1: Phenom II X4 965 Black Edition + AMD Radeon HD 5770 + Scheda Madre Asus Crosshair IV Formula + Scheda Audio Asus Xonar D2X. Sistema Windows 7 Ultimate 64 Bit
Assemblato 3: Intel Core i3 3220 + nVIDIA Geforce 640 GT. Sistema openSUSE 13.1 64 bit GNOME