Configurazione mod_proxy_fcgi per Apache 2.4.2

1 risposta [Ultimo messaggio]
Ritratto di Menzo
Menzo
(Newbie)
Offline
Newbie
Iscritto: 06/07/2012
Messaggi: 2

Buonasera a tutti,

sono nuovo nel forum, quindi se non rispetto qualche regola potete segnalarmelo. Avrei bisogno di un'informazione, devo configurare il modulo mod_proxy_fcgi per poter eseguire web application scritte in C++.
Le azioni che ho fatto sono le seguenti:

- Ho installato apache 2.4.2 al path /etc/apache2;
- Nella cartella /etc/apache2/htdocs (che è la Document Root) ho creato una cartella che ho chiamato fcgi-bin;
- Dentro ho inserito un file eseguibile (.bin) derivato dalla compilazione ed esecuzione su Eclipse di una web application di test
scritta in c++;
- Ho caricato sia il module mod_proxy che mod_proxy_fcgi decommentando le relative righe nel file /etc/apache2/conf/httpd.conf nella sezione Load Module;
-Per far sì che tutti i file binari inseriti nella cartella fcgi-bin vengano eseguiti dal modulo mod_proxy_fastcgi ho inserito la seguente sezione nel file /etc/apache2/conf/httpd.conf (dopo aver letto un pò di documentazione da internet):

AddHandler fcgi-script .bin .exe
Options +ExecCGI

- Ho restartato apache

Risultato: non funge

Qualche suggerimento???

Menzo

Ritratto di Menzo
Menzo
(Newbie)
Offline
Newbie
Iscritto: 06/07/2012
Messaggi: 2

Ho letto la documentazione da qui
http://httpd.apache.org/docs/2.4/mod/mod_proxy_fcgi.html
e sembra tutto semplicissimo. I passi da fare sono:

- inserire nella cartella /etc/apache2/htdocs/fcgi-bin (/etc/apache2/htdocs è la DocumentRoot di Apache) il file binario ProvaFCGI in uscita dalla compilazione di Eclipse (testato con successo anche da shell, lanciando l'eseguibile);

- modificare così il file di configurazione di apache:

LoadModule proxy_module modules/mod_proxy.so
LoadModule proxy_fcgi_module modules/mod_proxy_fcgi.so

Alias /myapp/ "/etc/apache2/htdocs/fcgi-bin/"

ProxyPass /myapp/* fcgi://localhost:40000/
AddHandler fcgi-script .exe .bin

- andare da browser Firefox ed editare: http://localhost:80/myapp/ProvaFCGI

Anzichè farmi partire l'applicazione di prova, mi da il seguente messaggio:

"You have chosen to open
Prova FCGI
which is a file BIN
from: localhost

SAVE CANCEL"

Dovrebbe aprirlo automaticamente, glielo sto dicendo nel file di configurazione di Apache??? Perchè non lo fa??? Nessuno ha mai configurato questo modulo, sto impazzendo da tre giorni. Su internet non si trova molto. Ringrazio quanti mi aiuteranno.