Info installazione Lamp non corretta

Nessuna risposta
Ritratto di Appass_maturo
Appass_maturo
(Junior)
Offline
Junior
Iscritto: 29/12/2019
Messaggi: 17

Buonasera a tutti, perdonatemi, anch'io non ho grande esperienza nella configurazione di un server Lamp per ospitare il mio sito didattico; credo di aver commesso degli errori banali, provo a riassumervi ciò che ho fatto:

la mia idea sarebbe stata quella di installare il server Lamp, in modo da procedere all'installazione di Wordpress, tutto in locale e fare delle prove per la costruzione di un sito di ricette.

Ho provato ad installare il tutto da Yast, ma non avendo grande dimestichezza con questo strumento, sono tornato al terminale seguendo la seguente guida e apportando le seguenti modifiche:

1) sudo zypper install apache2;

Per avviare Apache2 ho digitato:
sudo systemctl start Apache2;

Per far partire partire automaticamente all'avvio, il server ho digitato:
sudo system ctl enable apache2;

Ho creato il seguente file di test, utilizzando emacs, non conosco molto bene vi e nano:

sudo sh -c 'cat > /srv/www.htdocs/index.html <

Welcome to Apache2 on openSuse

Welcome to Apache2 on openSuse.

EOF'

Effettuando la verifica andando con il mio browser su: http://localhost è stata ok.

Non sono riuscito ancora ad aprire "al mondo", in quanto so che devo configurare il firewall per questo, quindi per il servizio http, mi consigliate in questo caso, di utilizzare Yast?

PHP7
sudo zypper install php7 php7-mysql apache2-mod_php7

Ho riavviato il server con:
sudo systemctl restart apache2

Ho creato il seguente file di test:
sudo sh -c 'cat > /srv/www/htdocs/phpinfo.php <