localhost/~nomeutente/: non riesco ad accedere alle sottocartelle

2 risposte [Ultimo messaggio]
Ritratto di kikko
kikko
(Junior)
Offline
Junior
Iscritto: 09/04/2008
Messaggi: 34

Salve
Da pochi mesi ho installato opensuse 10.2 su un vecchio Athon 1700. Lo uso stabilmente, al punto da non utilizzare più Windows, in un laptop duel core molto più recente.

Vengo al punto: ho installato apache, PHP5 e Mysql via Yast, per testare siti in locale. Il server funziona (compare la scritta It works!), anche per la cartella dell'utente public_html, nel mio caso enrico: http://localhost/~enrico/. Funziona anche il php: ho inserito per controllare un php info nella public_html e funziona.

Il problema è quando creo una sottocartella: non la vedo. Ho provato a copiare il file index.html che c'è nella directori public_html ed il file php info: il risultato è il medesimo: errore 500.

Immagino (da niubbo) si tratti di un problema di permessi. Qualcuno può darmi ragguagli per favore?
Grazie in anticipo

openSUSE 12.2 (x86_64), KDE: 4.8.5 "release 2", AMD Athlon(tm) 64 X2 Dual Core Processor 6000+ GeForce 7300 SE

Ritratto di anubis
anubis
(Guru)
Offline
Guru
Iscritto: 07/04/2007
Messaggi: 3656

infatti si tratta di permessi.

molto probabilmente hai messo i permessi in 760 oppure in 660, prova a dare 664 o 764 in base a quelli che già ci sono

OpenSUSE Member,Packman Packager, Education Project Admin, LXDE Project Admin
Powered by http://en.opensuse.org/HP_Pavilion_dv6855el

Ritratto di kikko
kikko
(Junior)
Offline
Junior
Iscritto: 09/04/2008
Messaggi: 34

Scusate, ho capito perché non accedevo: il file htaccess

Mentre controllavo - di nuovo - i permessi, secondo il suggerimento di Anubis - grazie - mi è caduto l'occhio sul file htaccess, che correda il filesystem di Drupal (il cms che volevo installare). Per scrupolo l'ho rinominato e la sottocartella è ora accessibile.

Ora devo capire il perché...

MI scuso per avervi distubato per nulla, ma non ci avevo proprio pensato. E, del resto, è la prima volta che gestisco un server in locale.

Sorry again

openSUSE 12.2 (x86_64), KDE: 4.8.5 "release 2", AMD Athlon(tm) 64 X2 Dual Core Processor 6000+ GeForce 7300 SE