Configurazione firewall per SAMBA

8 risposte [Ultimo messaggio]
Ritratto di subbustrato
subbustrato
(Junior)
Offline
Junior
Iscritto: 17/05/2006
Messaggi: 39

Mi aiutate a configurare il firewall per samba??
Grazie,ciao!!

Ritratto di ap1978
ap1978
(Guru)
Offline
Guru
Iscritto: 01/10/2004
Messaggi: 2972

Quando fai una domanda, riporta la versione di SuSE che stai usando, che è indispensabile per sapere come risponderti.

Ti rispondo supponendo che tu stia usando SuSE 10.1:

- Apri le porte nel firewall quando Samba Server in Yast ti propone l'opzione.

- Modifica /etc/sysconfig/SuSEfirewall2 in modo che l'istruzione FW_SERVICES_ACCEPT_EXT sia come la seguente:

FW_SERVICES_ACCEPT_EXT="0/0,tcp,1024:65535,137:139 0/0,udp,1024:65535,137:139"

- Riavvia il firewall.

- Ripeti su tutte le workstation SuSE.

Ciao

ap Big Grin

Ritratto di subbustrato
subbustrato
(Junior)
Offline
Junior
Iscritto: 17/05/2006
Messaggi: 39

Daccordo,scusami....
la tua supposizione era esatta (suse 10.1),ho fatto quello che mi hai detto,solo che non riesco ancora a navigare nella mie risorse condivise,a meno di disattivare il firewall ovviamente...
per ora ti ringrazio,se magari hai qualche altro consiglio sono tutto orecchie...
CIAOOOO!! Wink

Ritratto di ap1978
ap1978
(Guru)
Offline
Guru
Iscritto: 01/10/2004
Messaggi: 2972

Quote:

subbustrato ha scritto:
Daccordo,scusami....
la tua supposizione era esatta (suse 10.1),ho fatto quello che mi hai detto,solo che non riesco ancora a navigare nella mie risorse condivise,a meno di disattivare il firewall ovviamente...
per ora ti ringrazio,se magari hai qualche altro consiglio sono tutto orecchie...
CIAOOOO!! Wink

E' strano. L'unico ostacolo che potevi avere era quello. Il firewall di SuSE, se hai fatto quello che ti ho detto, non dovrebbe crearti problemi.

Non vedi nessuna risorsa condivisa?
Riesci a visualizzare il PC in rete locale da Linux?

Ciao

ap Big Grin

Ritratto di subbustrato
subbustrato
(Junior)
Offline
Junior
Iscritto: 17/05/2006
Messaggi: 39

Se il firewall è attivo appena clicco sull'icona "navigazione rete locale" mi spara fuori un errore che dice potrebbe essere dovuto al firewall...non solo non vedo risorse condivise,ma neppure il mio gruppo di lavoro

Ritratto di ap1978
ap1978
(Guru)
Offline
Guru
Iscritto: 01/10/2004
Messaggi: 2972

Ricontrolla le impostazioni di SuSEfirewall, probabilmente hai commesso qualche errore nella configurazione.
In Yast->Sicurezza e utenti -> Firewall, devi vedere consentita l'interfaccia "Server samba", oltre ad aver messo la riga che ti ho detto.

Inoltre, hai configurato samba client in Yast in modo da usare il tuo gruppo di lavoro?

Quale PC funge da domain controller nella tua rete locale? Samba o Windows?

Ciao

ap Big Grin

Ritratto di subbustrato
subbustrato
(Junior)
Offline
Junior
Iscritto: 17/05/2006
Messaggi: 39

SAMBA è impostato come primary domain controller,e il gruppo di lavoro è impostato correttamente.....
Ho notato che se mi connetto alla mia rete locale tramite cavo (prima mi connettevo con la scheda di rete wireless),vedo il mio gruppo di lavoro,e come unico membro del gruppo vedo la macchina Linux....Diciamo che via cavo va un po' meglio,anche se il problema persiste.

Ritratto di ap1978
ap1978
(Guru)
Offline
Guru
Iscritto: 01/10/2004
Messaggi: 2972

Quote:

subbustrato ha scritto:
SAMBA è impostato come primary domain controller,e il gruppo di lavoro è impostato correttamente.....
Ho notato che se mi connetto alla mia rete locale tramite cavo (prima mi connettevo con la scheda di rete wireless),vedo il mio gruppo di lavoro,e come unico membro del gruppo vedo la macchina Linux....Diciamo che via cavo va un po' meglio,anche se il problema persiste.

Puoi inviarmi via e-mail il tuo file /etc/sysconfig/SuSEfirewall2, così ci do un'occhiata.

Ciao

ap Big Grin

Ritratto di subbustrato
subbustrato
(Junior)
Offline
Junior
Iscritto: 17/05/2006
Messaggi: 39

La mail te la invio volentieri,ma qual'è il tuo indirizzo??
(magari nella mail ci allego anche una birra per tutti gli sbattimenti che ti stai facendo Wink )
CIAOOOOOOOOO