Verifica MySql, funziona o no?

4 risposte [Ultimo messaggio]
Ritratto di franco_da_vc
franco_da_vc
(Monster)
Offline
Monster
Iscritto: 22/05/2008
Messaggi: 282

Ho installato sul mio nuovo sistem, (suse 13.1) Lamp, ma non so se Mysql si è installato bene.

Il problema è che il database mi serve per far funzionare il cms Joomla, purtroppo quando arrivo alla creazione delle tabelle di gestione ottengo un messaggio di errore che mi dice di che non riesce a connettersi con il database.

Spulciando nei vari post ho trovato un comando che dovrebbe dare un responso sulla funzionalità di mysql, io ottengo semplicemente

Citazione:


Franco@linux-8c5e:~> mysql -u root -p
Enter password:
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysql/mysql.sock' (2)

Devo ritenere che oltre ad installarlo dovrei prima configurarlo? E se si quale può essere il configuratore?

In effetti joomla tra i dati che chiede per creare il database di gestione vi è anche la password, io però ho sempre creduto che il database ricevesse la password dal cms e che quella password fosse relativa alle tabelle stesse.

C'è qualcuno che può darmi qualche spunto? non è che c'è solo qualcosa di male installato?

Attendo vostre risposte e vi ringrazio.

Bye by AFo

Ritratto di pinquadr
pinquadr
(Guru)
Offline
Guru
Iscritto: 20/11/2004
Messaggi: 921

Forse la causa è banale: il servizio mysql non viene avviato automaticamente. Vai in Yast>Sistema>Gestore dei servizi e controlla la voce mysql.

OpenSuse Leap42 con KDE5 su Intel I7 4930K scheda madre Asus Sabertooth X79 - RAM 32 Gb - scheda video NVIDIA GTX660 1GB - scheda TV Hauppauge WinTV Nova T stick

Ritratto di Arin
Arin
(Junior)
Offline
Junior
Iscritto: 18/11/2009
Messaggi: 44

ciao Franco,
1. prima vedi su yast se hai installati: mysql-client, mysql-server, mysql-tool, mysql-bench.

2. vai poi su sistema > gestione dei servizi > runlevel5

3.
se è disabilitato clicca su enable
se anche inattivo clicca poi su start

4. su terminale come root digita "mysql_secure_installation", lì risponderai i vari quesiti per configurare password e altri semplici parametri con yes

Ritratto di franco_da_vc
franco_da_vc
(Monster)
Offline
Monster
Iscritto: 22/05/2008
Messaggi: 282

Ottimo! avete centrato proprio i problemi che mi afliggevano:

Arin ha scritto:

1. prima vedi su yast se hai installati: mysql-client, mysql-server, mysql-tool, mysql-bench.

In effetti il client ed il server erano caricati anche se il nome è variato in mysql-community-server e così di seguito per gli altri pacchetti, diversamente i secondi due non li avevo inseriti.
Oltre a questi quattro file ne ho caricati all'installazione del sistema altri: libmysqlclient18, libmysqld18 e mariadb-errormessages; non vorrei aver caricato dei componenti che poi si dovessero dimostrare dannosi per il mio uso.

Arin ha scritto:

2. vai poi su sistema > gestione dei servizi > runlevel5
3. se è disabilitato clicca su enable - se anche inattivo clicca poi su start

Questo proprio non lo sapevo e devo ringraziare sia te che Pinquadr per avermelo suggerito, erano proprio disabilitato e inattivo

Arin ha scritto:

4. su terminale come root digita "mysql_secure_installation", lì risponderai i vari quesiti per configurare password e altri semplici parametri con yes

Anche questo fatto ed è stato veramente semplice, MySql sembra funzionare a dovere ed io ho gia integrato il tutto con Joomla che è partito tranquillamente, mi resta solo da testare se MyPhpAdmin funziona, però non lo farò stasera.

Spero di non dover fare ulteriori post anche per quest'ultima attività.

Per ora ciao e grazie

Bye by AFo

Ritratto di alex87alex
alex87alex
(Newbie)
Offline
Newbie
Iscritto: 28/01/2009
Messaggi: 3

http://localhost/phpMyAdmin Day Dreaming