Aggiornamento driver nvidia su 11.2 [Risolto]

2 risposte [Ultimo messaggio]
Ritratto di geppetto
geppetto
(Junior)
Offline
Junior
Iscritto: 01/10/2008
Messaggi: 48

Ciao a tutti. Mi serve un aiuto
Oggi mi è successo un problema. Tramite yast ho aggiornato i pacchetti installati e si è aggiornato anche il driver della scheda video Nvidia.
In seguito a questo aggiornamento in driver non funziona più.
Io uso openSuse 11.2 e il driver che si è installate è 195.36.31_2.6.365_0.1-11.1-x86_64.

In fase di installazione mi è uscito questo:

--------------------------------------------------------------------------------------------------------
Switching the use"nv" driver of X.Org tn "nvidia" driver of NVIDIA
--------------------------------------------------------------------------------------------------------

SaX2 generated xorg.conf not available
Warning! MD5DIR is not set: your probably called this script outside SuSEconfig...!
Using MD5DIR="/var/adm/SuSEconfig/md5"...
No change for /etc/X11/xdm/Xservers
No change for /etc/X11/xdn/xdm-config

Grazie in anticipo

Ritratto di deckard
deckard (non verificato)
()

Non saprei di preciso, però farei così:

* guarderei se nella cartella /etc/X11/ c'è il file xorg.conf.
* se non c'è, ma c'è qualcosa di simile tipo xorg.conf.backup, lo rinominerei a xorg.conf (lo puoi fare da root)
* lancerei da una shell di root il programma nvidia-settings e gli farei salvare un nuovo xorg.conf

Una avvertenza: il computer boota senza xorg.conf, ma se questo esiste ed è malformato secondo me crea problemi. Per questo questa operazione potrebbe esser pericolosa. Nel caso ci fossero problemi, apri una shell di root e dai questo comando:

mv /etc/X11/xorg.conf /etc/X11/xorg.conf.corrotto

e riavvia con:

reboot

Bye

Ps: aggiorna anche i driver nvidia per sicurezza

Ritratto di geppetto
geppetto
(Junior)
Offline
Junior
Iscritto: 01/10/2008
Messaggi: 48

Per qualche motivo che non ho le competenze per scoprirlo, il driver nvidia 195.36.31_2.6.365_0.1-11.1-x86_64 non va d'accordo con il kernel-desktop 2.6.31.15-0.1.1

Con il Kernel-dektop 2.6.31.5-0.1.1 tutto funziona correttamente.

Ciao Bruno