Caricare i driver video alla partenza

3 risposte [Ultimo messaggio]
Ritratto di Poalo73
Poalo73
(Junior)
Offline
Junior
Iscritto: 12/11/2015
Messaggi: 40

Ciao, come dicevo qui, alcuni giorni fa ho avuto un problema di installazione, che ho risolto con l'opzione "nomodeset". Quindi, forse ovviamente, i driver video radeon non vengono caricati, e la è a risoluzione 800x600, non modificabile da Impostazioni di sistema.

Se però da Konsole digito:

sudo modprobe radeon modeset=1

lo schermo diventa improvvisamente nero e dopo alcuni secondi mi si presenta la schermata di login, ma quando entro la grafica è ok. Questo però dura solo fino al prossimo riavvio, quando si ritorna al punto di partenza...

Ho provato a creare un file:

/etc/modules-load.d/radeon.conf

con contenuto "radeon" (senza ""), ma niente.

Vi chiedo quindi come fare a caricare questo modulo alla partenza.

Grazie.

Opensuse Leap 42.3/Tumbleweeed
Squadra di traduzione di KDE
AMD Athlon X2-Athlon II-E1

Ritratto di gi-gi
gi-gi
(Moderatore)
Offline
Moderatore
Iscritto: 09/12/2014
Messaggi: 417

Ciao.

Per forzare il caricamento di un modulo (driver) del kernel apri YaST --> Sistema --> Editor di /etc/sysconfig poi spostati in Network --> Firewall --> SuSEfirewall2 --> FW_LOAD_MODULES e nel campo "Impostazione di FW_LOAD_MODULES:" scrivi radeon (se hai più moduli da caricare separali da uno spazio).

Per verificare che il caricamento sia avvenuto lancia Konsole e poi il comando

lsmod | (for i in $(seq 1); do read -r; printf "%s\n" "$REPLY"; done; sort)

Verifica nell'elenco che compare in ordine alfabetico che sia presente la voce radeon

gigi

Ritratto di Poalo73
Poalo73
(Junior)
Offline
Junior
Iscritto: 12/11/2015
Messaggi: 40

Grazie per la risposta, ma purtroppo non funziona (in effetti digitando quel comando il modulo non compare...): per inciso, nella casella di testo c'era già una voce, e io ho aggiunto la mia facendola precedere da un o spazio.

Spulciando tra i vari messaggi del journal però si legge "vgacon disable radeon kernel modesetting" e "no ums support in radeon module" che, se ho ben capito, derivano dal parametro che ho dovuto usare per l'installazione. Il problema è però che non ho capito cosa posso fare...

Opensuse Leap 42.3/Tumbleweeed
Squadra di traduzione di KDE
AMD Athlon X2-Athlon II-E1

Ritratto di Poalo73
Poalo73
(Junior)
Offline
Junior
Iscritto: 12/11/2015
Messaggi: 40

Risolto:

YaST --> Sistema --> Boot Loader --> Scheda "Parametri kernel": bisogna rimuovere l'iniziale "nomodeset" (ovviamente senza "") dalla casella "Parametro facoltativo della riga di comando del kernel" e dare OK. A quel punto viene ricreato initrd (credo Confused ), e dopo il riavvio tutto ok.

Opensuse Leap 42.3/Tumbleweeed
Squadra di traduzione di KDE
AMD Athlon X2-Athlon II-E1