configurazione lettore tessera sanitaria su gnome 13.1

Ritratto di paolomolino
paolomolino
(Monster)
Offline
Monster
Iscritto: 04/08/2011
Messaggi: 442

eccole, comunque dopo il tutto per far funzionare ci vuole sempre un riavvio di firefox

Immagini allegate:

Processore: Intel Pentium G3220 3.0Ghz Dual-core
RAM: 8 Gigabyte Kingston So su memoria solida Kingston120 gb
Scheda Video: Intel HD Graphics Haswell
Sistema operativo: openSUSE leap 42.1 64 bit GNOME

Ritratto di mauriziod
mauriziod
(Guru)
Offline
Guru
Iscritto: 01/06/2009
Messaggi: 1704

Ma come cavolo funzione con quel percorso??????????
/home/paolo/usr/local/lib/libcardos11.so

Nerd

AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAHHHHHHHHHHHHHHHHHHHHHHHHH capisco adesso cosa combinasti!!!!!!!!!!!!!!!!!!!!!
Laughing

Scompattasti il file sotto Home tua e non alla radice!!!

Bene..

Chiudi Firefox e da terminale:

  su
  (digita la tua password)
  cp -rv /home/paolo/usr/ /
  (Attenzione si scrive "cp -rv /home/paolo/usr/ /" e NON "cp -rv /home/paolo/usr//")
  exit
  (qui si chiude il terminale)
 

Poi su Firefox metti il percorso (adesso c'è):
/usr/local/lib/libcardos11.so

Adesso dovrebbe funzionare!!!

Pero mi dici,per essere sicuri del tutto che cartelle avresti in /home/paolo/ ?

SO: Linux desktop Sistema: OpenSUSE Leap 15.1 (64bit) KDEE 5.12
SO: Linux desktop Sistema: OpenSUSE Tumbleweed (64bit) KDE 5
Miao

Ritratto di paolomolino
paolomolino
(Monster)
Offline
Monster
Iscritto: 04/08/2011
Messaggi: 442

allora la faccenda si fa sempre più interessante.
ho0 fatto quello che mi hai detto, quando vado a caricare il modulo, mi dice che il modulo è già presente. Non solo. Quando attacco lo smartcard reader devo:
1) da terminale come superutente fare ldconfig
2) dopodichè andare su qui https://servizi.arubapec.it/crtest/showcert.php
3) al che mi legge la carta correttamente ma non mi fa accedere e mi dice la solita frasetta "nessun lettore o carta rilevati ecc."

se non vfaccio ld config e se non riavvio firefox, non mi considera la carta. In allegato la schermata della mia home, spero che sia quello di cui avevi bisogno te...

Immagini allegate:

Processore: Intel Pentium G3220 3.0Ghz Dual-core
RAM: 8 Gigabyte Kingston So su memoria solida Kingston120 gb
Scheda Video: Intel HD Graphics Haswell
Sistema operativo: openSUSE leap 42.1 64 bit GNOME

Ritratto di mauriziod
mauriziod
(Guru)
Offline
Guru
Iscritto: 01/06/2009
Messaggi: 1704

Dimenticavo fai anche

su
  (digita la tua password)
  cp -rv /home/paolo/etc/ /
  (Attenzione si scrive "cp -rv /home/paolo/etc/ /" e NON "cp -rv /home/paolo/etc//")
  exit
  (qui si chiude il terminale)

poi fai come superutente (si dice root) il ldconfig

Non farti fregare dal tuo browser: Fregatene!!!!! Su Firefox CANCELLALO quel driver e riscrivilo!!! Quella posizione è errata!!!

La posizione giusta è /usr/local/lib e non /home/paolo/eccetera...

SO: Linux desktop Sistema: OpenSUSE Leap 15.1 (64bit) KDEE 5.12
SO: Linux desktop Sistema: OpenSUSE Tumbleweed (64bit) KDE 5
Miao

Ritratto di paolomolino
paolomolino
(Monster)
Offline
Monster
Iscritto: 04/08/2011
Messaggi: 442

piccolo passo in avanti, tutto bene con firefox che ricaricato tutto mi legge correttamente la carta, ma quando vado a fare la login, mi da il solito errore di assenza di smartcard o di carta...se gliela vuoi dare su...lo capisco, sembra impossibile

Processore: Intel Pentium G3220 3.0Ghz Dual-core
RAM: 8 Gigabyte Kingston So su memoria solida Kingston120 gb
Scheda Video: Intel HD Graphics Haswell
Sistema operativo: openSUSE leap 42.1 64 bit GNOME

Ritratto di mauriziod
mauriziod
(Guru)
Offline
Guru
Iscritto: 01/06/2009
Messaggi: 1704

Prova rifare il comando ldconfig!

Ripeto:

Non farti fregare dal tuo browser: Fregatene!!!!! Su Firefox CANCELLALO quel driver e riscrivilo!!!

Quella posizione è errata: La posizione giusta è /usr/local/lib e non /home/paolo/eccetera...

SO: Linux desktop Sistema: OpenSUSE Leap 15.1 (64bit) KDEE 5.12
SO: Linux desktop Sistema: OpenSUSE Tumbleweed (64bit) KDE 5
Miao

Ritratto di paolomolino
paolomolino
(Monster)
Offline
Monster
Iscritto: 04/08/2011
Messaggi: 442

l'ho fatto, tant'è che ora il certificato della carta e la carta stessa nelle opzioni di sicurezza me la da!

Processore: Intel Pentium G3220 3.0Ghz Dual-core
RAM: 8 Gigabyte Kingston So su memoria solida Kingston120 gb
Scheda Video: Intel HD Graphics Haswell
Sistema operativo: openSUSE leap 42.1 64 bit GNOME

Ritratto di mauriziod
mauriziod
(Guru)
Offline
Guru
Iscritto: 01/06/2009
Messaggi: 1704

Bene, prendo per buono che tu lo facesti... Magari è il vecchio pasticcio che da fastidio...

Allora, con Firefox CHIUSO, fai da terminale:

su
 (digita la tua password)
rm /home/paolo/etc/
rm /home/paolo/usr/
ldconfig
exit
 (qui si chiude il terminale)

Riprova...

SO: Linux desktop Sistema: OpenSUSE Leap 15.1 (64bit) KDEE 5.12
SO: Linux desktop Sistema: OpenSUSE Tumbleweed (64bit) KDE 5
Miao

Ritratto di paolomolino
paolomolino
(Monster)
Offline
Monster
Iscritto: 04/08/2011
Messaggi: 442

guarda qua che mi dice

paolo@linux-7urs:~> su
Password: 
linux-7urs:/home/paolo # rm /home/paolo/etc/
rm: impossibile rimuovere "/home/paolo/etc/": È una directory
linux-7urs:/home/paolo # rm /home/paolo/usr/
rm: impossibile rimuovere "/home/paolo/usr/": È una directory
linux-7urs:/home/paolo # ldconfig
linux-7urs:/home/paolo # exit
exit
paolo@linux-7urs:~> pcsc_scan -n
PC/SC device scanner
V 1.4.18 (c) 2001-2011, Ludovic Rousseau <ludovic.rousseau@free.fr>
Compiled with PC/SC lite version: 1.8.8
Using reader plug'n play mechanism
Scanning present readers...
0: ACS ACR38U-CCID 00 00
 
Sat Jun 15 20:34:24 2013
Reader 0: ACS ACR38U-CCID 00 00
  Card state: Card removed, 
 
Sat Jun 15 20:35:30 2013
Reader 0: ACS ACR38U-CCID 00 00
  Card state: Card inserted, 
  ATR: 3B DF 18 00 81 31 FE 7D 00 6B 15 0C 01 81 01 11 01 43 4E 53 10 31 80 E8
pcsc_scan -n

Immagini allegate:

Processore: Intel Pentium G3220 3.0Ghz Dual-core
RAM: 8 Gigabyte Kingston So su memoria solida Kingston120 gb
Scheda Video: Intel HD Graphics Haswell
Sistema operativo: openSUSE leap 42.1 64 bit GNOME

Ritratto di paolomolino
paolomolino
(Monster)
Offline
Monster
Iscritto: 04/08/2011
Messaggi: 442

e aggiungo questa schermata per farti vedere che ho caricato il percorso giusto...

Immagini allegate:

Processore: Intel Pentium G3220 3.0Ghz Dual-core
RAM: 8 Gigabyte Kingston So su memoria solida Kingston120 gb
Scheda Video: Intel HD Graphics Haswell
Sistema operativo: openSUSE leap 42.1 64 bit GNOME